summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2022-02-19 16:06:27 +0100
committerPhilipp A2022-02-19 16:06:27 +0100
commit12a218c94da8da81d34c838739f4dcec1d8d316a (patch)
tree3b55bad1f98d1b3cb3c0e6b13ca5269e1dbc2c21
parent0e9e5dbca3085038ca704d7a9c47b03ab2866f48 (diff)
downloadaur-12a218c94da8da81d34c838739f4dcec1d8d316a.tar.gz
build from source
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD22
3 files changed, 18 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8de476f42aad..e732baa5d29a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = python-wheel-inspect
pkgdesc = Extract information from wheels
pkgver = 1.7.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jwodder/wheel-inspect
arch = any
license = MIT
- makedepends = install-wheel-scripts
+ makedepends = python-build
+ makedepends = python-installer
depends = python
depends = python-attrs
depends = python-entry-points-txt
@@ -13,9 +14,7 @@ pkgbase = python-wheel-inspect
depends = python-packaging
depends = python-readme-renderer
depends = python-wheel-filename
- noextract = wheel_inspect-1.7.0-py3-none-any.whl
- source = https://files.pythonhosted.org/packages/py3/w/wheel-inspect/wheel_inspect-1.7.0-py3-none-any.whl
- sha256sums = 69b34de1f4464ddfc76280c4563e4afc644de2c88e3ae6882f030afdad3d73e4
+ source = https://files.pythonhosted.org/packages/source/w/wheel-inspect/wheel-inspect-1.7.0.tar.gz
+ sha256sums = e3a930c841e1d6d233fd2d213ee6ce07e990006a32d73b0f89937b539db26af6
pkgname = python-wheel-inspect
-
diff --git a/.gitignore b/.gitignore
index 4d7ad300862e..1d2dabc4faac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
/src/
/pkg/
-/*.whl
-/*.pkg.tar.xz
+/*.tar.gz
+/*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
index 24835086def1..828e554f159d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,22 @@
_name=wheel-inspect
pkgname=python-$_name
pkgver=1.7.0
-pkgrel=1
+pkgrel=2
pkgdesc='Extract information from wheels'
arch=(any)
url="https://github.com/jwodder/$_name"
license=(MIT)
depends=(python python-attrs python-entry-points-txt python-headerparser python-packaging python-readme-renderer python-wheel-filename)
-makedepends=(install-wheel-scripts)
-_pyarch=py3
-_wheel="${_name/-/_}-$pkgver-$_pyarch-none-any.whl"
-source=("https://files.pythonhosted.org/packages/$_pyarch/${_name::1}/$_name/$_wheel")
-sha256sums=('69b34de1f4464ddfc76280c4563e4afc644de2c88e3ae6882f030afdad3d73e4')
-noextract=("$_wheel")
+makedepends=(python-build python-installer)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('e3a930c841e1d6d233fd2d213ee6ce07e990006a32d73b0f89937b539db26af6')
+
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
package() {
- local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
- mkdir -p "$site"
- unzip "$_wheel" -d "$site"
- install-wheel-scripts --prefix="$pkgdir/usr" "$_wheel"
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}