summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaetan Bisson2023-02-11 11:07:58 -1000
committerGaetan Bisson2023-02-11 11:07:58 -1000
commit12b5a8f779218f318dfa10fdbc01ac7b51d4d02a (patch)
tree363e3f3f85ce26a75286d84a0e3d2709617960b8
parentfdd53105db8352f066d369158154e34bf4519911 (diff)
downloadaur-12b5a8f779218f318dfa10fdbc01ac7b51d4d02a.tar.gz
remove obsolete fix
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--output-jpeg.patch37
3 files changed, 2 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0789d7bbfba3..ebde9c78255b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mupdf-git
pkgdesc = Lightweight PDF, XPS, and E-book viewer
- pkgver = 20230207.1ca88ef11
+ pkgver = 20230210.4ea8f996e
pkgrel = 1
url = https://mupdf.com/
arch = x86_64
@@ -27,13 +27,11 @@ pkgbase = mupdf-git
source = git://git.ghostscript.com/thirdparty-extract.git
source = git://git.ghostscript.com/thirdparty-freeglut.git
source = git://git.ghostscript.com/thirdparty-lcms2.git#branch=lcms2mt
- source = output-jpeg.patch
source = desktop
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = bf9b2349d4adda7118bc32005ade1d52c545dba980765443f2aeba198c2f85df
sha256sums = 3240d4ebda002cb2c4f42cd42793c6160f1701d349d0acb797819dfd10d4fedd
pkgname = mupdf-git
diff --git a/PKGBUILD b/PKGBUILD
index 0ea2b9372960..740f02068a4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=mupdf-git
_pkgname=mupdf
-pkgver=20230207.1ca88ef11
+pkgver=20230210.4ea8f996e
pkgrel=1
pkgdesc='Lightweight PDF, XPS, and E-book viewer'
arch=('x86_64' 'armv7h' 'aarch64')
@@ -16,13 +16,11 @@ source=('git://git.ghostscript.com/mupdf.git'
'git://git.ghostscript.com/thirdparty-extract.git'
'git://git.ghostscript.com/thirdparty-freeglut.git'
'git://git.ghostscript.com/thirdparty-lcms2.git#branch=lcms2mt'
- 'output-jpeg.patch'
'desktop')
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'bf9b2349d4adda7118bc32005ade1d52c545dba980765443f2aeba198c2f85df'
'3240d4ebda002cb2c4f42cd42793c6160f1701d349d0acb797819dfd10d4fedd')
conflicts=("${_pkgname}"{,-gl,-tools})
@@ -35,7 +33,6 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
- patch -p1 -i ../output-jpeg.patch source/fitz/output-jpeg.c
for lib in extract freeglut lcms2; do
rm -fr thirdparty/$lib
cp -a ../thirdparty-$lib thirdparty/$lib
diff --git a/output-jpeg.patch b/output-jpeg.patch
deleted file mode 100644
index 03006b2a7da7..000000000000
--- a/output-jpeg.patch
+++ /dev/null
@@ -1,37 +0,0 @@
---- output-jpeg.c 2023-02-07 12:48:20.328740181 -1000
-+++ output-jpeg.c.new 2023-02-07 12:50:24.268536252 -1000
-@@ -28,10 +28,16 @@
-
- #define JZ_CTX_FROM_CINFO(c) (fz_context *)((c)->client_data)
-
-+static void fz_jpg_mem_init(j_common_ptr cinfo, fz_context *ctx)
-+{
-+ cinfo->client_data = ctx;
-+}
-+
-+#define fz_jpg_mem_term(cinfo)
-+
- #else /* SHARE_JPEG */
-
- typedef void * backing_store_ptr;
--
- #include "jmemcust.h"
-
- #define JZ_CTX_FROM_CINFO(c) (fz_context *)(GET_CUST_MEM_DATA(c)->priv)
-@@ -76,7 +82,7 @@
- }
- }
-
--#endif
-+#endif /* SHARE_JPEG */
-
- #define OUTPUT_BUF_SIZE (16<<10)
-
-@@ -92,6 +98,7 @@
- {
- char msg[JMSG_LENGTH_MAX];
- fz_context *ctx = JZ_CTX_FROM_CINFO(cinfo);
-+
- cinfo->err->format_message(cinfo, msg);
- fz_throw(ctx, FZ_ERROR_GENERIC, "jpeg error: %s", msg);
- }