summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrLi2021-12-26 11:19:09 +0800
committerBrLi2021-12-26 11:19:09 +0800
commit12d34aebfd41155ade1845b2c9da90881b3d788b (patch)
tree58bf55ab05e640ab3b051a773a1e8f1d598a1725
parent30c0b18793ca0a7a1c2136f0bfb41cb3f8c21f2d (diff)
downloadaur-12d34aebfd41155ade1845b2c9da90881b3d788b.tar.gz
updpkg
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 21 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4921a3a03ec9..b0e6a21ca894 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zettlr
pkgdesc = A markdown editor for writing academic texts and taking notes
- pkgver = 2.0.3
+ pkgver = 2.1.0
pkgrel = 1
url = https://www.zettlr.com
arch = x86_64
@@ -8,21 +8,19 @@ pkgbase = zettlr
license = custom
makedepends = git
makedepends = yarn
+ makedepends = nodejs-lts-gallium
depends = electron
- depends = nodejs>=14.0.0
optdepends = pandoc: For exporting to various format
optdepends = texlive-bin: For Latex support
optdepends = ttf-lato: Display output in a more comfortable way
options = !strip
- source = zettlr-2.0.3.tar.gz::https://github.com/Zettlr/Zettlr/archive/v2.0.3.tar.gz
+ source = zettlr-2.1.0.tar.gz::https://github.com/Zettlr/Zettlr/archive/v2.1.0.tar.gz
source = 0001-Do-not-download-pandoc.patch
- source = locales-2.0.3-1.zip::https://github.com/citation-style-language/locales/archive/d5ee85de8e74d4109509014758b6f496a968ff03.zip
- source = chicago-author-date-2.0.3-1.csl::https://github.com/citation-style-language/styles/raw/ccb71844fdafb2b7a48cccb364f4b4c03d3cdce6/chicago-author-date.csl
- source = https://github.com/jgm/pandoc/releases/download/2.16.1/pandoc-2.16.1-linux-amd64.tar.gz
- sha256sums = e3c7b3e12b43c3749ec7ad8b33ed453fcabbf03e9741f817ba093e91fd87a1f5
+ source = locales-2.1.0-1.zip::https://github.com/citation-style-language/locales/archive/c38205618f1a23eb80e8c5f33c8086648ca3874b.zip
+ source = chicago-author-date-2.1.0-1.csl::https://github.com/citation-style-language/styles/raw/ccb71844fdafb2b7a48cccb364f4b4c03d3cdce6/chicago-author-date.csl
+ sha256sums = edbd806804da93db8db7e81551de50bf1ec2a4a115aa8995238a4dd69ab09367
sha256sums = a0fe981dade0ce52be190d8e8a2fd7f6c05c32c7d44d96c63f6f494460d483ef
- sha256sums = 6e6d0ff9e0d62d25606475752a6db8ee6143f735d5c95400b8f55bff523de182
+ sha256sums = 275fc80a391b4002b52182deb12997a1408118b7753977ea69ef5256c6f3ff47
sha256sums = 1455e57b314fd13ba155f4ab93f061e3e6393c13cd0f16380adb9d73614f7930
- sha256sums = 3fe3d42179af289d4f5452b9317d2bc9cd139a4f33a37f68d70e128f1d415aa4
pkgname = zettlr
diff --git a/PKGBUILD b/PKGBUILD
index dd2c8a657ab9..0d4e8dc2b06f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,29 +6,29 @@
_bundle_pandoc=false
pkgname=zettlr
-pkgver=2.0.3
+pkgver=2.1.0
pkgrel=1
pkgdesc="A markdown editor for writing academic texts and taking notes"
arch=('x86_64')
url='https://www.zettlr.com'
license=('GPL' 'custom') # Noted that the icon and name are copyrighted
-depends=(electron 'nodejs>=14.0.0')
-makedepends=(git yarn)
+depends=(electron)
+makedepends=(git yarn nodejs-lts-gallium) # check .github/workflows/build.yml for NODE_VERSION
optdepends=('pandoc: For exporting to various format'
'texlive-bin: For Latex support'
'ttf-lato: Display output in a more comfortable way')
-_csl_locale_commit=d5ee85de8e74d4109509014758b6f496a968ff03 # Oct 20, 2021
+_csl_locale_commit=c38205618f1a23eb80e8c5f33c8086648ca3874b # Dec 23, 2021
_csl_style_commit=ccb71844fdafb2b7a48cccb364f4b4c03d3cdce6 # Sep 19, 2021
-_pandoc_binary_ver=2.16.1 # check scripts/get-pandoc.sh for update
+_pandoc_binary_ver=2.16.2 # check scripts/get-pandoc.sh for update
options=(!strip)
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Zettlr/Zettlr/archive/v${pkgver}.tar.gz"
'0001-Do-not-download-pandoc.patch'
# citation style
"locales-${pkgver}-${pkgrel}.zip::https://github.com/citation-style-language/locales/archive/${_csl_locale_commit}.zip"
"chicago-author-date-${pkgver}-${pkgrel}.csl::https://github.com/citation-style-language/styles/raw/${_csl_style_commit}/chicago-author-date.csl")
-sha256sums=('e3c7b3e12b43c3749ec7ad8b33ed453fcabbf03e9741f817ba093e91fd87a1f5'
+sha256sums=('edbd806804da93db8db7e81551de50bf1ec2a4a115aa8995238a4dd69ab09367'
'a0fe981dade0ce52be190d8e8a2fd7f6c05c32c7d44d96c63f6f494460d483ef'
- '6e6d0ff9e0d62d25606475752a6db8ee6143f735d5c95400b8f55bff523de182'
+ '275fc80a391b4002b52182deb12997a1408118b7753977ea69ef5256c6f3ff47'
'1455e57b314fd13ba155f4ab93f061e3e6393c13cd0f16380adb9d73614f7930')
if ${_bundle_pandoc} ; then
# pandoc binary source
@@ -38,7 +38,8 @@ fi
prepare() {
cd "Zettlr-${pkgver}"
-
+
+ # Use pacman mechanism to download pandoc binary instead of using upstream script
patch -Np1 -i $srcdir/0001-Do-not-download-pandoc.patch
# csl:refresh from package.json
@@ -52,7 +53,7 @@ if ${_bundle_pandoc} ; then
cp "${srcdir}/pandoc-${_pandoc_binary_ver}/bin/pandoc" resources/pandoc-linux-x64
ln -sf pandoc-linux-x64 resources/pandoc
else
- # Using Arch's pandoc, need to fake a link
+ # Using Arch's pandoc, need to fake a link, otherwise npm/yarn complains
ln -sf /usr/bin/pandoc resources/pandoc-linux-x64
ln -sf /usr/bin/pandoc resources/pandoc
fi
@@ -126,7 +127,8 @@ END
"${pkgdir}/usr/share/icons/hicolor/${px}x${px}/apps/Zettlr.png"
done
- # generate freedesktop entry files, aligned with description in package.json and forge.config.js
+ # Generate desktop entry file
+ # Based on descriptions in package.json and forge.config.js
install -Dm644 /dev/stdin "${pkgdir}/usr/share/applications/Zettlr.desktop" <<END
[Desktop Entry]
Name=Zettlr
@@ -140,7 +142,8 @@ MimeType=text/markdown;
Categories=Office;
END
- # generate mimetype configuration file to associate with zettlr
+ # Generate mimetype configuration file to associate with zettlr
+ # Based on electron-builder.yml
install -Dm644 /dev/stdin "${pkgdir}/usr/share/mime/packages/Zettlr.xml" <<END
<?xml version="1.0" encoding="utf-8"?>
<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">