summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoland Suchan2023-11-14 21:12:34 +0100
committerRoland Suchan2023-11-14 21:12:34 +0100
commit12efdf67c29adf67f5ceb39419d27c525e7d3dfb (patch)
tree1cced620d3315daea26becdb8c1b38b3452017b9
parent20c7e48d518c0a7eec8352054a6afe2114481101 (diff)
downloadaur-12efdf67c29adf67f5ceb39419d27c525e7d3dfb.tar.gz
version 2.3.1-13
-rw-r--r--.SRCINFO17
-rw-r--r--CMakeLists.patch45
-rw-r--r--CMakeLists_qrender.patch26
-rw-r--r--PKGBUILD87
-rw-r--r--found_ffmpeg.patch237
-rw-r--r--mathops_fix.patch58
6 files changed, 361 insertions, 109 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e789fd5a32e..4bce01357b4f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,16 @@
pkgbase = qdvdauthor
- pkgdesc = QDVDAuthor is a GUI frontend for dvdauthor, video DVD creator.
+ pkgdesc = A GUI frontend for dvdauthor, video DVD creator.
pkgver = 2.3.1
pkgrel = 13
url = https://sourceforge.net/projects/qdvd
arch = i686
arch = x86_64
license = GPL
- makedepends = cmake
- makedepends = extra-cmake-modules
- depends = qt5-base
- depends = ffmpeg063-static
depends = vlc
depends = xine-lib
- depends = libx11
- provides = qslideshow
- provides = dvd-slideshow
- provides = qrender
- provides = qplayer
source = https://sourceforge.net/projects/qdvd/files/qdvd-2.3.1-qt5/qdvdauthor-2.3.1-013.tar.gz
- source = CMakeLists.patch
- source = CMakeLists_qrender.patch
- md5sums = ce1169060c618e50e07f0272a3b4d282
+ source = found_ffmpeg.patch
+ source = mathops_fix.patch
+ sha256sums = 8170ae54ad380e1265a8da767b8ee1e70d4ede116a61422de24a509e28bc351e
pkgname = qdvdauthor
diff --git a/CMakeLists.patch b/CMakeLists.patch
deleted file mode 100644
index 7feb8b5e22a2..000000000000
--- a/CMakeLists.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-diff -upr ffDiaporama.r0/src/qdvdauthor-2.3.1/CMakeLists.txt ffDiaporama.r1/src/qdvdauthor-2.3.1/CMakeLists.txt
---- qdvdauthor.r0/CMakeLists.txt 2021-08-03 11:23:22.000000000 +0200
-+++ qdvdauthor.r1/CMakeLists.txt 2023-01-19 19:18:03.189089001 +0100
-@@ -262,20 +262,20 @@
- #${FFMPEG_AVCODEC_INCLUDE_DIR}
- #${FFMPEG_AVFORMAT_INCLUDE_DIR}
- #${FFMPEG_SWSCALE_INCLUDE_DIR}
-- ${CMAKE_SOURCE_DIR}/qrender/ffmpeg-0.6.3/include
-+ #${CMAKE_SOURCE_DIR}/qrender/ffmpeg-0.6.3/include
- #/usr/local/include
- #/usr/local/include/ffmpeg063
-- #/usr/include/ffmpeg063
-+ /opt/ffmpeg063/include
- )
- set(FFMPEG_LIBRARIES
- #${FFMPEG_AVCODEC_LIBRARY}
- #${FFMPEG_AVFORMAT_LIBRARY}
- #${FFMPEG_AVUTIL_LIBRARY}
- #${FFMPEG_SWSCALE_LIBRARY}
-- ${CMAKE_SOURCE_DIR}/qrender/ffmpeg-0.6.3/lib/libavcodec.so
-- ${CMAKE_SOURCE_DIR}/qrender/ffmpeg-0.6.3/lib/libavformat.so
-- ${CMAKE_SOURCE_DIR}/qrender/ffmpeg-0.6.3/lib/libavutil.so
-- ${CMAKE_SOURCE_DIR}/qrender/ffmpeg-0.6.3/lib/libswscale.so
-+ #${CMAKE_SOURCE_DIR}/qrender/ffmpeg-0.6.3/lib/libavcodec.so
-+ #${CMAKE_SOURCE_DIR}/qrender/ffmpeg-0.6.3/lib/libavformat.so
-+ #${CMAKE_SOURCE_DIR}/qrender/ffmpeg-0.6.3/lib/libavutil.so
-+ #${CMAKE_SOURCE_DIR}/qrender/ffmpeg-0.6.3/lib/libswscale.so
- #/usr/local/lib64/libavcodec.so
- #/usr/local/lib64/libavformat.so
- #/usr/local/lib64/libavutil.so
-@@ -284,10 +284,10 @@
- #/usr/lib/libavformat.so
- #/usr/lib/libavutil.so
- #/usr/lib/libswscale.so
-- #/usr/local/lib/libavcodec.so
-- #/usr/local/lib/libavformat.so
-- #/usr/local/lib/libavutil.so
-- #/usr/local/lib/libswscale.so
-+ /opt/ffmpeg063/lib/libavcodec.so
-+ /opt/ffmpeg063/lib/libavformat.so
-+ /opt/ffmpeg063/lib/libavutil.so
-+ /opt/ffmpeg063/lib/libswscale.so
- )
- #endif (FFMPEG_FOUND)
-
diff --git a/CMakeLists_qrender.patch b/CMakeLists_qrender.patch
deleted file mode 100644
index f4088c1a2954..000000000000
--- a/CMakeLists_qrender.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff -upr ffDiaporama.r0/src/qdvdauthor-2.3.1/qrender/ffmpeg-0.6.3/CMakeLists.txt ffDiaporama.r1/src/qdvdauthor-2.3.1/qrender/ffmpeg-0.6.3/CMakeLists.txt
---- qdvdauthor.r0/qrender/ffmpeg-0.6.3/CMakeLists.txt 2017-11-25 08:36:00.000000000 +0100
-+++ qdvdauthor.r1/qrender/ffmpeg-0.6.3/CMakeLists.txt 2023-01-19 19:19:07.385087235 +0100
-@@ -1,12 +1,12 @@
- ########### install files ###############
-
--INSTALL(FILES lib/libavcodec.so.52 DESTINATION lib64/)
--INSTALL(FILES lib/libavcodec.so.52.72.2 DESTINATION lib64/)
--INSTALL(FILES lib/libavdevice.so.52 DESTINATION lib64/)
--INSTALL(FILES lib/libavdevice.so.52.2.0 DESTINATION lib64/)
--INSTALL(FILES lib/libavformat.so.52 DESTINATION lib64/)
--INSTALL(FILES lib/libavformat.so.52.64.2 DESTINATION lib64/)
--INSTALL(FILES lib/libavutil.so.50 DESTINATION lib64/)
--INSTALL(FILES lib/libavutil.so.50.15.1 DESTINATION lib64/)
--INSTALL(FILES lib/libswscale.so.0 DESTINATION lib64/)
--INSTALL(FILES lib/libswscale.so.0.11.0 DESTINATION lib64/)
-+#INSTALL(FILES lib/libavcodec.so.52 DESTINATION lib64/)
-+#INSTALL(FILES lib/libavcodec.so.52.72.2 DESTINATION lib64/)
-+#INSTALL(FILES lib/libavdevice.so.52 DESTINATION lib64/)
-+#INSTALL(FILES lib/libavdevice.so.52.2.0 DESTINATION lib64/)
-+#INSTALL(FILES lib/libavformat.so.52 DESTINATION lib64/)
-+#INSTALL(FILES lib/libavformat.so.52.64.2 DESTINATION lib64/)
-+#INSTALL(FILES lib/libavutil.so.50 DESTINATION lib64/)
-+#INSTALL(FILES lib/libavutil.so.50.15.1 DESTINATION lib64/)
-+#INSTALL(FILES lib/libswscale.so.0 DESTINATION lib64/)
-+#INSTALL(FILES lib/libswscale.so.0.11.0 DESTINATION lib64/)
diff --git a/PKGBUILD b/PKGBUILD
index 6582592f15e9..4f35fbcdf11a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,29 @@
pkgname=qdvdauthor
pkgver=2.3.1
-pkgrel=13
-pkgdesc='QDVDAuthor is a GUI frontend for dvdauthor, video DVD creator'
+pkgrel=1
+pkgdesc='A GUI frontend for dvdauthor, video DVD creator'
url='https://sourceforge.net/projects/qdvd'
license=('GPL2')
-arch=('i686' 'x86_64')
-depends=('qt5-base' 'ffmpeg063-static' 'vlc' 'xine-lib' 'libx11')
-makedepends=('cmake' 'extra-cmake-modules')
-conflicts=()
+arch=('x86_64')
+depends=(
+ 'bash'
+ 'gcc-libs' # libgcc_s.so libstdc++.so
+ 'glibc' # libm.so
+ 'qt5-base' # libQt5Core.so libQt5Gui.so libQt5Network.so libQt5PrintSupport.so libQt5Widgets.so libQt5Xml.so
+ 'xine-lib' # libxine.so
+ 'vlc'
+ 'libx11' # libX11.so
+ 'libva' 'libva.so'
+ 'libglvnd' 'libGLX.so' 'libOpenGL.so'
+ 'bzip2' 'libbz2.so'
+ 'zlib' 'libz.so'
+)
+makedepends=(
+ 'qt5-tools'
+ 'cmake'
+ 'extra-cmake-modules'
+)
provides=(
'dvd-slideshow'
'qdvdauthor'
@@ -17,30 +32,52 @@ provides=(
'qslideshow'
'qrender'
)
-options=()
-source=("https://sourceforge.net/projects/qdvd/files/qdvd-2.3.1-qt5/qdvdauthor-${pkgver}-013.tar.gz"
- 'CMakeLists.patch'
- 'CMakeLists_qrender.patch')
-md5sums=('ce1169060c618e50e07f0272a3b4d282'
- 'c9c7641aff17d1f9a299f4ea4fa03c6b'
- '612adb519f1dc94a403740e9c08a9afe')
+source=(
+ "https://sourceforge.net/projects/qdvd/files/qdvd-${pkgver}-qt5/qdvdauthor-${pkgver}-013.tar.gz"
+ 'https://ffmpeg.org/releases/ffmpeg-0.6.7.tar.bz2'
+ 'mathops_fix.patch'
+ 'found_ffmpeg.patch'
+)
+sha256sums=(
+ '8170ae54ad380e1265a8da767b8ee1e70d4ede116a61422de24a509e28bc351e'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+)
+options=('debug')
prepare() {
- cd "$pkgname-$pkgver"
- patch --forward --strip=1 --input="${srcdir}/CMakeLists.patch"
- patch --forward --strip=1 --input="${srcdir}/CMakeLists_qrender.patch"
+ patch -d ffmpeg-0.6.7 -p1 -i "${srcdir}/mathops_fix.patch"
+ patch -d "$pkgname-$pkgver" -p1 -i "${srcdir}/found_ffmpeg.patch"
}
build() {
- cd qdvdauthor-${pkgver}/build
-
- cmake ../. -DCMAKE_INSTALL_PREFIX=/usr
- make clean
- make "-j$(nproc)" || return 1
+ cd ffmpeg-0.6.7
+
+ CFLAGS="${CFLAGS} -Wno-implicit-function-declaration" \
+ ./configure \
+ --prefix="${srcdir}/fakeroot" \
+ --disable-ffmpeg \
+ --disable-ffplay \
+ --disable-ffprobe \
+ --disable-ffserver \
+ --enable-pic \
+ --disable-doc
+
+ make
+ make install
+
+ cd ..
+ export PKG_CONFIG_LIBDIR="${srcdir}/fakeroot/lib/pkgconfig"
+ export PKG_CONFIG_PATH="${PKG_CONFIG_LIBDIR}:/usr/lib/pkgconfig:/usr/share/pkgconfig"
+
+ cmake -S "qdvdauthor-${pkgver}" -B build \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DFFMPEG_DIRS="${srcdir}/fakeroot"
+
+ cmake --build build
}
-
+
package() {
- cd qdvdauthor-${pkgver}/build
-
- make DESTDIR="$pkgdir" install
+ DESTDIR="${pkgdir}" cmake --install build
}
diff --git a/found_ffmpeg.patch b/found_ffmpeg.patch
new file mode 100644
index 000000000000..ab43c42e6553
--- /dev/null
+++ b/found_ffmpeg.patch
@@ -0,0 +1,237 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -126,18 +126,18 @@
+ #FFMPEG_FIND(LIBAVUTIL avutil avutil.h)
+ #FFMPEG_FIND(LIBSWSCALE swscale swscale.h)
+
+-SET(FFMPEG_FOUND "NO")
+-IF (FFMPEG_LIBAVFORMAT_FOUND AND
+-FFMPEG_LIBAVDEVICE_FOUND AND
+-FFMPEG_LIBAVCODEC_FOUND AND
+-FFMPEG_LIBAVUTIL_FOUND AND
+-FFMPEG_LIBSWSCALE_FOUND
+-)
+-ELSE ()
++#SET(FFMPEG_FOUND "NO")
++#IF (FFMPEG_LIBAVFORMAT_FOUND AND
++#FFMPEG_LIBAVDEVICE_FOUND AND
++#FFMPEG_LIBAVCODEC_FOUND AND
++#FFMPEG_LIBAVUTIL_FOUND AND
++#FFMPEG_LIBSWSCALE_FOUND
++#)
++#ELSE ()
+
+-MESSAGE(STATUS "Could not find FFMPEG")
++#MESSAGE(STATUS "Could not find FFMPEG")
+
+-ENDIF()
++#ENDIF()
+
+ # We need add -DQT_WIDGETS_LIB when using QtWidgets in Qt 5.
+ add_definitions(${Qt5Widgets_DEFINITIONS})
+@@ -149,19 +149,19 @@
+ #find_library(AVCODEC_LIBRARY avcodec PATHS /usr/local/lib /usr/lib /usr/lib64 DOC "avcodec library" REQUIRED)
+ #find_library(AVUTIL_LIBRARY avutil PATHS /usr/local/lib /usr/lib /usr/lib64 DOC "avutil library" REQUIRED)
+
+-message(STATUS "Found AVFORMAT: " ${AVFORMAT_LIBRARY}
+-" Found AVCODEC: " ${AVCODEC_LIBRARY}
+-" Found AVUTIL: " ${AVUTIL_LIBRARY}
+-${FFMPEG_LIBRARIES} ${FFMPEG_LIBAVFORMAT_LIBRARIES})
++#message(STATUS "Found AVFORMAT: " ${AVFORMAT_LIBRARY}
++#" Found AVCODEC: " ${AVCODEC_LIBRARY}
++#" Found AVUTIL: " ${AVUTIL_LIBRARY}
++#${FFMPEG_LIBRARIES} ${FFMPEG_LIBAVFORMAT_LIBRARIES})
+
+ #link_directories(${AVFORMAT_LIBRARY} ${AVCODEC_LIBRARY} ${AVUTIL_LIBRARY})
+
+ #find_path(FFMPEG_INCLUDE libavformat/avformat.h PATHS /usr/local/include /usr/include DOC "avformat include path" REQUIRED)
+
+-message(STATUS "Found FFMPEG: " ${FFMPEG_INCLUDE})
++#message(STATUS "Found FFMPEG: " ${FFMPEG_INCLUDE})
+
+ #include_directories(${FFMPEG_INCLUDE})
+-
++#[[
+ SET (FFMPEG_DIRS
+ ${FFMPEG_INCLUDE}
+ ${FFMPEG_INCLUDE}/libavcodec
+@@ -171,7 +171,7 @@
+ ${FFMPEG_INCLUDE}/libavutil
+ ${FFMPEG_INCLUDE}/libavswresample
+ ${FFMPEG_INCLUDE}/libswscale
+- )
++ )]]
+
+ SET (xine_libs
+ xine
+@@ -179,7 +179,7 @@
+
+ #link_directories(${FFMPEG_DIRS})
+
+-message(STATUS "Found FFMPEG_DIRS: " ${FFMPEG_DIRS})
++#message(STATUS "Found FFMPEG_DIRS: " ${FFMPEG_DIRS})
+
+ #add_library(
+ #SDL_ffmpeg
+@@ -193,11 +193,11 @@
+ # PATH_SUFFIXES ffmpeg libavcodec
+ # )
+
+-find_path(FFMPEG_AVCODEC_INCLUDE_DIR
+- NAMES "libavcodec/avcodec.h"
+- PATHS /usr/local/include /usr/include
+- PATH_SUFFIXES "ffmpeg063"
+- )
++#find_path(FFMPEG_AVCODEC_INCLUDE_DIR
++# NAMES "libavcodec/avcodec.h"
++# PATHS /usr/local/include /usr/include
++# PATH_SUFFIXES "ffmpeg063"
++# )
+
+ #find_path(FFMPEG_AVFORMAT_INCLUDE_DIR
+ # NAMES avformat.h
+@@ -216,66 +216,77 @@
+ # PATHS ${_FFMPEG_AVCODEC_LIBRARY_DIRS} /usr/lib /usr/local/lib /opt/local/lib /sw/lib /usr/lib64
+ # )
+
+-find_library(FFMPEG_AVCODEC_LIBRARY
+- NAMES avcodec
+- PATHS /usr/local/lib /usr/local/lib64
+- )
++#find_library(FFMPEG_AVCODEC_LIBRARY
++# NAMES avcodec
++# PATHS /usr/local/lib /usr/local/lib64
++# )
+
+ #find_library(FFMPEG_AVFORMAT_LIBRARY
+ # NAMES avformat
+ # PATHS ${_FFMPEG_AVFORMAT_LIBRARY_DIRS} /usr/lib /usr/local/lib /opt/local/lib /sw/lib /usr/lib64
+ # )
+
+-find_library(FFMPEG_AVFORMAT_LIBRARY
+- NAMES avformat
+- PATHS /usr/local/lib /usr/local/lib64
+- )
++#find_library(FFMPEG_AVFORMAT_LIBRARY
++# NAMES avformat
++# PATHS /usr/local/lib /usr/local/lib64
++# )
+
+-find_library(FFMPEG_AVUTIL_LIBRARY
+- NAMES avutil
+- PATHS /usr/local/lib /usr/local/lib64
+- )
++#find_library(FFMPEG_AVUTIL_LIBRARY
++# NAMES avutil
++# PATHS /usr/local/lib /usr/local/lib64
++# )
+
+ #find_library(FFMPEG_SWSCALE_LIBRARY
+ # NAMES swscale
+ # PATHS ${_FFMPEG_SWSCALE_LIBRARY_DIRS} /usr/lib /usr/local/lib /opt/local/lib /sw/lib /usr/lib64
+ # )
+
+-find_library(FFMPEG_SWSCALE_LIBRARY
+- NAMES swscale
+- PATHS /usr/local/lib /usr/local/lib64
+- )
+-
++#find_library(FFMPEG_SWSCALE_LIBRARY
++# NAMES swscale
++# PATHS /usr/local/lib /usr/local/lib64
++# )
++
++find_package(PkgConfig REQUIRED)
++pkg_check_modules(FFMPEG REQUIRED IMPORTED_TARGET
++ # libavdevice
++ # libavfilter
++ libavformat
++ libavcodec
++ # libswresample
++ libswscale
++ libavutil
++)
+
+-message(STATUS "Found FFMPEG_AVCODEC_LIBRARY: " ${FFMPEG_AVCODEC_LIBRARY})
++#message(STATUS "Found FFMPEG_AVCODEC_LIBRARY: " ${FFMPEG_AVCODEC_LIBRARY})
+ #message(STATUS "Found FFMPEG_AVFORMAT_LIBRARY: " ${FFMPEG_AVFORMAT_LIBRARY})
+ #message(STATUS "Found FFMPEG_SWSCALE_LIBRARY: " ${FFMPEG_SWSCALE_LIBRARY})
+
+-if (FFMPEG_AVCODEC_LIBRARY AND FFMPEG_AVFORMAT_LIBRARY AND FFMPEG_SWSCALE_LIBRARY)
+- set(FFMPEG_FOUND TRUE)
+-endif (FFMPEG_AVCODEC_LIBRARY AND FFMPEG_AVFORMAT_LIBRARY AND FFMPEG_SWSCALE_LIBRARY)
++#if (FFMPEG_AVCODEC_LIBRARY AND FFMPEG_AVFORMAT_LIBRARY AND FFMPEG_SWSCALE_LIBRARY)
++# set(FFMPEG_FOUND TRUE)
++#endif (FFMPEG_AVCODEC_LIBRARY AND FFMPEG_AVFORMAT_LIBRARY AND FFMPEG_SWSCALE_LIBRARY)
+
+-message(STATUS "FFMPEG_FOUND: " ${FFMPEG_FOUND})
++#message(STATUS "FFMPEG_FOUND: " ${FFMPEG_FOUND})
+
+ #if (FFMPEG_FOUND)
+ set(FFMPEG_INCLUDE_DIRS
+- #${FFMPEG_AVCODEC_INCLUDE_DIR}
+- #${FFMPEG_AVFORMAT_INCLUDE_DIR}
+- #${FFMPEG_SWSCALE_INCLUDE_DIR}
+- ${CMAKE_SOURCE_DIR}/qrender/ffmpeg-0.6.3/include
++ ${FFMPEG_AVCODEC_INCLUDE_DIR}
++ ${FFMPEG_AVFORMAT_INCLUDE_DIR}
++ ${FFMPEG_AVUTIL_INCLUDE_DIR}
++ ${FFMPEG_SWSCALE_INCLUDE_DIR}
++ #${CMAKE_SOURCE_DIR}/qrender/ffmpeg-0.6.3/include
+ #/usr/local/include
+ #/usr/local/include/ffmpeg063
+ #/usr/include/ffmpeg063
+ )
+ set(FFMPEG_LIBRARIES
+- #${FFMPEG_AVCODEC_LIBRARY}
+- #${FFMPEG_AVFORMAT_LIBRARY}
+- #${FFMPEG_AVUTIL_LIBRARY}
+- #${FFMPEG_SWSCALE_LIBRARY}
+- ${CMAKE_SOURCE_DIR}/qrender/ffmpeg-0.6.3/lib/libavcodec.so
+- ${CMAKE_SOURCE_DIR}/qrender/ffmpeg-0.6.3/lib/libavformat.so
+- ${CMAKE_SOURCE_DIR}/qrender/ffmpeg-0.6.3/lib/libavutil.so
+- ${CMAKE_SOURCE_DIR}/qrender/ffmpeg-0.6.3/lib/libswscale.so
++ ${FFMPEG_AVCODEC_LIBRARY}
++ ${FFMPEG_AVFORMAT_LIBRARY}
++ ${FFMPEG_AVUTIL_LIBRARY}
++ ${FFMPEG_SWSCALE_LIBRARY}
++ #${CMAKE_SOURCE_DIR}/qrender/ffmpeg-0.6.3/lib/libavcodec.so
++ #${CMAKE_SOURCE_DIR}/qrender/ffmpeg-0.6.3/lib/libavformat.so
++ #${CMAKE_SOURCE_DIR}/qrender/ffmpeg-0.6.3/lib/libavutil.so
++ #${CMAKE_SOURCE_DIR}/qrender/ffmpeg-0.6.3/lib/libswscale.so
+ #/usr/local/lib64/libavcodec.so
+ #/usr/local/lib64/libavformat.so
+ #/usr/local/lib64/libavutil.so
+@@ -291,8 +302,8 @@
+ )
+ #endif (FFMPEG_FOUND)
+
+-message(STATUS "FFMPEG_INCLUDE_DIRS: " ${FFMPEG_INCLUDE_DIRS})
+-message(STATUS "FFMPEG_LIBRARIES: " ${FFMPEG_LIBRARIES})
++#message(STATUS "FFMPEG_INCLUDE_DIRS: " ${FFMPEG_INCLUDE_DIRS})
++#message(STATUS "FFMPEG_LIBRARIES: " ${FFMPEG_LIBRARIES})
+
+ if (FFMPEG_FOUND)
+ if (NOT FFMPEG_FIND_QUIETLY)
+diff --git a/qrender/CMakeLists.txt b/qrender/CMakeLists.txt
+--- a/qrender/CMakeLists.txt
++++ b/qrender/CMakeLists.txt
+@@ -1,7 +1,7 @@
+ project(qrender)
+
+ add_subdirectory(engine)
+-add_subdirectory(ffmpeg-0.6.3)
++#add_subdirectory(ffmpeg-0.6.3)
+
+ SET(qrender_engine_SOURCES
+ ${CMAKE_SOURCE_DIR}/qrender/engine/ffmpeg_enc.cpp
+@@ -55,7 +55,7 @@
+ #TARGET_LINK_LIBRARIES(qrender ${QT_QTCORE_LIBS}) #ooo
+ #TARGET_LINK_LIBRARIES(qrender ${QT_LIBRARIES})
+ #TARGET_LINK_LIBRARIES(qrender ${QT_LIBRARIES} ${FFMPEG_LIBRARIES} ${CMAKE_DL_LIBS} ${QT_QT3SUPPORT_LIBRARY} ${QT_QTXML_LIBRARY} ${QT_QTGUI_LIBRARY} ${QT_QTCORE_LIBRARY} ${QT_QTNETWORK_LIBRARY} ${xine_libs} X11)
+-TARGET_LINK_LIBRARIES(qrender Qt5::Widgets Qt5::Xml xine X11 Qt5::Network ${FFMPEG_LIBRARIES})
++TARGET_LINK_LIBRARIES(qrender Qt5::Widgets Qt5::Xml xine X11 Qt5::Network PkgConfig::FFMPEG)
+ #link_directories(${FFMPEG_LIBRARIES})
+ message(STATUS "Found qrender*:")
+
diff --git a/mathops_fix.patch b/mathops_fix.patch
new file mode 100644
index 000000000000..5e6c355a7ca9
--- /dev/null
+++ b/mathops_fix.patch
@@ -0,0 +1,58 @@
+diff --git a/libavcodec/x86/mathops.h b/libavcodec/x86/mathops.h
+index 5949dfe..29ea584 100644
+--- a/libavcodec/x86/mathops.h
++++ b/libavcodec/x86/mathops.h
+@@ -28,10 +28,18 @@
+ #if ARCH_X86_32
+ #define MULL(ra, rb, shift) \
+ ({ int rt, dummy; __asm__ (\
++ if (__builtin_constant_p(shift))
+ "imull %3 \n\t"\
+ "shrdl %4, %%edx, %%eax \n\t"\
+ : "=a"(rt), "=d"(dummy)\
+- : "a" ((int)(ra)), "rm" ((int)(rb)), "i"(shift));\
++ :"a"(a), "rm"(b), "i"(shift & 0x1F)
++ else
++ __asm__ (
++ "imull %3 \n\t"
++ "shrdl %4, %%edx, %%eax \n\t"
++ :"=a"(rt), "=d"(dummy)
++ :"a"(a), "rm"(b), "c"((uint8_t)shift)
++ );
+ rt; })
+
+ #define MULH(ra, rb) \
+@@ -81,19 +89,31 @@ __asm__ volatile(\
+ // avoid +32 for shift optimization (gcc should do that ...)
+ #define NEG_SSR32 NEG_SSR32
+ static inline int32_t NEG_SSR32( int32_t a, int8_t s){
++ if (__builtin_constant_p(s))
+ __asm__ ("sarl %1, %0\n\t"
+ : "+r" (a)
+- : "ic" ((uint8_t)(-s))
++ : "i" (-s & 0x1F)
+ );
++ else
++ __asm__ ("sarl %1, %0\n\t"
++ : "+r" (a)
++ : "c" ((uint8_t)(-s))
++ );
+ return a;
+ }
+
+ #define NEG_USR32 NEG_USR32
+ static inline uint32_t NEG_USR32(uint32_t a, int8_t s){
++ if (__builtin_constant_p(s))
+ __asm__ ("shrl %1, %0\n\t"
+ : "+r" (a)
+- : "ic" ((uint8_t)(-s))
++ : "i" (-s & 0x1F)
+ );
++ else
++ __asm__ ("shrl %1, %0\n\t"
++ : "+r" (a)
++ : "c" ((uint8_t)(-s))
++ );
+ return a;
+ }
+