summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarc Aldorasi2015-06-27 17:41:14 -0400
committerMarc Aldorasi2015-06-27 17:41:14 -0400
commit12f0519d0a9d8f6773c87ef4165f6a5cdc24093a (patch)
tree53cf7930d1691db986b2c12a2df0eba5097114ac
downloadaur-12f0519d0a9d8f6773c87ef4165f6a5cdc24093a.tar.gz
Moved from old AUR
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD57
-rw-r--r--lib32-swh-plugins.install9
-rw-r--r--mbeq_crash_fix.patch39
4 files changed, 124 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7015f08a905a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = lib32-swh-plugins
+ pkgdesc = Steve Harris' LADSPA plug-ins suite
+ pkgver = 0.4.15
+ pkgrel = 6
+ url = http://plugin.org.uk/
+ install = lib32-swh-plugins.install
+ arch = x86_64
+ license = GPL
+ makedepends = lib32-libxml2
+ makedepends = perl-xml-parser
+ depends = lib32-fftw
+ depends = lib32-ladspa
+ source = http://plugin.org.uk/releases/0.4.15/swh-plugins-0.4.15.tar.gz
+ source = mbeq_crash_fix.patch
+ md5sums = 2fbdccef2462ea553901acd429fa3573
+ md5sums = a60422c8dea95bee6f9adcdc70dff7e0
+
+pkgname = lib32-swh-plugins
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..97852dd429fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# $Id$
+# Maintainer: Marc Aldorasi <m101010a at gmail dot com>
+
+_pkgbasename=swh-plugins
+pkgname=lib32-$_pkgbasename
+pkgver=0.4.15
+pkgrel=6
+pkgdesc="Steve Harris' LADSPA plug-ins suite"
+arch=('x86_64')
+url="http://plugin.org.uk/"
+license=('GPL')
+install=lib32-swh-plugins.install
+depends=('lib32-fftw' 'lib32-ladspa')
+makedepends=('lib32-libxml2' 'perl-xml-parser')
+source=("http://plugin.org.uk/releases/$pkgver/$_pkgbasename-$pkgver.tar.gz"
+ 'mbeq_crash_fix.patch')
+md5sums=('2fbdccef2462ea553901acd429fa3573'
+ 'a60422c8dea95bee6f9adcdc70dff7e0')
+
+prepare() {
+ cd "$srcdir/$_pkgbasename-$pkgver"
+
+ # Arch64 fix;
+ # -fPIC seems to be the only option
+ export CFLAGS="$CFLAGS -fPIC"
+ export CXXFLAGS="$CFLAGS"
+
+ # fix Firefox crash on x64 when
+ # plugin is in use by ALSA;
+ # see https://bugs.archlinux.org/task/24579
+ patch -Np1 -i "$srcdir/mbeq_crash_fix.patch"
+}
+
+build() {
+ cd "$srcdir/$_pkgbasename-$pkgver"
+
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ ./configure --prefix=/usr
+ #sed -i 's|^plugindir = /usr/lib/ladspa$|plugindir = /usr/lib32/ladspa|' Makefile
+ #sed -i 's|metadata||' Makefile
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgbasename-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+
+ cd "$pkgdir"
+ rm -rf usr/share
+ mv usr/lib usr/lib32
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/lib32-swh-plugins.install b/lib32-swh-plugins.install
new file mode 100644
index 000000000000..3a94d566a6d0
--- /dev/null
+++ b/lib32-swh-plugins.install
@@ -0,0 +1,9 @@
+## arg 1: the new package version
+pre_install() {
+ true
+}
+
+## arg 1: the new package version
+post_install() {
+ echo "To use the 32-bit plugins, set LADSPA_PATH to '/usr/lib/ladspa:/usr/lib32/ladspa'"
+}
diff --git a/mbeq_crash_fix.patch b/mbeq_crash_fix.patch
new file mode 100644
index 000000000000..37ddd33a910c
--- /dev/null
+++ b/mbeq_crash_fix.patch
@@ -0,0 +1,39 @@
+diff -Nru swh-plugins-0.4.15.orig/mbeq_1197.c swh-plugins-0.4.15/mbeq_1197.c
+--- swh-plugins-0.4.15.orig/mbeq_1197.c 2006-08-09 01:49:15.000000000 +1000
++++ swh-plugins-0.4.15/mbeq_1197.c 2011-06-05 10:57:17.929107102 +1000
+@@ -457,7 +457,8 @@
+ #endif
+
+ // Multiply the bins magnitudes by the coeficients
+- for (i = 0; i < FFT_LENGTH/2; i++) {
++ comp[0] *= coefs[0];
++ for (i = 1; i < FFT_LENGTH/2; i++) {
+ comp[i] *= coefs[i];
+ comp[FFT_LENGTH-i] *= coefs[i];
+ }
+diff -Nru swh-plugins-0.4.15.orig/mbeq_1197.so.c swh-plugins-0.4.15/mbeq_1197.so.c
+--- swh-plugins-0.4.15.orig/mbeq_1197.so.c 2003-10-22 02:13:40.000000000 +1000
++++ swh-plugins-0.4.15/mbeq_1197.so.c 2011-06-05 10:57:52.265774336 +1000
+@@ -446,7 +446,8 @@
+ #endif
+
+ // Multiply the bins magnitudes by the coeficients
+- for (i = 0; i < FFT_LENGTH/2; i++) {
++ comp[0] *= coefs[0];
++ for (i = 1; i < FFT_LENGTH/2; i++) {
+ comp[i] *= coefs[i];
+ comp[FFT_LENGTH-i] *= coefs[i];
+ }
+diff -Nru swh-plugins-0.4.15.orig/mbeq_1197.xml swh-plugins-0.4.15/mbeq_1197.xml
+--- swh-plugins-0.4.15.orig/mbeq_1197.xml 2005-06-01 19:51:58.000000000 +1000
++++ swh-plugins-0.4.15/mbeq_1197.xml 2011-06-05 10:57:39.335774121 +1000
+@@ -171,7 +171,8 @@
+ #endif
+
+ // Multiply the bins magnitudes by the coeficients
+- for (i = 0; i < FFT_LENGTH/2; i++) {
++ comp[0] *= coefs[0];
++ for (i = 1; i < FFT_LENGTH/2; i++) {
+ comp[i] *= coefs[i];
+ comp[FFT_LENGTH-i] *= coefs[i];
+ }