summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBailey Kasin2019-08-06 03:55:42 -0700
committerBailey Kasin2019-08-06 03:55:42 -0700
commit12f10526983e9010d2601b880c86c02fafc69db3 (patch)
tree00cec19ae78fef9b375c05526a9a16519f5bbc0c
parent3cdba0bba9095752479a6e6f518f05331f6966ef (diff)
downloadaur-12f10526983e9010d2601b880c86c02fafc69db3.tar.gz
Opt depends and user creation
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
-rw-r--r--gogios.install2
3 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 060bf0043a41..426ed24643ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gogios
pkgdesc = Checks to see if required services are still running on important machines.
- pkgver = 1.2.r0.g4ebd7ed
+ pkgver = 1.2.1.r0.g2ed102f
pkgrel = 1
url = https://github.com/bkasin/gogios
install = gogios.install
@@ -9,6 +9,7 @@ pkgbase = gogios
makedepends = go
makedepends = make
optdepends = nginx
+ optdepends = nmap
provides = gogios
conflicts = gogios-bin
source = gogios::git+https://github.com/bkasin/gogios.git#branch=master
diff --git a/PKGBUILD b/PKGBUILD
index 2f2b7d5bc87b..44ee3c260345 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Bailey Kasin <bailey@gingertechnology.net> (https://angrysysadmins.tech)
pkgname=gogios
-pkgver=1.2.r0.g4ebd7ed
+pkgver=1.2.1.r0.g2ed102f
pkgrel=1
pkgdesc="Checks to see if required services are still running on important machines."
arch=('x86_64')
@@ -9,7 +9,7 @@ url="https://github.com/bkasin/gogios"
license=('MIT')
makedepends=('go' 'make')
-optdepends=('nginx')
+optdepends=('nginx' 'nmap')
install=${pkgname}.install
diff --git a/gogios.install b/gogios.install
index 01075ea27efa..4312ca622f8e 100644
--- a/gogios.install
+++ b/gogios.install
@@ -17,7 +17,7 @@ post_install() {
if id "gogios" >/dev/null 2>&1; then
echo "gogios user already exists"
else
- useradd --system --no-create-home --shell /sbin/nologin gogios
+ useradd --system --user-group --home-dir /var/spool/gogios --shell /sbin/nologin gogios
fi
chown gogios:gogios -R /var/log/gingertechnology