summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Seo2021-05-06 10:59:00 +0900
committerStephen Seo2021-05-06 10:59:00 +0900
commit1310eeafb3cf8f88aada5634dab401bdd1cd114c (patch)
tree98d0d0ba1baf5827284185cd4493e9a036e562df
parentbe4240c7a43924ba492184b98363f8122ed2aaab (diff)
downloadaur-1310eeafb3cf8f88aada5634dab401bdd1cd114c.tar.gz
Update for raylib 3.7.0
-rw-r--r--PKGBUILD6
-rw-r--r--raylib_glfw.patch10
2 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4b7f21b8ce2e..e7a664a12a29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Stephen Seo <seo.disparate@gmail.com>
pkgname=mingw-w64-raylib
-pkgver=3.5.0
+pkgver=3.7.0
pkgrel=1
pkgdesc="Simple and easy to use game programming library (mingw-w64)"
arch=(any)
@@ -19,8 +19,8 @@ source=(
)
noextract=()
md5sums=(
- '2cce7adca17062d8a90bab9aca4aa668'
- '41f1d54782295383566c5485adc8fae2'
+ '006da62cd93b25b1b02b8e806b9d4342'
+ '63cb5f70a8caf1f896465cab01f0d4fe'
)
diff --git a/raylib_glfw.patch b/raylib_glfw.patch
index 692c06ac720d..461fc94d4fac 100644
--- a/raylib_glfw.patch
+++ b/raylib_glfw.patch
@@ -1,12 +1,12 @@
Fixes issues with name conflicts building with external glfw
--- a/src/core.c
+++ b/src/core.c
-@@ -193,7 +193,7 @@
-
+@@ -195,7 +195,7 @@
+
// Support retrieving native window handlers
#if defined(_WIN32)
- #define GLFW_EXPOSE_NATIVE_WIN32
+// #define GLFW_EXPOSE_NATIVE_WIN32
- #include <GLFW/glfw3native.h> // WARNING: It requires customization to avoid windows.h inclusion!
-
- #if !defined(SUPPORT_BUSY_WAIT_LOOP)
+ #include "GLFW/glfw3native.h" // WARNING: It requires customization to avoid windows.h inclusion!
+
+ #if defined(SUPPORT_WINMM_HIGHRES_TIMER) && !defined(SUPPORT_BUSY_WAIT_LOOP)