summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron DeVore2015-07-08 11:23:23 -0700
committerAaron DeVore2015-07-08 11:23:23 -0700
commit13110b6855f7075cb405e6c100df99d6cc8df34e (patch)
treea5da7f12e097ebcc6c6574fdfd43132258be9d9d
downloadaur-13110b6855f7075cb405e6c100df99d6cc8df34e.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--Changelog11
-rw-r--r--LICENSE32
-rw-r--r--PKGBUILD37
-rw-r--r--python2-unittest2.install5
5 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..35757235b6c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = python2-unittest2
+ pkgdesc = The new features in unittest for Python 2.7 backported to Python 2.3+.
+ pkgver = 0.5.1
+ pkgrel = 3
+ url = http://www.voidspace.org.uk/python/articles/unittest2.shtml
+ install = python2-unittest2.install
+ changelog = Changelog
+ arch = any
+ license = BSD
+ makedepends = python2-distribute
+ depends = python2
+ source = http://pypi.python.org/packages/source/u/unittest2/unittest2-0.5.1.tar.gz
+ source = LICENSE
+ source = python2-unittest2.install
+ md5sums = a0af5cac92bbbfa0c3b0e99571390e0f
+ md5sums = 0c162ecb7937c6a146e5b0457f0ccf1e
+ md5sums = 322c77e5e303e5d4a35a6f7e7297538f
+ sha256sums = aa5de8cdf654d843379c97bd1ee240e86356d3355a97b147a6f3f4d149247a71
+ sha256sums = e0bfff5f29a59d078142b8b24b60b0105043057b9e238974d26ae778804ba9bc
+ sha256sums = 653310fa1e9d8224ee819944584f5b8a90e0ba92e84f8dbd37537bb6814729ae
+
+pkgname = python2-unittest2
+
diff --git a/Changelog b/Changelog
new file mode 100644
index 000000000000..954a8f021615
--- /dev/null
+++ b/Changelog
@@ -0,0 +1,11 @@
+2013-04-22 Aaron DeVore <aaron.devore@gmail.com> (0.5.1-3)
+- Fix break with new version of makepkg/pacman
+- Remove sha256sums
+2011-03-18 Aaron DeVore <aaron.devore@gmail.com>
+- Add sha256sums
+- Add python2-distribute to makedepends
+- Add post install warning: Runner executable is unit2-2, not unit2.
+- To avoid conflict with python-unittest2:
+ - move /usr/bin/unit2 -> /usr/bin/unit2-2
+ - move /usr/bin/unit2.py -> /usr/bin/unit2-2.py
+ (Remove when upstream adds a unit2-2 symlink)
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..855e800b4941
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,32 @@
+Copyright (c) 2003-2010, Michael Foord
+All rights reserved.
+E-mail : fuzzyman AT voidspace DOT org DOT uk
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are
+met:
+
+
+ * Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+
+ * Redistributions in binary form must reproduce the above
+ copyright notice, this list of conditions and the following
+ disclaimer in the documentation and/or other materials provided
+ with the distribution.
+
+ * Neither the name of Michael Foord nor the name of Voidspace
+ may be used to endorse or promote products derived from this
+ software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12aa39d54124
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Aaron DeVore <aaron.devore@gmail.com>
+
+pkgname=python2-unittest2
+pkgver=0.5.1
+pkgrel=3
+pkgdesc="The new features in unittest for Python 2.7 backported to Python 2.3+."
+arch=('any')
+url="http://www.voidspace.org.uk/python/articles/unittest2.shtml"
+license=("BSD")
+depends=("python2")
+makedepends=("python2-distribute")
+changelog=Changelog
+install="python2-unittest2.install"
+source=(http://pypi.python.org/packages/source/u/unittest2/unittest2-$pkgver.tar.gz
+ LICENSE
+ python2-unittest2.install)
+md5sums=('a0af5cac92bbbfa0c3b0e99571390e0f'
+ '0c162ecb7937c6a146e5b0457f0ccf1e'
+ '322c77e5e303e5d4a35a6f7e7297538f')
+sha256sums=('aa5de8cdf654d843379c97bd1ee240e86356d3355a97b147a6f3f4d149247a71'
+ 'e0bfff5f29a59d078142b8b24b60b0105043057b9e238974d26ae778804ba9bc'
+ '653310fa1e9d8224ee819944584f5b8a90e0ba92e84f8dbd37537bb6814729ae')
+
+build() {
+ cd "$srcdir/unittest2-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/unittest2-$pkgver"
+ python2 setup.py install "--root=$pkgdir" --optimize=1
+ # Leave /usr/bin/unit2 for unittest2 for Python 3
+ # Switch to full removal when upstream adds /usr/bin/unit2-2[.py]
+ mv "$pkgdir/usr/bin/unit2" "$pkgdir/usr/bin/unit2-2"
+ mv "$pkgdir/usr/bin/unit2.py" "$pkgdir/usr/bin/unit2-2.py"
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/python2-unittest2.install b/python2-unittest2.install
new file mode 100644
index 000000000000..a1d0f95a7b1e
--- /dev/null
+++ b/python2-unittest2.install
@@ -0,0 +1,5 @@
+post_install() {
+ echo "note: the unittest2 Python 2 executable is named unit2-2, not unit2"
+}
+
+# vim:set ts=2 sw=2 et: