summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrevel2016-10-07 01:13:54 +0200
committerrevel2016-10-07 01:13:54 +0200
commit1322f0f332233f0df02ef485006e768055af430f (patch)
treea88aadb8ef94b72e5b792949eb21d896b99ccfdb
parente643a62ddce459c687c00fa7e3f92bb7c2137ce2 (diff)
downloadaur-1322f0f332233f0df02ef485006e768055af430f.tar.gz
- updated to version 0.9.21
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD38
-rw-r--r--plugin_path.patch12
3 files changed, 47 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2776f0cf02d..f9d2a6f05f48 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = edb-debugger
pkgdesc = EDB (Evan's Debugger) is a QT4 based binary mode debugger with the goal of having usability on par with OllyDbg.
- pkgver = 0.9.20
+ pkgver = 0.9.21
pkgrel = 1
url = http://www.codef00.com/projects#debugger
install = edb.install
@@ -8,13 +8,18 @@ pkgbase = edb-debugger
arch = x86_64
license = GPL2
makedepends = boost>=1.35.0
- depends = qt4>=4.6
- source = http://www.codef00.com/projects/debugger-0.9.20.tgz
+ depends = qt5-xmlpatterns
+ depends = capstone>=3.0
+ optdepends = graphviz>=2.38.0
+ source = https://github.com/eteran/edb-debugger/releases/download/0.9.21/edb-debugger-0.9.21.tgz
source = edb.desktop
- md5sums = 5916d415f598fae8632dd763f58e11d1
+ source = plugin_path.patch
+ md5sums = 3754a96538b8f881153d26e4bb96e423
md5sums = 8844cd95efef848f8f4a444259491961
- sha256sums = fd4ebdf8a30ace88395b7b61407fd264cb3919d97368d4932201f0fed6b7ef4d
+ md5sums = 76f3b5f5b51301d3334a93bdf54f3819
+ sha256sums = 2686619e1288152033d4c9c9a2568cb12841d3854bba8815c37ce77d3bd11706
sha256sums = af1d0eae06544fbca7a9af2e2f55dc472324abf28402652e88d3b62c1882a132
+ sha256sums = 7f28fd5f37bc4493a48c199074ec4393b971246e8d208c28f4348d526ac60dce
pkgname = edb-debugger
diff --git a/PKGBUILD b/PKGBUILD
index d71dd83ed0fb..044ad1883809 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,39 +2,51 @@
# Contributor: shild <sxp@bk.ru>
pkgname=edb-debugger
-pkgver=0.9.20
+pkgver=0.9.21
pkgrel=1
pkgdesc="EDB (Evan's Debugger) is a QT4 based binary mode debugger with the goal of having usability on par with OllyDbg."
arch=('i686' 'x86_64')
url='http://www.codef00.com/projects#debugger'
license=('GPL2')
-depends=('qt4>=4.6')
+depends=('qt5-xmlpatterns' 'capstone>=3.0')
makedepends=('boost>=1.35.0')
+optdepends=('graphviz>=2.38.0')
install=edb.install
-source=("http://www.codef00.com/projects/debugger-$pkgver.tgz"
- 'edb.desktop')
-md5sums=('5916d415f598fae8632dd763f58e11d1'
- '8844cd95efef848f8f4a444259491961')
-sha256sums=('fd4ebdf8a30ace88395b7b61407fd264cb3919d97368d4932201f0fed6b7ef4d'
- 'af1d0eae06544fbca7a9af2e2f55dc472324abf28402652e88d3b62c1882a132')
+source=("https://github.com/eteran/edb-debugger/releases/download/$pkgver/edb-debugger-$pkgver.tgz"
+ 'edb.desktop'
+ 'plugin_path.patch')
+md5sums=('3754a96538b8f881153d26e4bb96e423'
+ '8844cd95efef848f8f4a444259491961'
+ '76f3b5f5b51301d3334a93bdf54f3819')
+sha256sums=('2686619e1288152033d4c9c9a2568cb12841d3854bba8815c37ce77d3bd11706'
+ 'af1d0eae06544fbca7a9af2e2f55dc472324abf28402652e88d3b62c1882a132'
+ '7f28fd5f37bc4493a48c199074ec4393b971246e8d208c28f4348d526ac60dce')
+
+prepare() {
+ cd "edb-debugger-$pkgver"
+ patch -p1 -i ../plugin_path.patch
+}
build() {
- cd "debugger"
-
- qmake-qt4 -makefile DEFAULT_PLUGIN_PATH="/usr/lib/edb/"
+ cd "edb-debugger-$pkgver"
+ [ ! -d build ] && mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX="$pkgdir/usr/" -DDEFAULT_PLUGIN_PATH="/usr/lib/edb/" ..
make
}
package() {
- cd "debugger"
+ cd "edb-debugger-$pkgver"
+ cd build
# install to pkg dir
- make INSTALL_ROOT="$pkgdir/usr/" install
+ make install
# correct /usr/lib64 -> /usr/lib on x86_64
[ "$CARCH" = "x86_64" ] && (mv "$pkgdir/usr/lib64" "$pkgdir/usr/lib")
# icons
+ cd ..
install -Dm644 src/images/edb48-logo.png "$pkgdir/usr/share/pixmaps/edb.png"
install -Dm644 src/images/edb48-logo.png "$pkgdir/usr/share/icons/hicolor/48x48/apps/edb.png"
diff --git a/plugin_path.patch b/plugin_path.patch
new file mode 100644
index 000000000000..295858dbdc2f
--- /dev/null
+++ b/plugin_path.patch
@@ -0,0 +1,12 @@
+diff -ruN 1/src/CMakeLists.txt 2/src/CMakeLists.txt
+--- 1/src/CMakeLists.txt 2016-09-28 23:02:41.000000000 +0200
++++ 2/src/CMakeLists.txt 2016-10-07 00:34:34.000000000 +0200
+@@ -45,7 +45,7 @@
+ set(GIT_BRANCH "Unknown")
+ endif()
+ add_definitions(-DGIT_BRANCH=${GIT_BRANCH})
+-add_definitions(-DDEFAULT_PLUGIN_PATH=${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/edb)
++add_definitions(-DDEFAULT_PLUGIN_PATH=${DEFAULT_PLUGIN_PATH})
+
+ include_directories(
+ "capstone-edb"