summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Richards2016-01-08 16:08:58 -0500
committerTom Richards2016-01-08 16:08:58 -0500
commit13c686d3b3ce36aae8f36b4c6bd02cb818bc3228 (patch)
treebc110fab8c7d59e3e2f57a52c6638211a3fdc5b3
parent671d082ef30656f4c727d67536fecc18b012391c (diff)
downloadaur-13c686d3b3ce36aae8f36b4c6bd02cb818bc3228.tar.gz
Switch to sha256sums
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD27
2 files changed, 20 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a738bab09f7..e8a56f2f4a7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Fri Jan 8 21:04:40 UTC 2016
pkgbase = brother-hl2040
pkgdesc = Brother HL-2040 CUPS driver
pkgver = 2.0.1
@@ -12,10 +14,10 @@ pkgbase = brother-hl2040
source = brother-hl2040.install
source = http://www.brother.com/pub/bsc/linux/dlf/cupswrapperHL2040-2.0.1-1.i386.rpm
source = http://www.brother.com/pub/bsc/linux/dlf/brhl2040lpr-2.0.1-1.i386.rpm
- md5sums = c162975d1764145bf3a73befdb4f5df3
- md5sums = 5400480b3988184f2a675a8a29e82baf
- md5sums = 82f57a91f1d4f2d51d37758a0c6a2673
- md5sums = 72930935ddb2ed7ba49fe1f5b4479e16
+ sha256sums = 4a2118ae57baf4a891656ef80dd789ef801875238eaa0b893473e0d8a424681f
+ sha256sums = 81f320491f4cdab592c25b075bea3ba84690c6ae0fa1746c5f865765901827f5
+ sha256sums = cff424e97b46c1de23b31a1a23f2edc5b78e5682bdc71222a39098b531c519f6
+ sha256sums = e123fe7030148c2842fa1859ccd89bd613c31fb7ec9c536032e42a1e0adeaece
depends_x86_64 = lib32-glibc
pkgname = brother-hl2040
diff --git a/PKGBUILD b/PKGBUILD
index 500cc9a03266..50d80452eec6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Sebastiaan Lokhorst <sebastiaanlokhorst@gmail.com>
+# Maintainer: Tom Richards <tom@tomrichards.net>
+# Contributor: Sebastiaan Lokhorst <sebastiaanlokhorst@gmail.com>
# Contributor: Aerion (emile [at] aerion [dot] co [dot] uk
# Contributor: Jaroslaw Rosiek <jaroslaw.rosiek@interia.pl>
@@ -10,23 +11,23 @@ url="http://www.brother.com"
license=('GPL')
install="brother-hl2040.install"
arch=('i686' 'x86_64')
-depends=('cups')
-depends_x86_64=('lib32-glibc')
+depends=('cups')
+depends_x86_64=('lib32-glibc')
source=(brother-hl2040.patch
brother-hl2040.install
http://www.brother.com/pub/bsc/linux/dlf/cupswrapperHL2040-$pkgver-1.i386.rpm
http://www.brother.com/pub/bsc/linux/dlf/brhl2040lpr-$pkgver-1.i386.rpm)
-md5sums=('c162975d1764145bf3a73befdb4f5df3'
- '5400480b3988184f2a675a8a29e82baf'
- '82f57a91f1d4f2d51d37758a0c6a2673'
- '72930935ddb2ed7ba49fe1f5b4479e16')
+sha256sums=('4a2118ae57baf4a891656ef80dd789ef801875238eaa0b893473e0d8a424681f'
+ '81f320491f4cdab592c25b075bea3ba84690c6ae0fa1746c5f865765901827f5'
+ 'cff424e97b46c1de23b31a1a23f2edc5b78e5682bdc71222a39098b531c519f6'
+ 'e123fe7030148c2842fa1859ccd89bd613c31fb7ec9c536032e42a1e0adeaece')
-prepare() {
- cd "$srcdir/usr/" || return 1
- patch -p1 < ../brother-hl2040.patch
+build() {
+ cd "$srcdir/usr"
+ patch -p1 -i "$srcdir/$pkgname.patch"
- cd "$srcdir" || return 1
+ cd "$srcdir"
"$srcdir/usr/local/Brother/cupswrapper/cupswrapperHL2040-$pkgver"
}
@@ -39,6 +40,6 @@ package() {
rm "$pkgdir/usr/share/brother/cupswrapper/cupswrapperHL2040-$pkgver"
rm "$pkgdir/usr/share/brother/inf/setupPrintcap"
- install -m 644 -D ppd_file "$pkgdir/usr/share/cups/model/HL2040.ppd"
- install -m 755 -D wrapper "$pkgdir/usr/lib/cups/filter/brlpdwrapperHL2040"
+ install -Dm644 ppd_file "$pkgdir/usr/share/cups/model/HL2040.ppd"
+ install -Dm755 wrapper "$pkgdir/usr/lib/cups/filter/brlpdwrapperHL2040"
}