summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Steel2015-06-08 18:30:26 +0100
committerJonathan Steel2015-06-08 18:30:26 +0100
commit13c95c76a9ef6b0c8058702970df1cbb0c9c42a0 (patch)
treed5151faca4328593cf552578abf8a181f5a9137f
downloadaur-13c95c76a9ef6b0c8058702970df1cbb0c9c42a0.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6831e74fff78
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = somagic-easycap
+ pkgdesc = Linux Somagic EasyCAP DC60 and EasyCAP002 capture software
+ pkgver = 1.1
+ pkgrel = 1
+ url = http://code.google.com/p/easycap-somagic-linux
+ arch = x86_64
+ arch = i686
+ license = GPL2
+ depends = libusbx
+ depends = libgcrypt
+ optdepends = somagic-easycap-tools: to extract the firmware
+ source = http://easycap-somagic-linux.googlecode.com/files/somagic-easycap_1.1.tar.gz
+ md5sums = 7e8942256b09f2c741658d567d62c202
+
+pkgname = somagic-easycap
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c7d740c6eb2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: jsteel <mail at jsteel dot org>
+
+pkgname=somagic-easycap
+pkgver=1.1
+pkgrel=1
+pkgdesc="Linux Somagic EasyCAP DC60 and EasyCAP002 capture software"
+url="http://code.google.com/p/easycap-somagic-linux"
+arch=('x86_64' 'i686')
+license=('GPL2')
+depends=('libusbx' 'libgcrypt')
+optdepends=('somagic-easycap-tools: to extract the firmware')
+source=(http://easycap-somagic-linux.googlecode.com/files/${pkgname}_$pkgver.tar.gz)
+md5sums=('7e8942256b09f2c741658d567d62c202')
+
+build() {
+ cd "$srcdir"/${pkgname}_$pkgver
+
+ make
+}
+
+package() {
+ cd "$srcdir"/${pkgname}_$pkgver
+
+ make PREFIX="$pkgdir"/usr/ install
+}