summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcoldBug2015-06-08 23:46:44 +0200
committercoldBug2015-06-08 23:46:44 +0200
commit140a3ffd3f45fb8e55b788df368bc8e8b85161a0 (patch)
tree148631111a4249fd32480bb510e14978e142c1cb
downloadaur-140a3ffd3f45fb8e55b788df368bc8e8b85161a0.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD33
-rw-r--r--folder-color-nautilus-bzr.install11
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b862258bf34
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = folder-color-nautilus-bzr
+ pkgdesc = Folder color switcher for nautilus with gnome icon- numix, vibrancy or humanity skin.
+ pkgver = 0.0.78
+ pkgrel = 1
+ url = http://foldercolor.tuxfamily.org/
+ install = folder-color-nautilus-bzr.install
+ arch = any
+ license = GPL3
+ makedepends = bzr
+ makedepends = python-distutils-extra
+ makedepends = python-setuptools
+ depends = python-nautilus
+ depends = nautilus
+ depends = gtk2
+ optdepends = numix-icon-theme-git: to use with numix theme
+ optdepends = humanitycolors-icon-theme: to use with humanity theme
+ optdepends = vibrancy-colors: to use with vibrancy theme
+ source = folder-color-nautilus-bzr::bzr+http://bazaar.launchpad.net/~costales/folder-color/trunk
+ sha256sums = SKIP
+
+pkgname = folder-color-nautilus-bzr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce3add303184
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: coldBug <coldBug at e.mail dot de>
+
+pkgname=folder-color-nautilus-bzr
+pkgver=0.0.78
+pkgrel=1
+pkgdesc="Folder color switcher for nautilus with gnome icon- numix, vibrancy or humanity skin."
+arch=(any)
+url="http://foldercolor.tuxfamily.org/"
+license=(GPL3)
+depends=('python-nautilus' 'nautilus' 'gtk2')
+makedepends=('bzr' 'python-distutils-extra' 'python-setuptools')
+optdepends=('numix-icon-theme-git: to use with numix theme' 'humanitycolors-icon-theme: to use with humanity theme' 'vibrancy-colors: to use with vibrancy theme')
+install=$pkgname.install
+source=($pkgname::bzr+http://bazaar.launchpad.net/~costales/folder-color/trunk)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname/"
+ echo $(egrep -m 1 -o "([0-9]{1,}\.)+[0-9]{1,}" setup.py)
+}
+
+prepare() {
+ cd "$pkgname/install_scripts/"
+ ./nautilus.sh
+ cd ..
+ chmod +x setup.py
+}
+
+package() {
+ cd "$pkgname/"
+ ./setup.py install --root="$pkgdir"
+}
+
diff --git a/folder-color-nautilus-bzr.install b/folder-color-nautilus-bzr.install
new file mode 100644
index 000000000000..8cc1b57b5d6c
--- /dev/null
+++ b/folder-color-nautilus-bzr.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -qtf usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}