summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormarazmista2015-06-09 18:53:09 +0200
committermarazmista2015-06-09 18:53:09 +0200
commit140c5d2dc9d571ba0a551f31a7f6a0159c596c65 (patch)
treeb6feea25cefeddefec0271a829304ed140c5cc65
downloadaur-140c5d2dc9d571ba0a551f31a7f6a0159c596c65.tar.gz
Initial AUR4 import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0cd8de25cb74
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = radeon-profile-daemon-git
+ pkgdesc = System daemon for radeon-profile
+ pkgver = 20150315
+ pkgrel = 1
+ url = http://github.com/marazmista/radeon-profile-daemon
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = qt4
+ depends = xf86-video-ati
+ depends = radeon-profile
+ provides = radeon-profile-daemon
+ replaces = radeon-profile-daemon
+ source = git://github.com/marazmista/radeon-profile-daemon.git
+ sha256sums = SKIP
+
+pkgname = radeon-profile-daemon-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b23ca593cff0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: marazmista <marazmista@gmail.com>
+
+pkgname=radeon-profile-daemon-git
+pkgver=20150315
+pkgrel=1
+pkgdesc="System daemon for radeon-profile"
+url="http://github.com/marazmista/radeon-profile-daemon"
+arch=('i686' 'x86_64')
+license=('GPL2')
+depends=('qt4' 'xf86-video-ati' 'radeon-profile')
+provides=('radeon-profile-daemon')
+replaces=('radeon-profile-daemon')
+source=('git://github.com/marazmista/radeon-profile-daemon.git')
+sha256sums=('SKIP')
+
+build() {
+mkdir -p build
+cd build
+qmake-qt4 "../radeon-profile-daemon/radeon-profile-daemon/"
+make
+}
+
+package() {
+cd build
+make prefix="${pkgdir}" install
+
+install -Dm644 "$srcdir/build/radeon-profile-daemon" "$pkgdir/usr/bin/radeon-profile-daemon"
+chmod +x "$pkgdir/usr/bin/radeon-profile-daemon"
+
+install -Dm644 "$srcdir/radeon-profile-daemon/radeon-profile-daemon/extra/radeon-profile-daemon.service" "$pkgdir/etc/systemd/system/radeon-profile-daemon.service"
+} \ No newline at end of file