summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMantas Mikulėnas2018-04-23 20:19:43 +0300
committerMantas Mikulėnas2018-04-23 20:19:43 +0300
commit142b5c50db44180ec3c7b767d5d09814231d7065 (patch)
treeb694177e48c6316d425e296a17c3b6d24cb3ed1b
parent32fd29d7c35636db3bda975227afa0d6f3fb6884 (diff)
downloadaur-142b5c50db44180ec3c7b767d5d09814231d7065.tar.gz
fix build with pcre 8.42
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--pcre-8.42-hack.diff40
3 files changed, 54 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cbd50c571bce..5524ae368b9b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = monotone
pkgdesc = A free distributed version control system
pkgver = 1.1
- pkgrel = 6
+ pkgrel = 7
url = http://www.monotone.ca/
arch = i686
arch = x86_64
@@ -15,8 +15,10 @@ pkgbase = monotone
depends = zlib
source = http://www.monotone.ca/downloads/1.1/monotone-1.1.tar.bz2
source = http://http.debian.net/debian/pool/main/m/monotone/monotone_1.1-9.debian.tar.xz
+ source = pcre-8.42-hack.diff
sha256sums = f95cf60a22d4e461bec9d0e72f5d3609c9a4576fb1cc45f553d0202ce2e38c88
sha256sums = 70a4e8fed56f4734de2192990db5e20fe8a8b819af51780df3d78310ee9eeeda
+ sha256sums = b23ad00a537314d939eceaa260b4535d85e2b052b4b00279e5f540d38f0d2e07
pkgname = monotone
diff --git a/PKGBUILD b/PKGBUILD
index d9960e0e6f99..6959cc3002d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=monotone
pkgver=1.1
-pkgrel=6
+pkgrel=7
pkgdesc='A free distributed version control system'
arch=('i686' 'x86_64')
url='http://www.monotone.ca/'
@@ -15,9 +15,11 @@ license=('GPL')
depends=('pcre' 'lua' 'botan1.10' 'sqlite3' 'libidn' 'zlib')
makedepends=('boost')
source=("http://www.monotone.ca/downloads/1.1/monotone-${pkgver}.tar.bz2"
- "http://http.debian.net/debian/pool/main/m/monotone/monotone_1.1-9.debian.tar.xz")
+ "http://http.debian.net/debian/pool/main/m/monotone/monotone_1.1-9.debian.tar.xz"
+ "pcre-8.42-hack.diff")
sha256sums=('f95cf60a22d4e461bec9d0e72f5d3609c9a4576fb1cc45f553d0202ce2e38c88'
- '70a4e8fed56f4734de2192990db5e20fe8a8b819af51780df3d78310ee9eeeda')
+ '70a4e8fed56f4734de2192990db5e20fe8a8b819af51780df3d78310ee9eeeda'
+ 'b23ad00a537314d939eceaa260b4535d85e2b052b4b00279e5f540d38f0d2e07')
prepare() {
cd "$srcdir/${pkgname}-${pkgver}"
@@ -25,6 +27,12 @@ prepare() {
msg2 "Applying $_f"
patch -Np1 < ../debian/patches/$_f
done
+ for _f in "${source[@]}"; do
+ if [[ $_f == *.@(diff|patch) ]]; then
+ msg2 "Applying $_f"
+ patch -Np1 < "$srcdir/$_f"
+ fi
+ done
msg2 "Bootstrapping autoconf"
aclocal
autoreconf --install
diff --git a/pcre-8.42-hack.diff b/pcre-8.42-hack.diff
new file mode 100644
index 000000000000..93db018bd1a4
--- /dev/null
+++ b/pcre-8.42-hack.diff
@@ -0,0 +1,40 @@
+--- a/src/pcrewrap.cc 2014-05-04 12:15:17.000000000 +0300
++++ b/src/pcrewrap.cc 2018-04-23 20:13:13.900797729 +0300
+@@ -74,7 +74,7 @@
+ namespace pcre
+ {
+ typedef map<char const *,
+- pair<struct real_pcre const *, struct pcre_extra const *> >
++ pair<struct real_pcre8_or_16 const *, struct pcre_extra const *> >
+ regex_cache;
+
+ class regex_cache_manager
+@@ -86,7 +86,7 @@
+ }
+
+ void store(char const * pattern,
+- pair<struct real_pcre const *, struct pcre_extra const *>
++ pair<struct real_pcre8_or_16 const *, struct pcre_extra const *>
+ data)
+ {
+ cache[pattern] = data;
+--- a/src/pcrewrap.hh 2014-05-04 12:15:17.000000000 +0300
++++ b/src/pcrewrap.hh 2018-04-23 20:13:15.174151327 +0300
+@@ -18,7 +18,7 @@
+ // definitions and so we don't actually expose it here. Unfortunately, this
+ // means we have to hope this pair of forward declarations will not change...
+
+-struct real_pcre;
++struct real_pcre8_or_16;
+ struct pcre_extra;
+
+ namespace pcre
+@@ -61,7 +61,7 @@
+ regex & operator=(regex const &);
+
+ // data
+- struct real_pcre const * basedat;
++ struct real_pcre8_or_16 const * basedat;
+ struct pcre_extra const * extradat;
+
+ // used by constructors