summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-12-21 00:47:46 -0800
committerxiota2023-12-21 00:47:46 -0800
commit14437aa7822a72570e4c292e1927ab3c31d37182 (patch)
tree3656a7d29d082a33c0968b6c3dde87927a25d757
parentf52d5fe7044c071f5173baf3760ba84c942149b1 (diff)
downloadaur-14437aa7822a72570e4c292e1927ab3c31d37182.tar.gz
13.11.9
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD24
2 files changed, 23 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e502ca4b475..fb0eb707caef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,28 @@
pkgbase = debhelper
pkgdesc = A collection of programs that can be used in a debian/rules file to automate common tasks
- pkgver = 13.11.8
+ pkgver = 13.11.9
pkgrel = 1
url = https://salsa.debian.org/debian/debhelper
arch = any
license = GPL2
license = GPL3
- makedepends = file
makedepends = git
makedepends = po4a
- depends = binutils
- depends = dpkg
- depends = file
- depends = html2text
- depends = man-db
depends = perl-pod-parser
- depends = strip-nondeterminism
- depends = po-debconf
optdepends = dh-make: convert source archives into Debian package source
provides = dh-strip-nondeterminism
conflicts = dh-strip-nondeterminism
- source = git+https://salsa.debian.org/debian/debhelper.git#tag=debian/13.11.8
+ source = git+https://salsa.debian.org/debian/debhelper.git#tag=debian/13.11.9
source = dh_strip_nondeterminism::https://salsa.debian.org/reproducible-builds/strip-nondeterminism/-/raw/master/bin/dh_strip_nondeterminism?inline=false
sha256sums = SKIP
sha256sums = SKIP
pkgname = debhelper
+ depends = perl-pod-parser
+ depends = binutils
+ depends = dpkg
+ depends = file
+ depends = html2text
+ depends = man-db
+ depends = strip-nondeterminism
+ depends = po-debconf
diff --git a/PKGBUILD b/PKGBUILD
index aee9a669606a..f784ababe446 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_pkgname="debhelper"
pkgname="$_pkgname"
-pkgver=13.11.8
+pkgver=13.11.9
pkgrel=1
pkgdesc="A collection of programs that can be used in a debian/rules file to automate common tasks"
url="https://salsa.debian.org/debian/debhelper"
@@ -16,19 +16,9 @@ arch=('any')
_url_dh_strip_nondeterminism="https://salsa.debian.org/reproducible-builds/strip-nondeterminism"
depends=(
- 'binutils'
- 'dpkg'
- 'file'
- 'html2text'
- 'man-db'
'perl-pod-parser'
- 'strip-nondeterminism'
-
- # AUR
- 'po-debconf'
)
makedepends=(
- 'file'
'git'
'po4a'
)
@@ -72,6 +62,18 @@ build() {
}
package() {
+ depends+=(
+ 'binutils'
+ 'dpkg'
+ 'file'
+ 'html2text'
+ 'man-db'
+ 'strip-nondeterminism'
+
+ # AUR
+ 'po-debconf'
+ )
+
cd "$_pkgsrc"
make DESTDIR="${pkgdir:?}" install
install -Dm755 "${srcdir:?}/dh_strip_nondeterminism" -t "${pkgdir:?}/usr/bin"