summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072022-02-26 22:12:01 +0100
committersL1pKn072022-02-26 22:12:01 +0100
commit147bf49c47ee2feb3ae7024952470e5c69679311 (patch)
treeadca66db1a83a0e13a48d025e03be9a088366aae
parent7103a45a16239fe3f272888e6156ea33fab529d5 (diff)
downloadaur-147bf49c47ee2feb3ae7024952470e5c69679311.tar.gz
bump
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD25
2 files changed, 17 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff355d4bd848..2e3a32ceb1c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = flacon-git
pkgdesc = Extracts individual tracks from one big audio file containing the entire album of music and saves them as separate audio files. (Git Version)
- pkgver = v5.5.1.84.gc7a5cfa
+ pkgver = 8.3.0.4.g7f3dad3
pkgrel = 1
url = http://flacon.github.io
arch = x86_64
@@ -10,6 +10,7 @@ pkgbase = flacon-git
makedepends = qt5-tools
depends = qt5-base
depends = uchardet
+ depends = taglib
depends = hicolor-icon-theme
depends = desktop-file-utils
optdepends = faac: For AAC support
@@ -23,8 +24,8 @@ pkgbase = flacon-git
optdepends = wavpack: For WavPack support
provides = flacon
conflicts = flacon
+ options = debug
source = git+https://github.com/flacon/flacon.git
sha256sums = SKIP
pkgname = flacon-git
-
diff --git a/PKGBUILD b/PKGBUILD
index e81d9cfbdb36..c31d5033cb47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgname=flacon-git
-pkgver=v5.5.1.84.gc7a5cfa
+pkgver=8.3.0.4.g7f3dad3
pkgrel=1
pkgdesc="Extracts individual tracks from one big audio file containing the entire album of music and saves them as separate audio files. (Git Version)"
arch=('x86_64')
@@ -9,6 +9,7 @@ url='http://flacon.github.io'
license=('LGPL2.1')
depends=('qt5-base'
'uchardet'
+ 'taglib'
'hicolor-icon-theme'
'desktop-file-utils'
)
@@ -30,25 +31,27 @@ conflicts=('flacon')
provides=('flacon')
source=('git+https://github.com/flacon/flacon.git')
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd flacon
- echo "$(git describe --long --tags | tr - .)"
-}
-
-prepare() {
- mkdir -p build
+ echo "$(git describe --long --tags | tr - . | tr -d v)"
}
build() {
- cd build
- cmake ../flacon \
+ cmake -S flacon -B build \
-DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_TESTS=Yes
- make
+ cmake --build build
+}
+
+check() {
+ cd build
+ ctest --output-on-failure
}
package() {
- make -C build DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" cmake --build build --target install
}