summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryjun2021-03-27 21:25:27 +0800
committeryjun2021-03-27 21:25:27 +0800
commit148d397c8570ff81e38e8ae2b1b6e0edf5e67d9c (patch)
treeaf3eed38f7f4a0dd565568654fc8c6df17133373
parent8dc583631339c9383eb3f49315e4b2fc92556cbc (diff)
downloadaur-148d397c8570ff81e38e8ae2b1b6e0edf5e67d9c.tar.gz
update: sunloginclient 11.0.0.36662
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD32
2 files changed, 18 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65933a2eda7c..5ca37bb116c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sunloginclient
pkgdesc = Proprietary software that supports remote control of mobile devices, Windows, Mac, Linux and other systems.(GUI version)
- pkgver = 11.0.0.35346
- pkgrel = 5
+ pkgver = 11.0.0.36662
+ pkgrel = 1
url = https://sunlogin.oray.com
install = sunloginclient.install
arch = x86_64
@@ -10,10 +10,10 @@ pkgbase = sunloginclient
depends = libappindicator-gtk3
depends = xorg-xhost
provides = sunlogin
- source = https://down.oray.com/sunlogin/linux/sunloginclient-11.0.0.35346-amd64.deb
+ source = https://down.oray.com/sunlogin/linux/sunloginclient-11.0.0.36662-amd64.deb
source = runsunloginclient.service
source = LICENSE
- sha256sums = 6f7d6d91f87da0b8dd5f101df5f49e6fa2ab027e01fe34205e920fe48da9c21e
+ sha256sums = 825e05405dcdd31e87a91a0bfa961c6e954f953d6ead667715924b4703e41ef0
sha256sums = 58942243be93d1e743fc42d9670e75a4f33f121faa3d6f2d44c95d73d1ead00c
sha256sums = b3da0bda5ab0d4badb2cf7723dac95a9c5f5efb89f3d3f192d78728b064d0720
diff --git a/PKGBUILD b/PKGBUILD
index d6c1cd2adb36..3b9c3d5b4cef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=sunloginclient
_pkgname=sunlogin
-pkgver=11.0.0.35346
-pkgrel=5
+pkgver=11.0.0.36662
+pkgrel=1
pkgdesc="Proprietary software that supports remote control of mobile devices, Windows, Mac, Linux and other systems.(GUI version)"
arch=("x86_64")
url="https://sunlogin.oray.com"
@@ -17,7 +17,7 @@ source=("https://down.oray.com/${_pkgname}/linux/${pkgname}-${pkgver}-amd64.deb"
"runsunloginclient.service"
'LICENSE')
install="${pkgname}.install"
-sha256sums=('6f7d6d91f87da0b8dd5f101df5f49e6fa2ab027e01fe34205e920fe48da9c21e'
+sha256sums=('825e05405dcdd31e87a91a0bfa961c6e954f953d6ead667715924b4703e41ef0'
'58942243be93d1e743fc42d9670e75a4f33f121faa3d6f2d44c95d73d1ead00c'
'b3da0bda5ab0d4badb2cf7723dac95a9c5f5efb89f3d3f192d78728b064d0720')
@@ -26,34 +26,30 @@ build() {
tar -xf data.tar.xz -C build
}
+_install (){
+ cd ${srcdir}/build
+
+ find usr/local/${_pkgname}/$1 -type f -exec \
+ install -Dm$2 {} -t ${pkgdir}/opt/${_pkgname}/$1 \;
+}
+
package() {
cd build
-
# system service
install -Dm644 ${srcdir}/run${pkgname}.service -t \
"${pkgdir}/usr/lib/systemd/system/"
-
# bin
- find usr/local/${_pkgname}/bin -type f -exec \
- install -Dm755 {} -t ${pkgdir}/opt/${_pkgname}/bin \;
+ _install bin 755
# font
- find usr/local/${_pkgname}/res/font -type f -exec \
- install -Dm644 {} -t ${pkgdir}/opt/${_pkgname}/res/font \;
+ _install res/font 644
# icon
- install -dm755 "$pkgdir/opt/${_pkgname}/res/icon"
- for ico in offline_lock offline online_ctrl online_lock online
- do
- icotool -x -i 3 usr/local/${_pkgname}/res/icon/$ico.ico -o .
- icotool -c "${ico}_3_24x24x32.png" -o \
- "$pkgdir/opt/${_pkgname}/res/icon/$ico.ico"
- done
+ _install res/icon 644
# skin
# write permission is required for sunlogin client to work
- find usr/local/${_pkgname}/res/skin -type f -exec \
- install -Dm666 {} -t ${pkgdir}/opt/${_pkgname}/res/skin \;
+ _install res/skin 666
# desktop entry
install -Dm644 usr/share/applications/${_pkgname}.desktop -t \