summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhuoyun Wei2015-10-29 21:29:17 +0800
committerZhuoyun Wei2015-10-30 00:10:45 +0800
commit148fdca4aca97fd1e28974cbd4d86e65b50008af (patch)
tree2cabd2c82cfa20db9657af78342305a36eac1d5b
downloadaur-148fdca4aca97fd1e28974cbd4d86e65b50008af.tar.gz
Initial commit (forked from extra/nginx)
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD121
-rw-r--r--logrotate10
-rw-r--r--nginx.install21
-rw-r--r--service17
5 files changed, 207 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..362eb93a9859
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+pkgbase = nginx-google_filter
+ pkgdesc = Lightweight HTTP server and IMAP/POP3 proxy server, with ngx_http_google_filter_module
+ pkgver = 1.8.0
+ pkgrel = 1
+ url = http://nginx.org
+ install = nginx.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = pcre
+ depends = zlib
+ depends = openssl
+ depends = geoip
+ provides = nginx=1.8.0
+ conflicts = nginx
+ backup = etc/nginx/fastcgi.conf
+ backup = etc/nginx/fastcgi_params
+ backup = etc/nginx/koi-win
+ backup = etc/nginx/koi-utf
+ backup = etc/nginx/mime.types
+ backup = etc/nginx/nginx.conf
+ backup = etc/nginx/scgi_params
+ backup = etc/nginx/uwsgi_params
+ backup = etc/nginx/win-utf
+ backup = etc/logrotate.d/nginx
+ source = http://nginx.org/download/nginx-1.8.0.tar.gz
+ source = ngx_http_google_filter_module-0.1.9.tar.gz::https://github.com/cuber/ngx_http_google_filter_module/archive/0.1.9.tar.gz
+ source = ngx_http_substitutions_filter_module-0.6.4.tar.gz::https://github.com/yaoweibin/ngx_http_substitutions_filter_module/archive/v0.6.4.tar.gz
+ source = service
+ source = logrotate
+ sha256sums = 23cca1239990c818d8f6da118320c4979aadf5386deda691b1b7c2c96b9df3d5
+ sha256sums = a5923f40cc62152bb69b386dbee2c8f67b1db0c807eb6de471a74f12043a74a9
+ sha256sums = ed4ddbcf0c434f4a1e97b61251a63ace759792764bd5cb79ff20efe348db8db3
+ sha256sums = 4ecbc33ce4bf2965996f51b0c7edb677904ba5cff9a32e93e1487a428d3a751b
+ sha256sums = 2613986dd5faab09ca962264f16841c8c55c3a0bc7a5bb737eabd83143090878
+
+pkgname = nginx-google_filter
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e18d08844bb5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,121 @@
+# Maintainer: Zhuoyun Wei <wzyboy@wzyboy.org>
+
+pkgname=nginx-google_filter
+_pkgname=nginx
+pkgver=1.8.0
+_mod1=ngx_http_google_filter_module
+_mod1ver=0.1.9
+_mod2=ngx_http_substitutions_filter_module
+_mod2ver=0.6.4
+pkgrel=1
+pkgdesc='Lightweight HTTP server and IMAP/POP3 proxy server, with ngx_http_google_filter_module'
+provides=("nginx=${pkgver}")
+conflicts=('nginx')
+arch=('i686' 'x86_64')
+url='http://nginx.org'
+license=('custom')
+depends=('pcre' 'zlib' 'openssl' 'geoip')
+backup=('etc/nginx/fastcgi.conf'
+ 'etc/nginx/fastcgi_params'
+ 'etc/nginx/koi-win'
+ 'etc/nginx/koi-utf'
+ 'etc/nginx/mime.types'
+ 'etc/nginx/nginx.conf'
+ 'etc/nginx/scgi_params'
+ 'etc/nginx/uwsgi_params'
+ 'etc/nginx/win-utf'
+ 'etc/logrotate.d/nginx')
+install=nginx.install
+source=(http://nginx.org/download/${_pkgname}-${pkgver}.tar.gz
+ ${_mod1}-${_mod1ver}.tar.gz::https://github.com/cuber/${_mod1}/archive/${_mod1ver}.tar.gz
+ ${_mod2}-${_mod2ver}.tar.gz::https://github.com/yaoweibin/${_mod2}/archive/v${_mod2ver}.tar.gz
+ service
+ logrotate)
+sha256sums=('23cca1239990c818d8f6da118320c4979aadf5386deda691b1b7c2c96b9df3d5'
+ 'a5923f40cc62152bb69b386dbee2c8f67b1db0c807eb6de471a74f12043a74a9'
+ 'ed4ddbcf0c434f4a1e97b61251a63ace759792764bd5cb79ff20efe348db8db3'
+ '4ecbc33ce4bf2965996f51b0c7edb677904ba5cff9a32e93e1487a428d3a751b'
+ '2613986dd5faab09ca962264f16841c8c55c3a0bc7a5bb737eabd83143090878')
+
+build() {
+ cd $_pkgname-$pkgver
+
+ ./configure \
+ --prefix=/etc/nginx \
+ --conf-path=/etc/nginx/nginx.conf \
+ --sbin-path=/usr/bin/nginx \
+ --pid-path=/run/nginx.pid \
+ --lock-path=/run/lock/nginx.lock \
+ --user=http \
+ --group=http \
+ --http-log-path=/var/log/nginx/access.log \
+ --error-log-path=stderr \
+ --http-client-body-temp-path=/var/lib/nginx/client-body \
+ --http-proxy-temp-path=/var/lib/nginx/proxy \
+ --http-fastcgi-temp-path=/var/lib/nginx/fastcgi \
+ --http-scgi-temp-path=/var/lib/nginx/scgi \
+ --http-uwsgi-temp-path=/var/lib/nginx/uwsgi \
+ --with-imap \
+ --with-imap_ssl_module \
+ --with-ipv6 \
+ --with-pcre-jit \
+ --with-file-aio \
+ --with-http_addition_module \
+ --with-http_auth_request_module \
+ --with-http_dav_module \
+ --with-http_degradation_module \
+ --with-http_flv_module \
+ --with-http_geoip_module \
+ --with-http_gunzip_module \
+ --with-http_gzip_static_module \
+ --with-http_mp4_module \
+ --with-http_realip_module \
+ --with-http_secure_link_module \
+ --with-http_spdy_module \
+ --with-http_ssl_module \
+ --with-http_stub_status_module \
+ --with-http_sub_module \
+ --add-module=../${_mod1}-${_mod1ver} \
+ --add-module=../${_mod2}-${_mod2ver}
+
+ make
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 contrib/vim/ftdetect/nginx.vim \
+ "$pkgdir"/usr/share/vim/vimfiles/ftdetect/nginx.vim
+ install -Dm644 contrib/vim/syntax/nginx.vim \
+ "$pkgdir"/usr/share/vim/vimfiles/syntax/nginx.vim
+ install -Dm644 contrib/vim/indent/nginx.vim \
+ "$pkgdir"/usr/share/vim/vimfiles/indent/nginx.vim
+
+ sed -e 's|\<user\s\+\w\+;|user html;|g' \
+ -e '44s|html|/usr/share/nginx/html|' \
+ -e '54s|html|/usr/share/nginx/html|' \
+ -i "$pkgdir"/etc/nginx/nginx.conf
+
+ rm "$pkgdir"/etc/nginx/*.default
+
+ install -d "$pkgdir"/var/lib/nginx
+ install -dm700 "$pkgdir"/var/lib/nginx/proxy
+
+ chmod 750 "$pkgdir"/var/log/nginx
+ chown http:log "$pkgdir"/var/log/nginx
+
+ install -d "$pkgdir"/usr/share/nginx
+ mv "$pkgdir"/etc/nginx/html/ "$pkgdir"/usr/share/nginx
+
+ install -Dm644 ../logrotate "$pkgdir"/etc/logrotate.d/nginx
+ install -Dm644 ../service "$pkgdir"/usr/lib/systemd/system/nginx.service
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$_pkgname/LICENSE
+
+ rmdir "$pkgdir"/run
+
+ install -d "$pkgdir"/usr/share/man/man8/
+ gzip -9c man/nginx.8 > "$pkgdir"/usr/share/man/man8/nginx.8.gz
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/logrotate b/logrotate
new file mode 100644
index 000000000000..61237601f6da
--- /dev/null
+++ b/logrotate
@@ -0,0 +1,10 @@
+/var/log/nginx/*log {
+ missingok
+ create 640 http log
+ su http log
+ sharedscripts
+ compress
+ postrotate
+ test ! -r /run/nginx.pid || kill -USR1 `cat /run/nginx.pid`
+ endscript
+}
diff --git a/nginx.install b/nginx.install
new file mode 100644
index 000000000000..7c4adf14bd9a
--- /dev/null
+++ b/nginx.install
@@ -0,0 +1,21 @@
+post_upgrade() {
+ if (( $(vercmp $2 1.2.7-4) <= 0 )); then
+ chmod 750 var/log/nginx
+ chown http:log var/log/nginx
+ fi
+ if (( $(vercmp $2 1.2.1-2) <= 0 )); then
+ echo ' >>> Since 1.2.1-2 several changes has been made in package:'
+ echo ' - *.conf files have been moved to /etc/nginx'
+ echo ' - /etc/conf.d/nginx has been removed'
+ echo ' Main configuration file is set to /etc/nginx/nginx.conf'
+ echo ' - access.log and error.log can be found in /var/log/nginx by default'
+ echo ' - bundled *.html files have been moved to /usr/share/nginx/html'
+ echo ' - /etc/nginx/{html,logs} symbolic links and *.default files have been removed'
+ fi
+ if (( $(vercmp $2 1.4.2-4) < 0 )); then
+ echo 'Nginx now includes only upstream bundled modules.'
+ echo 'Thus, passenger module support was dropped.'
+ fi
+}
+
+# vim:set ts=4 sw=4 et:
diff --git a/service b/service
new file mode 100644
index 000000000000..adfe6c0abbee
--- /dev/null
+++ b/service
@@ -0,0 +1,17 @@
+[Unit]
+Description=A high performance web server and a reverse proxy server
+After=network.target
+
+[Service]
+Type=forking
+PIDFile=/run/nginx.pid
+PrivateDevices=yes
+SyslogLevel=err
+
+ExecStart=/usr/bin/nginx -g 'pid /run/nginx.pid; error_log stderr;'
+ExecReload=/usr/bin/kill -HUP $MAINPID
+KillSignal=SIGQUIT
+KillMode=mixed
+
+[Install]
+WantedBy=multi-user.target