summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Ammann2015-12-24 16:52:32 +0100
committerMax Ammann2015-12-24 16:52:32 +0100
commit14abf7c33d98d6ab1ecbf29b86125b3613343454 (patch)
tree40e99ddb00a5fda724509becc61a01b2ccfd79ef
downloadaur-14abf7c33d98d6ab1ecbf29b86125b3613343454.tar.gz
Initial import
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD33
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0b3a27adf6c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+# Generated by mksrcinfo v8
+# Thu Dec 24 15:49:44 UTC 2015
+pkgbase = qwtplot3d-svn
+ pkgdesc = QwtPlot3D is a graphics extension to the Qt GUI application framework. It provides a 3D plotting widget for scientific data and mathematical expressions. It compares to the existing Qwt Project.
+ pkgver = 0.2.7r259
+ pkgrel = 1
+ url = http://qwtplot3d.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = zlib
+ makedepends = gcc
+ makedepends = make
+ makedepends = qt5-tools
+ makedepends = subversion
+ depends = qt5-base
+ depends = qt5-svg
+ depends = qt5-location
+ depends = qt5-declarative
+ depends = qt5-webchannel
+ depends = qt5-sensors
+ depends = qt5-serialport
+ depends = qt5-webkit
+ depends = qt5-multimedia
+ conflicts = qwtplot3d
+ replaces = qwtplot3d
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = qwtplot3d::svn+http://svn.code.sf.net/p/qwtplot3d/code/branches/maintain_0_2_x/#revision=259
+ md5sums = SKIP
+
+pkgname = qwtplot3d-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..37461f89c5b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Ammann Max <maximilian.ammann@googlemail.com>
+pkgname=qwtplot3d-svn
+replaces=('qwtplot3d')
+conflicts=('qwtplot3d')
+pkgver=0.2.7r259
+pkgrel=1
+pkgdesc="QwtPlot3D is a graphics extension to the Qt GUI application framework. It provides a 3D plotting widget for scientific data and mathematical expressions. It compares to the existing Qwt Project."
+arch=('i686' 'x86_64')
+url="http://qwtplot3d.sourceforge.net/"
+license=('zlib')
+makedepends=('gcc' 'make' 'qt5-tools' 'subversion')
+depends=('qt5-base' 'qt5-svg' qt5-location qt5-declarative qt5-webchannel qt5-sensors qt5-serialport qt5-webkit qt5-multimedia)
+options=('!strip' '!buildflags' 'staticlibs')
+source=('qwtplot3d::svn+http://svn.code.sf.net/p/qwtplot3d/code/branches/maintain_0_2_x/#revision=259')
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/qwtplot3d/qwtplot3d"
+ sed -i '/DESTDIR/s/^/#/g' qwtplot3d.pro
+
+ sed -i '/^CONFIG/ s/$/ shared_and_static build_all/' qwtplot3d.pro
+
+ sed -i '1s/^/#include <GL\/glu.h>\n/' include/qwt3d_openglhelper.h
+}
+
+package() {
+ cd "${srcdir}/qwtplot3d/qwtplot3d"
+ qmake DESTDIR=$pkgdir/usr/lib
+ make -j8
+
+ mkdir -p $pkgdir/"usr/include/qwtplot3d"
+ cp "include"/* $pkgdir/"usr/include/qwtplot3d"
+}