summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormaz-12017-02-02 11:21:16 +0800
committermaz-12017-02-02 11:21:16 +0800
commit14b95441060fe10f17c99e53033a6865114e7f5f (patch)
treeb4de23fa6c57af4fad42e7631a38cb11b6135f7a
downloadaur-14b95441060fe10f17c99e53033a6865114e7f5f.tar.gz
init
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD28
-rw-r--r--mount.exfat6
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f677b86d030
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Thu Feb 2 03:19:08 UTC 2017
+pkgbase = exfat-utils-autodetect
+ pkgdesc = Utilities for exFAT file system
+ pkgver = 1.2.5
+ pkgrel = 1
+ url = https://github.com/relan/exfat
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = rsync
+ depends = fuse
+ depends = glibc
+ provides = exfat-utils
+ conflicts = exfat-utils
+ options = !strip
+ source = mount.exfat
+ md5sums = 2b15364aacb5a79081e069c73a88dd9a
+ source_i686 = exfat-utils-i686.pkg.tar.xz::https://www.archlinux.org/packages/community/i686/exfat-utils/download/
+ md5sums_i686 = SKIP
+ source_x86_64 = exfat-utils-x86_64.pkg.tar.xz::https://www.archlinux.org/packages/community/x86_64/exfat-utils/download/
+ md5sums_x86_64 = SKIP
+
+pkgname = exfat-utils-autodetect
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8b673698a90d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=exfat-utils-autodetect
+pkgver=1.2.5
+pkgrel=1
+pkgdesc="Utilities for exFAT file system"
+arch=('i686' 'x86_64')
+url="https://github.com/relan/exfat"
+depends=( 'fuse' 'glibc')
+makedepends=( 'rsync')
+conflicts=( 'exfat-utils')
+provides=( 'exfat-utils')
+license=('GPL2')
+source_x86_64=("exfat-utils-x86_64.pkg.tar.xz::https://www.archlinux.org/packages/community/x86_64/exfat-utils/download/")
+md5sums_x86_64=('SKIP')
+source_i686=("exfat-utils-i686.pkg.tar.xz::https://www.archlinux.org/packages/community/i686/exfat-utils/download/")
+md5sums_i686=('SKIP')
+source=("mount.exfat")
+md5sums=('2b15364aacb5a79081e069c73a88dd9a')
+options=('!strip')
+
+pkgver() {
+ cat $srcdir/.PKGINFO | grep -oP '(?<=pkgver = )\d+\.\d+\.\d+'
+}
+
+package() {
+ mkdir -p ${pkgdir}/usr
+ rsync -Prltv --delete ${srcdir}/usr ${pkgdir}/ --exclude usr/bin/mount.exfat
+ install -Dm 755 ${srcdir}/mount.exfat ${pkgdir}/usr/bin/mount.exfat
+}
diff --git a/mount.exfat b/mount.exfat
new file mode 100644
index 000000000000..f5ebfd8f08bf
--- /dev/null
+++ b/mount.exfat
@@ -0,0 +1,6 @@
+#!/bin/sh
+if (cat /proc/filesystems | grep exfat) ; then
+ mount -i -t exfat "$@"
+else
+ mount.exfat-fuse "$@"
+fi