summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Peyser2018-08-23 17:12:42 +0200
committerAlexander Peyser2018-08-23 17:12:42 +0200
commit14d665347ddcb92ca3fc60cad1f2347babeadd3e (patch)
treefc96571ebd3be1300b7d5d5a222cab6d3fc1edef
parent366591bc923a2642c52a7c98b762f62d2a251a68 (diff)
downloadaur-14d665347ddcb92ca3fc60cad1f2347babeadd3e.tar.gz
update maintainer
-rw-r--r--PKGBUILD5
-rw-r--r--disper_0.3.1-fix_init.patch34
2 files changed, 3 insertions, 36 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 77090ff5da3c..ad9f0d32c4a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: Thomas Jost <schnouki@schnouki.net>
+# Co-maintainer: Alex Peyser <peyser.alex.public@gmail.com>
pkgname=disper
pkgver=0.3.1.1
pkgrel=1
@@ -9,8 +10,8 @@ license=('GPL')
depends=('python2')
source=(${url}/archive/${pkgname}-${pkgver}.tar.gz)
#source=(http://ppa.launchpad.net/disper-dev/ppa/ubuntu/pool/main/d/disper/disper_${pkgver}.tar.gz disper_0.3.1-fix_init.patch )
-md5sums=('223d1c7d6aed9fefa86a864ebef99ea0')
-sha256sums=('e73b3e5ec2e58da78864cf5ac7283c8c07083295e8edaf341fcf934f820a724b')
+md5sums=('89cd0998b463dbd13e3c4571966d0153')
+sha256sums=('355b5e55ccc377531753f716402128370e0bca690b77be7b867ff199dcbd8853')
build() {
cd "$srcdir/${pkgname}-${pkgname}-${pkgver}"
diff --git a/disper_0.3.1-fix_init.patch b/disper_0.3.1-fix_init.patch
deleted file mode 100644
index d1a6be7d3566..000000000000
--- a/disper_0.3.1-fix_init.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-diff -Naur disper/src/xrandr/__init__.py disper-new/src/xrandr/__init__.py
---- disper/src/xrandr/__init__.py 2011-09-09 16:20:45.000000000 +0200
-+++ disper-new/src/xrandr/__init__.py 2016-07-28 15:33:34.391703460 +0200
-@@ -83,10 +83,20 @@
-
- from core import Screen, xlib, rr
-
-+xopendisplay = None
-+class Display(Structure): pass
-+
-+def get_display(name):
-+ global xopendisplay
-+ if xopendisplay is None:
-+ xopendisplay = xlib.XOpenDisplay
-+ xopendisplay.restype = POINTER(Display)
-+ return xopendisplay(name)
-+
- def get_current_display():
- """Returns the currently used display"""
- display_url = os.getenv("DISPLAY")
-- dpy = xlib.XOpenDisplay(display_url)
-+ dpy = get_display(display_url)
- return dpy
-
- def get_current_screen():
-@@ -98,7 +108,7 @@
-
- def get_screen_of_display(display, count):
- """Returns the screen of the given display"""
-- dpy = xlib.XOpenDisplay(display)
-+ dpy = get_display(display)
- return Screen(dpy, count)
-
- def get_version():