summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNebulaNeko2020-11-14 19:32:35 +0800
committerNebulaNeko2020-11-14 19:32:35 +0800
commit151c48d3a503843844e5a3c983809936336ba4ad (patch)
treee13716894c574c9dc9c9e949cddca6bce2d5f66c
parent9c0ca8edefca14b3e9fe1334cb0473850c7d8da7 (diff)
downloadaur-151c48d3a503843844e5a3c983809936336ba4ad.tar.gz
updated PKGBUILD
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD60
2 files changed, 38 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e32e8d2a0e4..e93517d7db82 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = novnc-git
- pkgdesc = javascript vnc client
- pkgver = 20150614.1
+ pkgdesc = HTML VNC Client Library and Application
+ pkgver = 1.2.0.r20.g90456db
pkgrel = 1
url = https://github.com/kanaka/noVNC
arch = any
- license = GPL
- optdepends = websockify: for vnc servers without websocket support
+ license = custom
+ makedepends = git
+ depends = bash
+ depends = websockify
+ optdepends = python-numpy: better HyBi protocol performance
provides = novnc
conflicts = novnc
- source = novnc::git://github.com/kanaka/noVNC.git
+ source = novnc::git+https://github.com/novnc/noVNC.git
md5sums = SKIP
pkgname = novnc-git
diff --git a/PKGBUILD b/PKGBUILD
index 7018b7bc0cc9..861e6ad58be4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,46 @@
-# Maintainer: Radek Podgorny <radek@podgorny.cz>
+# Maintainer: seiuneko <chfsefefgesfen foxmail>
+# Contributor: Radek Podgorny <radek@podgorny.cz>
+
pkgname=novnc-git
-pkgver=20150614.1
+pkgver=1.2.0.r20.g90456db
pkgrel=1
-pkgdesc="javascript vnc client"
+pkgdesc="HTML VNC Client Library and Application"
arch=(any)
url="https://github.com/kanaka/noVNC"
-license=('GPL')
-depends=()
+license=('custom')
+depends=('bash' 'websockify')
+optdepends=('python-numpy: better HyBi protocol performance')
provides=('novnc')
conflicts=('novnc')
-source=("novnc::git://github.com/kanaka/noVNC.git")
+source=("novnc::git+https://github.com/novnc/noVNC.git")
md5sums=('SKIP')
-optdepends=(
- 'websockify: for vnc servers without websocket support'
-)
+makedepends=("git")
pkgver() {
cd "$srcdir"/novnc
- echo "$(git log -1 --format="%cd" --date=short | sed 's|-||g').$(git rev-list --count master)"
-}
-
-prepare() {
- cd $srcdir/novnc
- rm -f utils/*.o
- rm -rf .git
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-build() {
- cd $srcdir/novnc
- #make -C utils
+prepare(){
+ cd "novnc"
+ sed \
+ -e 's#\(share\)#\1/webapps#g' \
+ -e '2 i WEBSOCKIFY=/usr/bin/websockify' \
+ -i utils/launch.sh
}
package() {
- cd $srcdir/novnc
- mkdir -p $pkgdir/usr/share/novnc $pkgdir/usr/share/doc/novnc $pkgdir/usr/bin
- cp -a app core vendor utils vnc.html vnc_lite.html $pkgdir/usr/share/novnc/
- cp -a LICENSE.txt README.md $pkgdir/usr/share/doc/novnc
- cat >$pkgdir/usr/bin/novnc <<EOF
-#!/bin/sh
-
-cd /usr/share/novnc || exit 1
-exec ./utils/launch.sh \$*
-EOF
- chmod 0755 $pkgdir/usr/bin/novnc
+ cd "novnc"
+
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 vendor/pako/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE.MIT"
+ ( cd docs; find . -name 'LICENSE*' -type f -exec cp -a {} "$pkgdir/usr/share/licenses/$pkgname/{}" \; )
+
+ install -dm644 "$pkgdir/usr/share/doc/$pkgname"
+ ( cd docs; find . ! -name 'LICENSE*' -type f -exec cp -a {} "$pkgdir/usr/share/doc/$pkgname/{}" \; )
+
+ install -Dm755 utils/launch.sh "$pkgdir/usr/bin/novnc"
+
+ install -dm755 "$pkgdir/usr/share/webapps/novnc"
+ cp -a app core po vendor vnc.html karma.conf.js package.json vnc_lite.html "$pkgdir/usr/share/webapps/novnc"
}