summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordonGR2019-07-27 14:54:43 +0300
committerGordonGR2019-07-27 14:54:43 +0300
commit152be6b77345150313bc848f002fa1e06e5edb82 (patch)
tree70573de15040f6b0ef50ff80fb59247b4c7d7875
parentf2b0835b8cfefe3fc31697076e4b11e23331d51c (diff)
downloadaur-152be6b77345150313bc848f002fa1e06e5edb82.tar.gz
1.8.7.6994: Upstream update
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD55
2 files changed, 37 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c4a7b620b52..6d9ec9d87638 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
-# Generated by mksrcinfo v8
-# Mon Feb 27 19:17:40 UTC 2017
pkgbase = singularityviewer
pkgdesc = A Second Life (secondlife) protocol compatible client application, used to access its service as well as a number of other such as those based upon OpenSim platform
- pkgver = 1.8.7.6866
- pkgrel = 3
+ pkgver = 1.8.7.6994
+ pkgrel = 1
url = http://www.singularityviewer.org/
arch = x86_64
license = custom
+ depends = apr
depends = apr-util
depends = gtk2
depends = libgl
@@ -20,24 +19,21 @@ pkgbase = singularityviewer
depends = lib32-zlib
depends = gconf
depends = lib32-util-linux
+ depends = openal
+ depends = expat
+ depends = freealut
optdepends = libpulse: for PulseAudio support
optdepends = alsa-lib: for ALSA support
optdepends = nvidia-utils: for NVIDIA support
optdepends = flashplugin: for inworld Flash support
optdepends = gstreamer0.10: for video support, may need good, bad and ugly plugins
- optdepends = lib32-freealut: for OpenAL support
- optdepends = openal
optdepends = libxtst
- source = http://67.170.30.149/Singularity_1_8_7_6866_.tar.xz
+ source = https://downloads.sourceforge.net/project/singularityview/alphas/SingularityAlpha-x86_64-1.8.7.6994.tar.bz2
source = singularityviewer.desktop
source = singularityviewer.launcher
- source = http://dl.dropboxusercontent.com/u/4361965/singularityviewer.png
- source = http://archive.archlinux.org/repos/2016/12/06/extra/os/x86_64/harfbuzz-1.3.4-1-x86_64.pkg.tar.xz
- md5sums = 26239218a3ca9a6343039906e5374f79
+ md5sums = 2420b7825a812ff6bfec48914b90a13e
md5sums = 3b6c5641f35a099af35ff4065733049f
md5sums = eb596f5cf7b6f2d0c55c0082fb99a905
- md5sums = 0c825fe422dadd0cac9010e7ff152cfa
- md5sums = 0a3e4654c3009d740a6be09e58a2d451
pkgname = singularityviewer
diff --git a/PKGBUILD b/PKGBUILD
index e8fa240565dc..b94e1f34d45b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,51 @@
# Maintainer: GordonGR <ntheo1979@gmail.com>
pkgname=singularityviewer
-pkgver=1.8.7.6866
-_pkgver=1_8_7_6866
-pkgrel=3
-_harfbuzzver=1.3.4-1
+pkgver=1.8.7.6994
+_pkgver=1_8_7_6994
+pkgrel=1
pkgdesc="A Second Life (secondlife) protocol compatible client application, used to access its service as well as a number of other such as those based upon OpenSim platform"
url="http://www.singularityviewer.org/"
license=('custom')
arch=('x86_64')
-depends=('apr-util' 'gtk2' 'libgl' 'libidn' 'mesa' 'nss' 'sdl' 'libxss' 'lib32-libidn' 'lib32-libsndfile' 'lib32-zlib' 'gconf' 'lib32-util-linux')
-optdepends=('libpulse: for PulseAudio support' 'alsa-lib: for ALSA support'
+depends=('apr' 'apr-util' 'gtk2' 'libgl' 'libidn' 'mesa' 'nss' 'sdl' 'libxss' 'lib32-libidn' 'lib32-libsndfile' 'lib32-zlib' 'gconf' 'lib32-util-linux' 'openal' 'expat' 'freealut')
+optdepends=('libpulse: for PulseAudio support'
+ 'alsa-lib: for ALSA support'
'nvidia-utils: for NVIDIA support'
'flashplugin: for inworld Flash support'
'gstreamer0.10: for video support, may need good, bad and ugly plugins'
- 'lib32-freealut: for OpenAL support'
- 'openal'
'libxtst')
-source=("http://67.170.30.149/Singularity_${_pkgver}_$CARCH.tar.xz"
+
+source=("https://downloads.sourceforge.net/project/singularityview/alphas/SingularityAlpha-x86_64-${pkgver}.tar.bz2"
"singularityviewer.desktop"
- "singularityviewer.launcher"
- "http://dl.dropboxusercontent.com/u/4361965/singularityviewer.png"
- "http://archive.archlinux.org/repos/2016/12/06/extra/os/x86_64/harfbuzz-1.3.4-1-x86_64.pkg.tar.xz")
-md5sums=('26239218a3ca9a6343039906e5374f79'
+ "singularityviewer.launcher")
+md5sums=('2420b7825a812ff6bfec48914b90a13e'
'3b6c5641f35a099af35ff4065733049f'
- 'eb596f5cf7b6f2d0c55c0082fb99a905'
- '0c825fe422dadd0cac9010e7ff152cfa'
- '0a3e4654c3009d740a6be09e58a2d451')
+ 'eb596f5cf7b6f2d0c55c0082fb99a905')
package() {
cd $srcdir
-
+
# Rename Data Directory
-mv Singularity_${_pkgver}_$CARCH singularityviewer
-
+mv SingularityAlpha-$CARCH-${pkgver} singularityviewer
+
+# Remove old libraries
+#cd $srcdir
+cd singularityviewer/
+cd lib64/
+rm *SDL*
+rm *openal*
+rm *expat*
+rm *apr*
+rm *alut*
+rm *freetype*
+
# Install Desktop File
install -D -m644 $srcdir/singularityviewer.desktop \
$pkgdir/usr/share/applications/singularityviewer.desktop
# Install Icon File
-install -D -m644 $srcdir/singularityviewer.png \
+install -D -m644 $srcdir/singularityviewer/viewer_icon.png \
$pkgdir/usr/share/pixmaps/singularityviewer_icon.png
# Install Launcher
@@ -52,7 +58,7 @@ install -D -m755 $srcdir/singularityviewer/licenses.txt \
# Move Data to Destination Directory
install -d $pkgdir/opt
-mv singularityviewer $pkgdir/opt/
+mv $srcdir/singularityviewer $pkgdir/opt/
# Change Permissions of files to root:games
chown -R root:games $pkgdir/opt/singularityviewer
@@ -60,12 +66,9 @@ chmod -R g+rw $pkgdir/opt/singularityviewer
# Make Binary Group-Executable
chmod g+x $pkgdir/opt/singularityviewer/singularity
-
+
# Do not re-register the application with the desktop system at every launch, saves from locally installed desktop files.
sed -i 's|./refresh_desktop_app_entry.sh|#./refresh_desktop_app_entry.sh|' $pkgdir/opt/singularityviewer/singularity
-# Install harfbuzz binaries
-cd $srcdir/usr/lib/
-cp *harfbuzz.so* $pkgdir/opt/singularityviewer/lib64/
-
+
}