aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntony Kellermann2018-05-21 14:23:57 -0400
committerAntony Kellermann2018-05-21 14:23:57 -0400
commit1530be585d2651e563fc06550c35ddc247efa512 (patch)
treea9a1b04afef28c44a599e049443778a79ccc4ab7
parent2c337516fee989a07c8c56934614f6ded4097e8c (diff)
downloadaur-1530be585d2651e563fc06550c35ddc247efa512.tar.gz
Documentation and new version
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--README.md15
-rw-r--r--main.c10
-rw-r--r--tick.129
5 files changed, 25 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c23e3f39fda..018f5f80f202 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tick
pkgdesc = Command line stock and cryptocurrency portfolio tracker.
- pkgver = 2.1.0
+ pkgver = 2.2.0
pkgrel = 1
url = https://github.com/aokellermann/tick
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index fef3a6b116b6..ab57d6f71c50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Antony Kellermann <aokellermann@gmail.com>
pkgname=tick
-pkgver=2.1.0
+pkgver=2.2.0
pkgrel=1
pkgdesc="Command line stock and cryptocurrency portfolio tracker."
arch=('x86_64')
diff --git a/README.md b/README.md
index f98d09131816..910de7afebe6 100644
--- a/README.md
+++ b/README.md
@@ -39,13 +39,16 @@ tickers also being listed on the stock market, such as ETH.
To get info about your current holdings, run
```bash
-$ tick check [symbol/crypto_id/sort_option]
+$ tick check
+```
+Prints information about all of your current holdings and a grand total
+in an NCurses window. By default, your holdings will be sorted
+alphabetically. You may press the left and right arrow keys to change
+the sort category. Press "q" to exit the window. You can also get
+information on a specific security using
+```bash
+$ tick check [symbol/crypto_id/USD$]
```
-Running "check" with no other arguments will list your entire portfolio
-as well as produce a grand total. Adding the argument "-v", "-p", "-1",
-or "-7" will sort the output by value, profit, one day profit, or seven
-day profit. To check a single security, use the symbol or crypto_id as
-the argument instead of sort options.
You may encrypt your portfolio using the RC4 algorithm
```bash
diff --git a/main.c b/main.c
index 7f586fd27a6f..49f64664c205 100644
--- a/main.c
+++ b/main.c
@@ -28,15 +28,12 @@ int main(int argc, char* argv[]) {
int modop = -1;
// News
- if (strcmp(cmd, "news") == 0) {
- if (argc == 3 && strlen(argv[2]) <= 32 && strlen(argv[2]) > 1)
- news_print_top_three(argv[2]);
- else puts("Invalid input.");
- }
+ if (strcmp(cmd, "news") == 0 && argc == 3 && strlen(sym) <= 32 && strlen(sym) > 1)
+ news_print_top_three(sym);
//Encrypt/decrypt
else if ((strcmp(cmd, "encrypt") == 0 || strcmp(cmd, "decrypt") == 0) && argc == 2)
- portfolio_encrypt_decrypt(strcmp(cmd, "encrypt") == 0);
+ portfolio_encrypt_decrypt(strcmp(cmd, "encrypt") == 0); // 1 if encrypt, 0 if decrypt
// Info
else if (strcmp(cmd, "info") == 0 && argc == 3)
@@ -64,7 +61,6 @@ int main(int argc, char* argv[]) {
modop = REMOVE;
else if (strcmp(cmd, "set") == 0)
modop = SET;
-
else puts("Invalid arguments. Type \"man tick\" for help.");
// Portfolio Operations
diff --git a/tick.1 b/tick.1
index 41d5c27b517e..2885f5ed25d2 100644
--- a/tick.1
+++ b/tick.1
@@ -1,4 +1,4 @@
-.TH TICK "1" "May 2018" "Tick 2.1.0" "User Commands"
+.TH TICK "1" "May 2018" "Tick 2.2.0" "User Commands"
.SH NAME
Tick - Command line stock and cryptocurrency portfolio tracker.
@@ -7,8 +7,8 @@ Tick - Command line stock and cryptocurrency portfolio tracker.
tick COMMAND [ARGUMENTS]
.SH DESCRIPTION
-Create your portfolio by adding your current holdings. You can see information about your holdings with the command "check".
-You may also see information about securities that you may not own with commands "info" and "news".
+Create your portfolio by "add"-ing your current holdings. Then, use the command "check" to see information about your
+holdings. You may also see information about securities that you may not own with commands "info" and "graph".
.SS
Portfolio:
@@ -26,11 +26,14 @@ are not reinvested into a specific security, you should update your portfolio wi
You may also specify the share price instead of the total amount you spent by appending "ea" to the end of the share price.
.TP
-[check] [symbol/crypto_id/sort_option]
-Prints information about your current portfolio holdings. To print all of your holdings alphabetically as well as a
-grand total, no additional arguments besides "check" need to be used. Optionally, you may use the options "-a" to print
-alphabetically, "-v" to print by value, "-p" to print by profit, "-1" to print by one day profit, or "-7" to print by
-seven day profit. To print information about a single security, use the ticker or crypto id as an argument after "check".
+[check]
+Prints information about all of your current holdings and a grand total in an NCurses window. By default, your holdings
+will be sorted alphabetically. You may press the left and right arrow keys to change the sort category. Press "q" to
+exit the window.
+
+.TP
+[check] [symbol/crypto_id/USD$]
+Prints information about a specific security in your portfolio.
.TP
[encrypt/decrypt]
@@ -83,11 +86,6 @@ Or to get info about all your holdings, run
$ tick check
.RE
-or to sort by value
-.RS
-$ tick check -v
-
-.RE
To get the top three news articles on Tesla in the past two weeks, run
.RS
$ tick news tesla
@@ -102,11 +100,6 @@ $ tick info tesla
.RS
Portfolio file.
-.RE
-.I ~/.tick_portfolio
-.RS
-Portfolio file (legacy).
-
.SH GITHUB
Please report any bugs using the GitHub issue tracker: