summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlfredo Ramos2021-06-25 16:25:34 -0500
committerAlfredo Ramos2021-06-25 16:25:34 -0500
commit1541f01a79ae9b86495dff36263b68ce1ea44177 (patch)
tree835888a5d72fa27a0a729c784484aafec13ac7b3
parent0d237945cd814a4ef39261926f7344abf97ba4aa (diff)
downloadaur-1541f01a79ae9b86495dff36263b68ce1ea44177.tar.gz
Fix build for OpenColorIO
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD55
2 files changed, 47 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 41a71919d475..a668fc5a1b3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = krita-git
pkgdesc = A full-featured free digital painting studio. Git version.
- pkgver = 4.3.0.prealpha.3252.ga899f2f428
- pkgrel = 2
+ pkgver = 4.3.0.prealpha.6708.g97865cd60c
+ pkgrel = 1
url = https://krita.org
arch = x86_64
license = GPL3
@@ -12,11 +12,11 @@ pkgbase = krita-git
makedepends = eigen
makedepends = vc
makedepends = poppler-qt5
- makedepends = opencolorio
makedepends = python-pyqt5
makedepends = libheif
- makedepends = sip
- makedepends = python-sip
+ makedepends = sip4
+ makedepends = python-sip4
+ makedepends = kseexpr
depends = kitemviews
depends = kitemmodels
depends = ki18n
@@ -32,22 +32,24 @@ pkgbase = krita-git
depends = exiv2
depends = openexr
depends = fftw
- depends = curl
- depends = boost-libs
depends = giflib
+ depends = openjpeg2
+ depends = opencolorio1
depends = hicolor-icon-theme
optdepends = poppler-qt5: PDF filter
optdepends = ffmpeg: to save animations
- optdepends = opencolorio: for the LUT docker
optdepends = krita-plugin-gmic: G'MIC plugin
optdepends = python-pyqt5: for the Python plugins
optdepends = libheif: HEIF filter
- provides = krita=4.3.0.prealpha.3252.ga899f2f428
+ optdepends = kseexpr: SeExpr generator layer
+ optdepends = kimageformats: PSD support
+ provides = krita=4.3.0.prealpha.6708.g97865cd60c
conflicts = calligra-krita
conflicts = krita-il10n
conflicts = krita
source = git+https://github.com/KDE/krita.git
+ source = https://raw.githubusercontent.com/archlinux/svntogit-packages/4877333d60835f6531cc990af955cedb39158893/trunk/krita-opencolorio1.patch
sha256sums = SKIP
+ sha256sums = 2f892449e20abc370fe3dc8b5dd12f9964d1d402a909e775641e28685b1719b3
pkgname = krita-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 196da51761fe..0613c7f10d92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,46 +8,61 @@
_pkgname=krita
pkgname=${_pkgname}-git
-pkgver=4.3.0.prealpha.3252.ga899f2f428
-pkgrel=2
+pkgver=4.3.0.prealpha.6708.g97865cd60c
+pkgrel=1
pkgdesc='A full-featured free digital painting studio. Git version.'
arch=('x86_64')
url='https://krita.org'
license=('GPL3')
-depends=(kitemviews kitemmodels ki18n kcompletion karchive kguiaddons kcrash
- qt5-svg qt5-multimedia quazip gsl libraw exiv2 openexr fftw curl
- boost-libs giflib hicolor-icon-theme)
-makedepends=(git extra-cmake-modules kdoctools boost eigen vc poppler-qt5
- opencolorio python-pyqt5 libheif sip python-sip)
-optdepends=('poppler-qt5: PDF filter' 'ffmpeg: to save animations'
- 'opencolorio: for the LUT docker' "krita-plugin-gmic: G'MIC plugin"
- 'python-pyqt5: for the Python plugins' 'libheif: HEIF filter')
+depends=(
+ kitemviews kitemmodels ki18n kcompletion karchive kguiaddons kcrash
+ qt5-svg qt5-multimedia quazip gsl libraw exiv2 openexr fftw giflib
+ openjpeg2 opencolorio1 hicolor-icon-theme
+)
+makedepends=(
+ git extra-cmake-modules kdoctools boost eigen vc poppler-qt5
+ python-pyqt5 libheif sip4 python-sip4 kseexpr
+)
+optdepends=(
+ 'poppler-qt5: PDF filter'
+ 'ffmpeg: to save animations'
+ "krita-plugin-gmic: G'MIC plugin"
+ 'python-pyqt5: for the Python plugins'
+ 'libheif: HEIF filter'
+ 'kseexpr: SeExpr generator layer'
+ 'kimageformats: PSD support'
+)
provides=("${_pkgname}=${pkgver}")
conflicts=(calligra-krita krita-il10n krita)
-source=("git+https://github.com/KDE/${_pkgname}.git")
-sha256sums=('SKIP')
+source=(
+ "git+https://github.com/KDE/${_pkgname}.git"
+ 'https://raw.githubusercontent.com/archlinux/svntogit-packages/4877333d60835f6531cc990af955cedb39158893/trunk/krita-opencolorio1.patch'
+)
+sha256sums=(
+ 'SKIP'
+ '2f892449e20abc370fe3dc8b5dd12f9964d1d402a909e775641e28685b1719b3'
+)
pkgver() {
- cd "${srcdir}"/${_pkgname}
+ cd ${_pkgname}
git describe --long --tags 2>/dev/null | sed -r 's/^v//;s/-/./g'
}
prepare() {
- mkdir -p "${srcdir}"/build
+ patch -d ${_pkgname} -Np1 < krita-opencolorio1.patch
}
build() {
- cd "${srcdir}"/build
- cmake ../${_pkgname} \
+ cmake -B build -S ${_pkgname} \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_TESTING=OFF
- make
+ -DBUILD_TESTING=OFF \
+ -DBUILD_KRITA_QT_DESIGNER_PLUGINS=ON
+ cmake --build build --clean-first
}
package() {
- cd "${srcdir}"/build
- make DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" cmake --install build
}