summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUffe Jakobsen2016-10-17 11:47:30 +0200
committerUffe Jakobsen2016-10-17 11:47:30 +0200
commit154f0385baf619a2b78ec668f9209d4ab8837c70 (patch)
tree01a79062bf61e67d5c7757dff6bf57c90254a50c
parente84f68960c710645c94e14a51f496792886091ee (diff)
downloadaur-154f0385baf619a2b78ec668f9209d4ab8837c70.tar.gz
Upstream patch applyed - remove local patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--opencbm_usb_USB_LE16_TO_CPU_le16toh.patch29
3 files changed, 4 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 555e32866b0e..1aa3220cb658 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Oct 17 09:36:24 UTC 2016
+# Mon Oct 17 09:45:45 UTC 2016
pkgbase = opencbm-git
pkgdesc = OpenCBM allows access to Commodore (C64) storage devices VIC 1540, 1541, 1570, 1571, or even 1581 floppy drive
pkgver = r1229.dbeb7de
@@ -13,9 +13,7 @@ pkgbase = opencbm-git
depends = libusb
depends = libusb-compat
source = git+http://git.code.sf.net/p/opencbm/code
- source = opencbm_usb_USB_LE16_TO_CPU_le16toh.patch
md5sums = SKIP
- md5sums = 460f571c2f1e2b80c10ade19a831fbed
pkgname = opencbm-git
diff --git a/PKGBUILD b/PKGBUILD
index 9a575e5d570b..c49a73d212e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,10 +27,8 @@ options=()
install=
changelog=
noextract=()
-source=(git+http://git.code.sf.net/p/opencbm/code
- opencbm_usb_USB_LE16_TO_CPU_le16toh.patch)
-md5sums=('SKIP'
- '460f571c2f1e2b80c10ade19a831fbed')
+source=(git+http://git.code.sf.net/p/opencbm/code)
+md5sums=('SKIP')
pkgver() {
cd "${srcdir}/code"
@@ -43,7 +41,7 @@ prepare() {
build() {
cd "${srcdir}/code"
- #make -f LINUX/Makefile opencbm plugin-xum1541
+ #make -f LINUX/Makefile opencbm plugin-xum1541 plugin-xu1541
make -f LINUX/Makefile opencbm plugin
}
diff --git a/opencbm_usb_USB_LE16_TO_CPU_le16toh.patch b/opencbm_usb_USB_LE16_TO_CPU_le16toh.patch
deleted file mode 100644
index 852ff252c3f5..000000000000
--- a/opencbm_usb_USB_LE16_TO_CPU_le16toh.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-commit 84b10fc7188de11fade4df963503080acbdb198c (HEAD -> refs/heads/usb_USB_LE16_TO_CPU_le16toh)
-Author: Uffe Jakobsen <microtop@starion.dk>
-AuthorDate: Sun Oct 16 17:02:22 2016 +0200
-Commit: Uffe Jakobsen <microtop@starion.dk>
-CommitDate: Sun Oct 16 17:02:51 2016 +0200
-
- Linux: newer usb.h does not have USB_LE16_TO_CPU() macro anymore
----
-:100644 100644 b9f6bd1... d7681cf... M xu1541/misc/usb_echo_test.c
- xu1541/misc/usb_echo_test.c | 6 ++++++
- 1 file changed, 6 insertions(+)
-
-diff --git xu1541/misc/usb_echo_test.c xu1541/misc/usb_echo_test.c
-index b9f6bd1..d7681cf 100644
---- xu1541/misc/usb_echo_test.c
-+++ xu1541/misc/usb_echo_test.c
-@@ -27,6 +27,12 @@ usb_dev_handle *handle = NULL;
- #define QUIT_KEY
- #endif
-
-+// Linux: newer usb.h does not have USB_LE16_TO_CPU() macro anymore
-+#ifndef USB_LE16_TO_CPU
-+#include <endian.h>
-+#define USB_LE16_TO_CPU(x) x=le16toh(x);
-+#endif
-+
- /* send a number of 16 bit words to the xu1541 interface */
- /* and verify that they are correctly returned by the echo */
- /* command. This may be used to check the reliability of */