summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-08-10 16:34:04 +0300
committerCaleb Maclennan2021-08-10 16:34:04 +0300
commit1552be2b2f0160e6b33e586071825f7f130335c9 (patch)
tree9d112671bc82210f7bb9198270276cbb2c01b794
parente9d2bdfd22fda114a577d744b4d55f21efcd2a1e (diff)
downloadaur-1552be2b2f0160e6b33e586071825f7f130335c9.tar.gz
upgpkg: sile 0.10.15-2
Normalize packaging style (closer and closer to [community]\!)
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD72
2 files changed, 36 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3dea0fae5b4..c19fd09fa35c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -42,4 +42,3 @@ pkgbase = sile
sha256sums = 49b55730effd473c64a8955a903e48f61c51dd7bb862e6d5481193218d1e3c5c
pkgname = sile
-
diff --git a/PKGBUILD b/PKGBUILD
index bd957a653c56..64ea22a19e74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,45 +5,45 @@ pkgname=sile
pkgdesc='Modern typesetting system inspired by TeX'
pkgver=0.10.15
pkgrel=2
-arch=('x86_64')
-url='https://www.sile-typesetter.org'
-license=('MIT')
-_lua_deps=('bit32'
- 'cassowary'
- 'cosmo'
- 'cliargs'
- 'expat'
- 'filesystem'
- 'linenoise'
- 'lpeg'
- 'luaepnf'
- 'penlight'
- 'repl'
- 'sec'
- 'socket'
- 'stdlib'
- 'utf8'
- 'vstruct'
- 'zlib')
-depends=('fontconfig'
- 'freetype2'
- 'harfbuzz'
- 'gentium-plus-font'
- 'icu'
- 'libpng' # this goes with libtexpdf if ever split out to a library package
- 'lua'
+arch=(x86_64)
+url=https://www.sile-typesetter.org
+license=(MIT)
+_lua_deps=(bit32
+ cassowary
+ cosmo
+ cliargs
+ expat
+ filesystem
+ linenoise
+ lpeg
+ luaepnf
+ penlight
+ repl
+ sec
+ socket
+ stdlib
+ utf8
+ vstruct
+ zlib)
+depends=(fontconfig
+ freetype2
+ harfbuzz
+ gentium-plus-font
+ icu
+ libpng # this goes with libtexpdf if ever split out to a library package
+ lua
"${_lua_deps[@]/#/lua-}"
- 'zlib')
+ zlib)
# Note find via find-deps; needs rebuilding any time versions of these change;
# currently missing several because parent packages are missing the provides=()
-depends+=('libfreetype.so'
- 'libharfbuzz.so'
- 'libicudata.so'
- 'libicui18n.so'
- 'libicuio.so'
- 'libicuuc.so')
-checkdepends=('poppler')
-provides=('libtexpdf.so')
+depends+=(libfreetype.so
+ libharfbuzz.so
+ libicudata.so
+ libicui18n.so
+ libicuio.so
+ libicuuc.so)
+checkdepends=(poppler)
+provides=(libtexpdf.so)
source=("https://github.com/sile-typesetter/sile/releases/download/v$pkgver/$pkgname-$pkgver.tar.xz")
sha256sums=('49b55730effd473c64a8955a903e48f61c51dd7bb862e6d5481193218d1e3c5c')