summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Fink2020-03-10 15:15:53 +0200
committerChristoph Fink2020-03-10 15:15:53 +0200
commit1552d6590293318f2a2c1bc54aead7c142def33b (patch)
tree017c690e18bd25f7adcee49d87222f92dc058957
parent7f8fc96c3da5020740cf253af5839aacb1e5a4df (diff)
downloadaur-1552d6590293318f2a2c1bc54aead7c142def33b.tar.gz
0.14.1-3
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore12
-rw-r--r--PKGBUILD45
3 files changed, 32 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1d5b63eb550..db46a955ba67 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
-# Generated by mksrcinfo v8
-# Thu Jul 13 18:10:56 UTC 2017
pkgbase = python-unicodecsv
- pkgdesc = Python2's stdlib csv module is nice, but it doesn't support unicode. This module is a drop-in replacement which *does*.
+ pkgdesc = A drop-in replacement for the csv module that supports unicode strings
pkgver = 0.14.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/jdunck/python-unicodecsv
arch = any
license = BSD
makedepends = python-setuptools
- source = https://pypi.python.org/packages/source/u/unicodecsv/unicodecsv-0.14.1.tar.gz
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/u/unicodecsv/unicodecsv-0.14.1.tar.gz
source = https://raw.githubusercontent.com/jdunck/python-unicodecsv/master/LICENSE
sha256sums = 018c08037d48649a0412063ff4eda26eaa81eff1546dbffa51fa5293276ff7fc
sha256sums = a3b3fcd3f2b3e97b4c4ffc354f719e1519dc95dc0b09d82f769538feeb7db032
pkgname = python-unicodecsv
- depends = python
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index d44a93561adf..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,12 +0,0 @@
-# sources
-*.tar.gz
-LICENSE
-
-# build logs
-*-build.log
-*-namcap.log
-*-package*.log
-*-prepare.log
-
-# packages
-*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 019f790b6fbf..837d8718e602 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,40 @@
-# Maintainer: Carl George < arch at cgtx dot us >
+# Maintainer: peippo <christoph+aur@christophfink.com>
-_name="unicodecsv"
-_module="${_name}"
+pkgname="python-unicodecsv"
+_name=${pkgname#python-}
+pkgdesc="A drop-in replacement for the csv module that supports unicode strings"
+url="https://github.com/jdunck/python-unicodecsv"
+
+pkgver=0.14.1
+pkgrel=3
-pkgname="python-${_module}"
-pkgver="0.14.1"
-pkgrel="2"
-pkgdesc="Python2's stdlib csv module is nice, but it doesn't support unicode. This module is a drop-in replacement which *does*."
arch=("any")
-url="https://github.com/jdunck/python-${_name}"
license=("BSD")
-makedepends=("python-setuptools")
-source=("https://pypi.python.org/packages/source/${_name:0:1}/${_name}/${_name}-${pkgver}.tar.gz"
- "https://raw.githubusercontent.com/jdunck/python-unicodecsv/master/LICENSE")
-sha256sums=('018c08037d48649a0412063ff4eda26eaa81eff1546dbffa51fa5293276ff7fc'
- 'a3b3fcd3f2b3e97b4c4ffc354f719e1519dc95dc0b09d82f769538feeb7db032')
+
+makedepends=(
+ "python-setuptools"
+)
+depends=(
+ "python"
+)
+
+source=(
+ "https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
+ "https://raw.githubusercontent.com/jdunck/python-unicodecsv/master/LICENSE"
+)
+sha256sums=(
+ "018c08037d48649a0412063ff4eda26eaa81eff1546dbffa51fa5293276ff7fc"
+ "a3b3fcd3f2b3e97b4c4ffc354f719e1519dc95dc0b09d82f769538feeb7db032"
+)
build() {
- cd "${srcdir}/${_name}-${pkgver}"
+ cd "${srcdir}"/${_name}-${pkgver}
python setup.py build
}
package() {
- depends=("python")
- install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
cd "${srcdir}/${_name}-${pkgver}"
- python setup.py install --skip-build --root="${pkgdir}" --optimize=1
+ python setup.py install --root="${pkgdir}" --optimize=1
}