summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororumin2015-06-14 02:21:14 +0900
committerorumin2015-06-14 02:21:19 +0900
commit1569153c012e14037d806db7d953ff7cef85d08a (patch)
tree3f979bad558d8704292dbcb5b9c6876e6dcda8ad
downloadaur-1569153c012e14037d806db7d953ff7cef85d08a.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
-rw-r--r--wacom-utility.desktop18
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc4a230f61d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = wacom-utility-git
+ pkgdesc = Graphical tablet configuration utility
+ pkgver = 20130909
+ pkgrel = 2
+ url = http://github.com/lubosz/wacom-utility.git
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gtk2
+ depends = python2
+ depends = xf86-input-wacom
+ depends = gksu
+ source = wacom-utility.desktop
+ md5sums = 1d44b3571fd5e48b80b2dec5209fcf47
+
+pkgname = wacom-utility-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98b6941c0c03
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgname=wacom-utility-git
+pkgver=20150614
+pkgrel=1
+pkgdesc="Graphical tablet configuration utility"
+arch=('i686' 'x86_64')
+url="http://github.com/lubosz/wacom-utility.git"
+license=('GPL')
+depends=('gtk2' 'python2' 'xf86-input-wacom' 'gksu')
+source=(wacom-utility.desktop)
+md5sums=('1d44b3571fd5e48b80b2dec5209fcf47')
+
+_gitname="wacom-utility"
+_gitroot="http://github.com/lubosz/$_gitname"
+
+package() {
+ cd ${srcdir}/
+ git clone ${_gitroot}
+
+ cd ${_gitname}
+ mkdir -p "${pkgdir}"/usr/share/wacom-utility
+ mkdir -p "${pkgdir}"/usr/share/applications
+ cp -a ./* "${pkgdir}"/usr/share/wacom-utility
+ install -Dm644 "${startdir}"/wacom-utility.desktop "${pkgdir}"/usr/share/applications/
+}
diff --git a/wacom-utility.desktop b/wacom-utility.desktop
new file mode 100644
index 000000000000..80ed4c801fc8
--- /dev/null
+++ b/wacom-utility.desktop
@@ -0,0 +1,18 @@
+#!/usr/bin/env xdg-open
+
+[Desktop Entry]
+Version=1.0
+Encoding=UTF-8
+Name=Wacom Control Panel
+Type=Application
+Exec=python2 /usr/share/wacom-utility/wacom_utility.py
+Terminal=false
+Icon=/usr/share/wacom-utility/images/generic.png
+Comment=Utility to configure wacom pen tablets
+Categories=GNOME;GTK;X-XFCE;Settings;HardwareSettings;
+OnlyShowIn=GNOME;Settings;XFCE
+Hidden=false
+Name[en_CA]=Wacom Control Panel
+Comment[en_CA]=Utility to configure wacom pen tablets
+X-GNOME-Autostart-enabled=false
+GenericName=