summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Kauselmann2017-10-22 14:00:24 +0200
committerFelix Kauselmann2017-10-22 14:00:24 +0200
commit15793b761ccc8b0661db6cf9f55f6fd960c49a7b (patch)
tree0466c95dace888d324ab6eca51f530b9a9334242
downloadaur-15793b761ccc8b0661db6cf9f55f6fd960c49a7b.tar.gz
Initial upload
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD25
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..74ad87ff3d6d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Sun Oct 22 11:57:12 UTC 2017
+pkgbase = libunarr
+ pkgdesc = A lightweight decompression library with support for rar, tar and zip archives.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/selmf/unarr
+ arch = i686
+ arch = x86_64
+ license = LGPL3
+ makedepends = cmake
+ makedepends = git
+ depends = zlib
+ depends = bzip2
+ depends = xz
+ conflicts = libunarr-git
+ source = https://github.com/selmf/unarr/releases/download/v1.0.0/unarr-1.0.0.tar.xz
+ md5sums = db62163a06a2a7af18e46640f2482854
+
+pkgname = libunarr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47d13ae28df1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Felix Kauselmann <licorn at gmail dot com>
+pkgname=libunarr
+pkgver=1.0.0
+pkgrel=1
+arch=('i686' 'x86_64')
+url="https://github.com/selmf/unarr"
+license=("LGPL3")
+pkgdesc="A lightweight decompression library with support for rar, tar and zip archives."
+source=("https://github.com/selmf/unarr/releases/download/v${pkgver}/unarr-${pkgver}.tar.xz")
+makedepends=('cmake' 'git')
+depends=('zlib' 'bzip2' 'xz')
+conflicts=('libunarr-git')
+
+md5sums=('db62163a06a2a7af18e46640f2482854')
+
+build() {
+ cd "${srcdir}/unarr-${pkgver}"
+ cmake ./ -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR:STRING=/usr/lib
+ make
+}
+
+package() {
+ cd "${srcdir}/unarr-${pkgver}"
+ make DESTDIR=$pkgdir install
+}