summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2022-12-27 08:46:03 +0100
committerFrederic Bezies2022-12-27 08:46:03 +0100
commit157b65389cfbb790632f1969dac343b3811ddf47 (patch)
treea8eeac99d7cb703f46d5c092668e70b492ebf0e0
parent0c32e22ddeb72933ed7252e519258f93a3bc5ab8 (diff)
downloadaur-157b65389cfbb790632f1969dac343b3811ddf47.tar.gz
2022.12.26 update
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e3cc1b9d5f3..e9a6d96ec80a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dosbox-x-sdl2
pkgdesc = x86 emulator with builtin DOS, with patches and more features
- pkgver = 2022.08.0
+ pkgver = 2022.12.26
pkgrel = 1
url = http://dosbox-x.com
arch = i686
@@ -11,13 +11,12 @@ pkgbase = dosbox-x-sdl2
depends = fluidsynth
depends = libxkbfile
depends = libxrandr
- depends = ffmpeg4.4
depends = sdl2_net
depends = libslirp
conflicts = dosbox-x-git
conflicts = dosbox-x
conflicts = dosbox-x-sdl2-git
- source = https://github.com/joncampbell123/dosbox-x/archive/dosbox-x-windows-v2022.08.0.tar.gz
- sha256sums = bac936ee198b607fb0cc55dfc4575e44b700dbc9138904d2e264792a6e6a941c
+ source = https://github.com/joncampbell123/dosbox-x/archive/dosbox-x-v2022.12.26.tar.gz
+ sha256sums = 39fb1ed19ea31e11883aa57655493b3100ac6b328ef59c799b840b9bfdfacb7b
pkgname = dosbox-x-sdl2
diff --git a/PKGBUILD b/PKGBUILD
index bcec6128141a..1c769930db79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,29 @@
# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
pkgname=dosbox-x-sdl2
-pkgver=2022.08.0
+pkgver=2022.12.26
pkgrel=1
pkgdesc="x86 emulator with builtin DOS, with patches and more features"
arch=(i686 x86_64 aarch64)
url="http://dosbox-x.com"
license=(GPL)
-depends=(fluidsynth libxkbfile libxrandr ffmpeg4.4 sdl2_net libslirp)
+depends=(fluidsynth libxkbfile libxrandr sdl2_net libslirp)
makedepends=(glu)
optdepends=()
conflicts=('dosbox-x-git' 'dosbox-x' 'dosbox-x-sdl2-git')
-source=(https://github.com/joncampbell123/dosbox-x/archive/dosbox-x-windows-v${pkgver}.tar.gz)
-sha256sums=('bac936ee198b607fb0cc55dfc4575e44b700dbc9138904d2e264792a6e6a941c')
+source=(https://github.com/joncampbell123/dosbox-x/archive/dosbox-x-v${pkgver}.tar.gz)
+sha256sums=('39fb1ed19ea31e11883aa57655493b3100ac6b328ef59c799b840b9bfdfacb7b')
build() {
- cd "$srcdir/dosbox-x-dosbox-x-windows-v$pkgver"
- # Workaround ffmpeg5, thanks to Grapelli on the bug opened on dosbox-x github page
- sed -i 's|"$LIBS -lavcodec -lavformat -lavutil -lswscale "`pkg-config libavcodec --libs`|`pkg-config libavcodec libavformat libavutil libswscale libswresample --libs`"$LIBS"|' configure.ac
+ cd "$srcdir/dosbox-x-dosbox-x-v$pkgver"
./autogen.sh
export LDFLAGS="${LDFLAGS//,--as-needed}"
chmod +x configure
- PKG_CONFIG_PATH="/usr/lib/ffmpeg4.4/pkgconfig" ./configure --enable-core-inline --disable-debug --enable-avcodec --prefix=/usr --enable-sdl2
+ ./configure --enable-core-inline --disable-debug --enable-avcodec --prefix=/usr --enable-sdl2
make -j$(nproc)
}
package() {
- cd "$srcdir/dosbox-x-dosbox-x-windows-v$pkgver"
+ cd "$srcdir/dosbox-x-dosbox-x-v$pkgver"
make DESTDIR="$pkgdir" install
}