summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2020-04-25 12:08:42 -0300
committerGonzalo Exequiel Pedone2020-04-25 12:08:42 -0300
commit15b9e5c2d4f5536da9efd18e801b530eff0ab986 (patch)
tree68dcb8cb3ad36d0dbadf9e254c88e7dfb9bacb6d
parentf812e19a22e596ce167a7705e5c3d2590b6b2f52 (diff)
downloadaur-15b9e5c2d4f5536da9efd18e801b530eff0ab986.tar.gz
Updated to Qt 5.14.2.
-rw-r--r--.SRCINFO10
-rw-r--r--0002-Force-64-bit-atomics-usage.patch33
-rw-r--r--0003-Fix-neon.patch44
-rw-r--r--PKGBUILD13
4 files changed, 45 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b61981d5c396..8fdcf4493f93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = android-x86-qt5
pkgdesc = Qt 5 for Android
- pkgver = 5.14.1
+ pkgver = 5.14.2
pkgrel = 1
url = https://www.qt.io
install = android-x86-qt5.install
@@ -38,12 +38,12 @@ pkgbase = android-x86-qt5
options = !buildflags
options = staticlibs
options = !emptydirs
- source = http://download.qt-project.org/official_releases/qt/5.14/5.14.1/single/qt-everywhere-src-5.14.1.tar.xz
+ source = http://download.qt-project.org/official_releases/qt/5.14/5.14.2/single/qt-everywhere-src-5.14.2.tar.xz
source = 0001-Support-pkg-config-under-Android.patch
- source = 0003-Fix-neon.patch
- md5sums = 781c3179410aff7ef84607214e1e91b4
+ source = 0002-Force-64-bit-atomics-usage.patch
+ md5sums = b3d2b6d00e6ca8a8ede6d1c9bdc74daf
md5sums = 6af9dcc450ae6c69d8fddccf0680d84a
- md5sums = 656c7eec7d37854cef1763c163c1ca98
+ md5sums = f17efcb3d46afefd9d2c011301fd53c5
pkgname = android-x86-qt5
diff --git a/0002-Force-64-bit-atomics-usage.patch b/0002-Force-64-bit-atomics-usage.patch
new file mode 100644
index 000000000000..6231b8f3ce3b
--- /dev/null
+++ b/0002-Force-64-bit-atomics-usage.patch
@@ -0,0 +1,33 @@
+--- a/qtbase/src/corelib/configure.json 2020-03-27 06:49:31.000000000 -0300
++++ b/qtbase/src/corelib/configure.json 2020-04-24 19:15:38.820283504 -0300
+@@ -135,27 +135,17 @@
+ "label": "64 bit atomics",
+ "test": {
+ "tail": [
+- "void test(volatile std::atomic<std::int64_t> &a)",
++ "void test()",
+ "{",
+- " std::int64_t v = a.load(std::memory_order_acquire);",
+- " while (!a.compare_exchange_strong(v, v + 1,",
+- " std::memory_order_acq_rel,",
+- " std::memory_order_acquire)) {",
+- " v = a.exchange(v - 1);",
+- " }",
+- " a.store(v + 1, std::memory_order_release);",
+ "}"
+ ],
+ "main": [
+- "void *ptr = (void*)0xffffffc0; // any random pointer",
+- "test(*reinterpret_cast<std::atomic<std::int64_t> *>(ptr));"
++ "test();"
+ ],
+ "qmake": "CONFIG += c++11"
+ },
+- "headers": [ "atomic", "cstdint" ],
+ "sources": [
+- "",
+- "-latomic"
++ ""
+ ]
+ },
+ "librt": {
diff --git a/0003-Fix-neon.patch b/0003-Fix-neon.patch
deleted file mode 100644
index 069aae3f4de6..000000000000
--- a/0003-Fix-neon.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- a/qtbase/src/corelib/global/qfloat16.cpp 2020-01-19 09:49:52.130475297 -0300
-+++ b/qtbase/src/corelib/global/qfloat16.cpp 2020-01-19 09:47:33.000000000 -0300
-@@ -204,7 +204,7 @@
-
- #undef f16cextern
- }
--
-+/*
- #elif defined(__ARM_FP16_FORMAT_IEEE) && defined(__ARM_NEON__)
- static inline bool hasFastF16()
- {
-@@ -229,7 +229,7 @@
- vst1q_f32(out + i, vcvt_f32_f16(vld1_f16(in_f16 + i)));
- SIMD_EPILOGUE(i, len, 3)
- out[i] = float(in_f16[i]);
--}
-+}*/
- #else
- static inline bool hasFastF16()
- {
-
---- a/qtbase/src/gui/painting/painting.pri 2019-12-07 03:27:07.000000000 -0300
-+++ b/qtbase/src/gui/painting/painting.pri 2020-01-19 10:07:08.307871293 -0300
-@@ -166,7 +166,7 @@
- DEFINES += QT_COMPILER_SUPPORTS_SSE4_1 QT_COMPILER_SUPPORTS_SSE4_2
- SOURCES += painting/qdrawhelper_sse4.cpp painting/qimagescale_sse4.cpp
- }
-- arm64-v8a {
-+ arm64-v8a | armeabi-v7a {
- SOURCES += painting/qdrawhelper_neon.cpp painting/qimagescale_neon.cpp
- HEADERS += painting/qdrawhelper_neon_p.h
- }
-
---- a/qtbase/src/gui/image/image.pri 2019-12-07 03:27:07.000000000 -0300
-+++ b/qtbase/src/gui/image/image.pri 2020-01-19 11:14:07.704965297 -0300
-@@ -97,7 +97,7 @@
- MIPS_DSPR2_ASM += image/qimage_mips_dspr2_asm.S
- } else {
- # see https://developer.android.com/ndk/guides/abis
-- arm64-v8a {
-+ arm64-v8a | armeabi-v7a {
- SOURCES += image/qimage_neon.cpp
- }
- x86 | x86_64 {
diff --git a/PKGBUILD b/PKGBUILD
index 8eb012cf849f..bba56ca58f29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
_android_arch=x86
pkgname=android-${_android_arch}-qt5
-pkgver=5.14.1
+pkgver=5.14.2
pkgrel=1
pkgdesc="Qt 5 for Android"
arch=('any')
@@ -65,10 +65,10 @@ _pkgfqn="qt-everywhere-src-${pkgver}"
install="${pkgname}.install"
source=("http://download.qt-project.org/official_releases/qt/${pkgver:0:4}/${pkgver}/single/${_pkgfqn}.tar.xz"
"0001-Support-pkg-config-under-Android.patch"
- "0003-Fix-neon.patch")
-md5sums=('781c3179410aff7ef84607214e1e91b4'
+ "0002-Force-64-bit-atomics-usage.patch")
+md5sums=('b3d2b6d00e6ca8a8ede6d1c9bdc74daf'
'6af9dcc450ae6c69d8fddccf0680d84a'
- '656c7eec7d37854cef1763c163c1ca98')
+ 'f17efcb3d46afefd9d2c011301fd53c5')
prepare() {
cd ${_pkgfqn}
@@ -80,8 +80,8 @@ prepare() {
patch -Np1 -i "../0001-Support-pkg-config-under-Android.patch"
case "$_android_arch" in
- armv7a-eabi)
- patch -Np1 -i "../0003-Fix-neon.patch"
+ aarch64 | x86-64)
+ patch -Np1 -i "../0002-Force-64-bit-atomics-usage.patch"
;;
*)
;;
@@ -115,6 +115,7 @@ build() {
-examplesdir ${ANDROID_PREFIX_SHARE}/qt5/examples
-testsdir ${ANDROID_PREFIX_SHARE}/qt5/tests
-xplatform android-clang
+ --disable-rpath
-nomake tests
-nomake examples
-skip qtserialport