summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrealgagu2018-04-02 13:37:49 -0500
committerfrealgagu2018-04-02 13:37:49 -0500
commit15d1448aa1d8bb80b775578535ee35a893e29e49 (patch)
tree1928138f27e407d8ef4b51face295f7d4db0b54e
parent6bc653115901a00b921d0be5d76ed9702f02151d (diff)
downloadaur-15d1448aa1d8bb80b775578535ee35a893e29e49.tar.gz
Installing in /usr/bin instead of /usr/local/bin according to Arch packaging standards
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD19
3 files changed, 22 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8db0f22d0134..df2f6be1d1fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,20 @@
pkgbase = welle.io
- pkgdesc = Open source DAB and DAB+ software defined radio (SDR) with support for rtl-sdr (RTL2832U) and airspy
+ pkgdesc = An open source DAB and DAB+ software defined radio (SDR) with support for rtl-sdr (RTL2832U) and airspy
pkgver = 1.0
- pkgrel = 2
+ pkgrel = 3
url = https://www.welle.io
- arch = any
+ arch = x86_64
license = GPL2
makedepends = gcc
makedepends = cmake
depends = faad2
depends = fftw
- depends = libusb
- depends = qt5-base
depends = qt5-charts
depends = qt5-declarative
depends = qt5-multimedia
- depends = qt5-quickcontrols2
depends = rtl-sdr
optdepends = airspy
+ optdepends = qt5-quickcontrols2
source = welle.io-1.0.tar.gz::https://github.com/AlbrechtL/welle.io/archive/V1.0.tar.gz
sha256sums = 669ae5d471f723c32622cbf6ee37b66c3aefd8e02d6334b55d1fb60b3c22a883
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cd44cc0a3206
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+welle.io-*.pkg.tar.xz
+welle.io-*.tar.gz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index 98b9ffa9ee80..4f4ecf0dbd1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=welle.io
pkgver=1.0
-pkgrel=2
-pkgdesc="Open source DAB and DAB+ software defined radio (SDR) with support for rtl-sdr (RTL2832U) and airspy"
-arch=("any")
+pkgrel=3
+pkgdesc="An open source DAB and DAB+ software defined radio (SDR) with support for rtl-sdr (RTL2832U) and airspy"
+arch=("x86_64")
url="https://www.${pkgname}"
license=("GPL2")
-depends=("faad2" "fftw" "libusb" "qt5-base" "qt5-charts" "qt5-declarative" "qt5-multimedia" "qt5-quickcontrols2" "rtl-sdr")
+depends=("faad2" "fftw" "qt5-charts" "qt5-declarative" "qt5-multimedia" "rtl-sdr")
+optdepends=("airspy" "qt5-quickcontrols2")
makedepends=("gcc" "cmake")
-optdepends=("airspy")
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/AlbrechtL/${pkgname}/archive/V${pkgver}.tar.gz")
sha256sums=("669ae5d471f723c32622cbf6ee37b66c3aefd8e02d6334b55d1fb60b3c22a883")
@@ -21,8 +21,17 @@ build() {
}
package() {
+ msg2 "Installing desktop file into /usr/share/applications/"
install -D -m 0644 "${srcdir}/${pkgname}-${pkgver}/${pkgname/./-}.desktop" "${pkgdir}/usr/share/applications/${pkgname/./-}.desktop"
+
+ msg2 "Installing icon into /usr/share/pixmaps/"
install -D -m 0644 "${srcdir}/${pkgname}-${pkgver}/icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname/./-}.png"
+
+ msg2 "Installing application"
cd "${pkgname}-${pkgver}/build"
make DESTDIR=${pkgdir} install
+
+ msg2 "Moving from /usr/local/bin to /usr/bin to match Arch packaging standards"
+ mv "${pkgdir}/usr/local/"* "${pkgdir}/usr/"
+ rm -r "${pkgdir}/usr/local"
}