summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Diehl2023-10-10 12:39:57 +0200
committerMartin Diehl2023-10-10 12:39:57 +0200
commit15d70af71e30233eb9a906b889b75406f4b1d4d5 (patch)
tree094b9d0611eb370a24ec7427c030e97ce8e6ea5a
parent61fa84a783323afe6eb41ca1d9b86699694b8523 (diff)
downloadaur-15d70af71e30233eb9a906b889b75406f4b1d4d5.tar.gz
modern build
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3d5e1c51947d..6b1b22a9d835 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Martin Diehl <aur@martin-diehl.net>
pkgver=0.42.3
-pkgrel=1
+pkgrel=2
pkgname=python-pyvista
_name=${pkgname#python-}
pkgdesc='3D plotting and mesh analysis through a streamlined interface for the Visualization Toolkit (VTK)'
@@ -16,11 +16,11 @@ sha512sums=('822d8829b3ccb4110040007e2f59393969ce5a2de8c320abbe2e2f017b815ee0d26
build() {
cd "$_name-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$_name-$pkgver"
- python setup.py install --skip-build --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}