summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjuju21432020-02-09 16:06:53 -0500
committerjuju21432020-02-09 16:06:53 -0500
commit15f34c2ed08cd9e3f66a1042f3320cddea7e3406 (patch)
tree855218a3f90da586b89880e348847c79d83e54ee
parent1ed55730521ff050871ec5cac0c729b1bfcb1e0a (diff)
downloadaur-15f34c2ed08cd9e3f66a1042f3320cddea7e3406.tar.gz
Revert back to original source URL
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc5c17a0e3b7..b68af519e374 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,9 +10,9 @@ pkgbase = x16-rom
makedepends = cc65
makedepends = pandoc
optdepends = x16-emulator: emulator for the ROMs
- source = x16-rom-98d773e203a5e853741db323d927fbc066f2507d.tar.gz::https://github.com/mist64/x16-rom/archive/98d773e203a5e853741db323d927fbc066f2507d.tar.gz
- source = https://raw.githubusercontent.com/mist64/x16-emulator/r36/github-pandoc.css
- md5sums = 471e63a8da769a548a918ff44c32774e
+ source = x16-rom-r36.tar.gz::https://github.com/commanderx16/x16-rom/archive/r36.tar.gz
+ source = https://raw.githubusercontent.com/commanderx16/x16-emulator/r36/github-pandoc.css
+ md5sums = 248d486c05320c7579abd7204a3f2b32
md5sums = 3accdbadaf70264c743b1f655f5dc146
pkgname = x16-rom
diff --git a/PKGBUILD b/PKGBUILD
index eb6af4e3bc57..b3293e9cd120 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,6 @@
# Maintainer: Julien Savard <juju@juju2143.ca>
pkgname=x16-rom
pkgver=r36
-_realpkgver=98d773e203a5e853741db323d927fbc066f2507d
pkgrel=1
pkgdesc="ROM files for The 8-Bit Guy's Commander X16"
arch=('any')
@@ -17,20 +16,20 @@ replaces=()
options=()
install=x16-rom.install
changelog=
-source=("$pkgname-${_realpkgver}.tar.gz::https://github.com/mist64/$pkgname/archive/${_realpkgver}.tar.gz"
- "https://raw.githubusercontent.com/mist64/x16-emulator/$pkgver/github-pandoc.css")
-md5sums=('471e63a8da769a548a918ff44c32774e'
+source=("$pkgname-$pkgver.tar.gz::https://github.com/commanderx16/$pkgname/archive/$pkgver.tar.gz"
+ "https://raw.githubusercontent.com/commanderx16/x16-emulator/$pkgver/github-pandoc.css")
+md5sums=('248d486c05320c7579abd7204a3f2b32'
'3accdbadaf70264c743b1f655f5dc146')
build() {
- cd "$pkgname-${_realpkgver}"
+ cd "$pkgname-$pkgver"
_pkgver1=${pkgver#r}
make PRERELEASE_VERSION=${_pkgver1%%[^0-9]*}
pandoc --from gfm --to html -c github-pandoc.css --standalone --metadata pagetitle="X16 KERNAL/BASIC/DOS ROM" README.md --output KERNAL-BASIC.html
}
package() {
- cd "$pkgname-${_realpkgver}"
+ cd "$pkgname-$pkgver"
install -Dm644 rom.bin "$pkgdir/usr/share/$pkgname/rom.bin"
install -Dm644 ../github-pandoc.css "$pkgdir/usr/share/doc/$pkgname/github-pandoc.css"
install -Dm644 KERNAL-BASIC.html "$pkgdir/usr/share/doc/$pkgname/KERNAL-BASIC.html"