summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Poellmann2023-07-01 20:52:33 +0000
committerDaniel Poellmann2023-07-01 20:52:33 +0000
commit15f601428cdc8624a6aa9d96607cd35cc652db04 (patch)
tree65dc0994b825c24284b21cea6dc456f1ff7c4129
parent92adc110487e28e6b6fbd9f90c85a631eb3846a1 (diff)
downloadaur-15f601428cdc8624a6aa9d96607cd35cc652db04.tar.gz
parallel build according to ncpu
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03944237b6d3..a9851bb89c7b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = linphone-desktop
pkgdesc = A free VoIP and video softphone based on the SIP protocol
pkgver = 5.0.18
- pkgrel = 2
+ pkgrel = 3
url = http://linphone.org
arch = x86_64
license = GPL
+ makedepends = coreutils
makedepends = git
makedepends = gendesk
makedepends = cmake
diff --git a/PKGBUILD b/PKGBUILD
index d692de91ee79..d14a2fdedcaa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=linphone-desktop
pkgver=5.0.18
-pkgrel=2
+pkgrel=3
pkgdesc='A free VoIP and video softphone based on the SIP protocol'
arch=(x86_64)
url='http://linphone.org'
license=(GPL)
depends=('qt5-base' 'libxcrypt-compat' 'v4l-utils' 'glew')
-makedepends=('git' 'gendesk' 'cmake' 'yasm' 'nasm' 'doxygen' 'perl' 'python-pystache' 'python-six' 'libpulse' 'qt5-base' 'qt5-declarative' 'qt5-quickcontrols2' 'qt5-svg' 'qt5-tools')
+makedepends=('coreutils' 'git' 'gendesk' 'cmake' 'yasm' 'nasm' 'doxygen' 'perl' 'python-pystache' 'python-six' 'libpulse' 'qt5-base' 'qt5-declarative' 'qt5-quickcontrols2' 'qt5-svg' 'qt5-tools')
source=("git+https://github.com/BelledonneCommunications/linphone-desktop.git#commit=88f05be"
"linphone.png::https://gitlab.linphone.org/BC/public/linphone-desktop/-/raw/8dfd384e3df08b200c8eb382b740da6839961bf0/linphone-app/assets/icons/hicolor/128x128/apps/icon.png"
)
@@ -24,8 +24,8 @@ build() {
git submodule update --init --recursive
mkdir -p build build/OUTPUT && cd build
- cmake .. -DCMAKE_BUILD_PARALLEL_LEVEL=10 -DCMAKE_BUILD_TYPE=RelWithDebInfo
- cmake --build . --target install --parallel 10 --config RelWithDebInfo
+ cmake .. -DCMAKE_BUILD_PARALLEL_LEVEL=$(nproc) -DCMAKE_BUILD_TYPE=RelWithDebInfo
+ cmake --build . --target install --parallel $(nproc) --config RelWithDebInfo
cd "$srcdir"
gendesk -f -n \