summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTommy Jerry Mairo2022-01-04 15:04:09 -0800
committerTommy Jerry Mairo2022-01-04 15:04:09 -0800
commit15f840dea2d899772333d787f1eef885ba523e2f (patch)
treeb426d59eeaea50cd8643daa131ec0f0106c10274
parent3f9c18df43476114c1d0378033b423a4052290cc (diff)
downloadaur-15f840dea2d899772333d787f1eef885ba523e2f.tar.gz
Update: remove patch as checked in upstream
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD13
-rw-r--r--UPnPBase.patch24
4 files changed, 11 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab5b57a68beb..0bb1b04b33f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = amule-dlp-git
pkgdesc = An eMule-like client for ed2k p2p network with DLP patch
- pkgver = 2.3.2.r10525.07932e9a3
- pkgrel = 3
+ pkgver = 2.3.2.r10607.78a95e54e
+ pkgrel = 1
url = https://github.com/persmule/amule-dlp
install = amule.install
arch = i686
@@ -22,14 +22,11 @@ pkgbase = amule-dlp-git
conflicts = amule
conflicts = amule-dlp
conflicts = amule-dlp-hg
- source = git+https://github.com/persmule/amule-dlp.git#commit=07932e9a37f88f3daa1322628f2db818178c258b
+ source = git+https://github.com/persmule/amule-dlp.git
source = amuled.systemd
source = amuleweb.systemd
- source = UPnPBase.patch
sha256sums = SKIP
sha256sums = 6dbdd1ad1c3c3d8637b8f4cbd5416f39c8e4277a2f8498577b08bf6cda8dbca9
sha256sums = f4f43b1154ddccc9036a4291a58c6715f097b171fec62ea7aead0c9d9fa654f2
- sha256sums = efc6a7c93f04cbeafc4aa4b3db28e22992a8a435f41708a97c5d190c9466b306
pkgname = amule-dlp-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f33fcf244178
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+amule-dlp/
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
index a1a8f491e3fa..d87ff69834d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
# Contributor: Dario 'Dax' Vilardi <dax [at] deelab [dot] org>
# Contributor: Anatol Pomozov <anatol.pomozov@gmail.com>
pkgname=amule-dlp-git
-pkgver=2.3.2.r10525.07932e9a3
-pkgrel=3
+pkgver=2.3.2.r10607.78a95e54e
+pkgrel=1
pkgdesc="An eMule-like client for ed2k p2p network with DLP patch"
arch=('i686' 'x86_64')
url="https://github.com/persmule/amule-dlp"
@@ -18,14 +18,12 @@ makedepends=('git' 'boost')
optdepends=('antileech')
install=amule.install
provides=('amule' 'amule-dlp')
-source=("git+https://github.com/persmule/amule-dlp.git#commit=07932e9a37f88f3daa1322628f2db818178c258b"
+source=("git+https://github.com/persmule/amule-dlp.git"
'amuled.systemd'
- 'amuleweb.systemd'
- 'UPnPBase.patch')
+ 'amuleweb.systemd')
sha256sums=('SKIP'
'6dbdd1ad1c3c3d8637b8f4cbd5416f39c8e4277a2f8498577b08bf6cda8dbca9'
- 'f4f43b1154ddccc9036a4291a58c6715f097b171fec62ea7aead0c9d9fa654f2'
- 'efc6a7c93f04cbeafc4aa4b3db28e22992a8a435f41708a97c5d190c9466b306')
+ 'f4f43b1154ddccc9036a4291a58c6715f097b171fec62ea7aead0c9d9fa654f2')
pkgver() {
cd "${srcdir}/amule-dlp"
@@ -35,7 +33,6 @@ pkgver() {
prepare(){
cd "${srcdir}/amule-dlp"
cp src/aMule.xpm amule.xpm
- patch -p1 < ../UPnPBase.patch
}
build() {
diff --git a/UPnPBase.patch b/UPnPBase.patch
deleted file mode 100644
index f01fc3a575df..000000000000
--- a/UPnPBase.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/src/UPnPBase.cpp 2020-10-23 05:30:49.252207564 -0700
-+++ b/src/UPnPBase.cpp 2020-10-23 05:26:15.927719211 -0700
-@@ -824,13 +824,17 @@
- // Null string at first
- std::ostringstream msg;
-
-+ // Declare those here to avoid
-+ // "jump to label ‘error’ [-fpermissive] crosses initialization
-+ // of ‘char* ipAddress’"
-+ unsigned short port;
-+ char *ipAddress;
-+
- // Start UPnP
- int ret;
-- char *ipAddress = NULL;
-- unsigned short port = 0;
-- ret = UpnpInit(ipAddress, udpPort);
-+ ret = UpnpInit2(0, udpPort);
- if (ret != UPNP_E_SUCCESS) {
-- msg << "error(UpnpInit): Error code ";
-+ msg << "error(UpnpInit2): Error code ";
- goto error;
- }
- port = UpnpGetServerPort();