summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2022-12-16 23:04:53 -0500
committerTed Alff2022-12-16 23:04:53 -0500
commit15fd359dbc1a80989f2fc250f2d4c23fe1f336f4 (patch)
treed60afbea0918ec809cc0024bf6dc77ac11c7069a
parentd47d1f2fa37b25b065693d17f9c64a8dd1c842ef (diff)
downloadaur-15fd359dbc1a80989f2fc250f2d4c23fe1f336f4.tar.gz
Switch to hhannine branch
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
-rw-r--r--python3.10_fix.patch12
-rw-r--r--rename_without_310.patch12
4 files changed, 30 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 668d6ff414d2..c26bfd15979d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = python-system_hotkey
pkgdesc = Python library for system wide hotkeys
- pkgver = 1.0.2+12+37073bb
- pkgrel = 2
- url = https://github.com/timeyyy/system_hotkey
+ pkgver = 1.0.5
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/hhannine/system_hotkey310
arch = any
license = BSD
makedepends = python-setuptools
- makedepends = git
depends = python-xcffib
- source = python-system_hotkey::git+https://github.com/timeyyy/system_hotkey
- source = python3.10_fix.patch
+ source = python-system_hotkey::git+https://github.com/hhannine/system_hotkey310#commit=c0ee3549d5a1c66dee90ec669c95c4c0a81ab050
+ source = rename_without_310.patch
sha256sums = SKIP
- sha256sums = 2f15f1ebeb95e1b3e9cccfeac6f05da1af98b634834d912d02e807c3cc0a0df2
+ sha256sums = 4bc354ad56f76ebbaf49111eea73080e1133eff42f2484b521be5c73a01bbad2
pkgname = python-system_hotkey
diff --git a/PKGBUILD b/PKGBUILD
index 10a80ec30341..3fbd6e51495a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,28 @@
# Contributor: twa022 <twa022 at gmail dot com>
pkgname=python-system_hotkey
-_pkgver=1.0.2
-pkgver=1.0.2+12+37073bb
-pkgrel=2
+epoch=1
+pkgver=1.0.5
+pkgrel=1
pkgdesc="Python library for system wide hotkeys"
arch=('any')
-url="https://github.com/timeyyy/system_hotkey"
+#url="https://github.com/timeyyy/system_hotkey"
+url="https://github.com/hhannine/system_hotkey310"
license=('BSD')
depends=('python-xcffib')
-makedepends=('python-setuptools' 'git')
-source=("${pkgname}::git+https://github.com/timeyyy/system_hotkey"
- 'python3.10_fix.patch')
+makedepends=('python-setuptools')
+_commit='c0ee3549d5a1c66dee90ec669c95c4c0a81ab050'
+source=("${pkgname}::git+${url}#commit=${_commit}"
+ 'rename_without_310.patch')
sha256sums=('SKIP'
- '2f15f1ebeb95e1b3e9cccfeac6f05da1af98b634834d912d02e807c3cc0a0df2')
-_release_commit='f30711752d0d4510cda2a213e4ec9c665677e167'
-#source=("${pkgname}-${pkgver}.tar.gz::https://github.com/timeyyy/${pkgname/python-/}/archive/${pkgver}.tar.gz")
-#sha256sums=('4d6e06bf359efecf4bea251e330c852f83b9150f503df28fd94239499f4ff606')
+ '4bc354ad56f76ebbaf49111eea73080e1133eff42f2484b521be5c73a01bbad2')
prepare() {
cd "${srcdir}/${pkgname}"
- patch -uNp2 -r- -i ../python3.10_fix.patch
-}
-
-pkgver() {
-# cd "${srcdir}/${pkgname/python-/}-${pkgver}"
- cd "${srcdir}/${pkgname}"
- printf "%s+%s+%s" "${_pkgver}" "$(( `git rev-list --count HEAD` - `git rev-list --count ${_release_commit}` ))" "$( git describe --always )"
+ patch -Np2 -r- -i ../rename_without_310.patch
}
package() {
-# cd "${srcdir}/${pkgname/python-/}-${pkgver}"
cd "${srcdir}/${pkgname}"
python setup.py install --root="${pkgdir}"
}
diff --git a/python3.10_fix.patch b/python3.10_fix.patch
deleted file mode 100644
index d93efc78b9af..000000000000
--- a/python3.10_fix.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur ./python-system_hotkey.orig/system_hotkey/system_hotkey.py ./python-system_hotkey/system_hotkey/system_hotkey.py
---- ./python-system_hotkey.orig/system_hotkey/system_hotkey.py 2021-12-15 12:22:51.996228526 -0500
-+++ ./python-system_hotkey/system_hotkey/system_hotkey.py 2021-12-15 12:23:31.192184801 -0500
-@@ -285,7 +285,7 @@
-
- thread safe
- '''
-- assert isinstance(hotkey, collections.Iterable) and type(hotkey) not in (str, bytes)
-+ assert isinstance(hotkey, collections.abc.Iterable) and type(hotkey) not in (str, bytes)
- if self.consumer == 'callback' and not callback:
- raise TypeError('Function register requires callback argument in non sonsumer mode')
-
diff --git a/rename_without_310.patch b/rename_without_310.patch
new file mode 100644
index 000000000000..31fa079b96a4
--- /dev/null
+++ b/rename_without_310.patch
@@ -0,0 +1,12 @@
+diff -Naur ./python-system_hotkey.orig/setup.py ./python-system_hotkey/setup.py
+--- ./python-system_hotkey.orig/setup.py 2022-12-16 22:52:33.318586219 -0500
++++ ./python-system_hotkey/setup.py 2022-12-16 22:53:26.232640510 -0500
+@@ -9,7 +9,7 @@
+ return f.read()
+
+ setup(
+- name = 'system_hotkey310',
++ name = 'system_hotkey',
+ version='1.0.5',
+ description = 'System wide hotkeys',
+ long_description = (read('README.rst') + '\n\n' +