summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOlivier Galibert2015-09-12 13:44:49 +0200
committerOlivier Galibert2015-09-12 13:44:49 +0200
commit1607c76c96138b0c023ef6694c428dc069d42d27 (patch)
tree8b2ebff79283ad47cdf88a38789b97d4337c1bb6
downloadaur-1607c76c96138b0c023ef6694c428dc069d42d27.tar.gz
Update to 0.0.12
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
-rw-r--r--emacs-yaml-mode.install19
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..40fc767d0246
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by makepkg 4.2.1
+# Sat Sep 12 11:42:22 UTC 2015
+pkgbase = emacs-yaml-mode
+ pkgdesc = Emacs major mode for editing files in the YAML data serialization format
+ pkgver = 0.0.12
+ pkgrel = 1
+ url = https://github.com/yoshiki/yaml-mode
+ install = emacs-yaml-mode.install
+ arch = any
+ license = GPL
+ depends = emacs
+ source = https://github.com/yoshiki/yaml-mode/archive/v0.0.12.tar.gz
+ md5sums = 8976243eee9d7df0fdb8fa99a698035a
+
+pkgname = emacs-yaml-mode
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb740f3f4405
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Olivier Galibert <galibert@pobox.com>
+# Contributor: Philip Mueller <mail at philip.in-aachen dot net>
+pkgname=emacs-yaml-mode
+pkgver=0.0.12
+pkgrel=1
+pkgdesc="Emacs major mode for editing files in the YAML data serialization format"
+arch=('any')
+url="https://github.com/yoshiki/yaml-mode"
+license=('GPL')
+groups=()
+depends=('emacs')
+install=emacs-yaml-mode.install
+source=https://github.com/yoshiki/yaml-mode/archive/v$pkgver.tar.gz
+md5sums=('8976243eee9d7df0fdb8fa99a698035a')
+
+package() {
+ cd $srcdir/yaml-mode-$pkgver
+ # Install the mode for Emacs
+ install -D -m644 yaml-mode.el $pkgdir/usr/share/emacs/site-lisp/yaml-mode.el
+}
diff --git a/emacs-yaml-mode.install b/emacs-yaml-mode.install
new file mode 100644
index 000000000000..e8819e5971ea
--- /dev/null
+++ b/emacs-yaml-mode.install
@@ -0,0 +1,19 @@
+post_install () {
+
+cat << EOF
+
+==> Add this code to your .emacs file to use the mode:
+
+(require 'yaml-mode)
+(add-to-list 'auto-mode-alist '("\\.yml\\'" . yaml-mode))
+
+EOF
+}
+
+post_upgrade () {
+ post_install $1
+}
+
+op=$1
+shift
+$op $*