summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Shi2020-07-02 11:20:17 +0800
committerSimon Shi2020-07-02 11:20:17 +0800
commit160d771a2985dd420fd32543e8e218f1f1232f09 (patch)
treeb22ba2f30c56dde887fe4f37ac75ef2b31a0418a
parentb4a61f4abadea03544234ac2c673271b7b3f00ae (diff)
downloadaur-160d771a2985dd420fd32543e8e218f1f1232f09.tar.gz
Update PKGBUILD
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD24
2 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ff4f3651966..d5b5ab2b8e3e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
-# Generated by mksrcinfo v8
-# Wed Apr 25 17:42:22 UTC 2018
pkgbase = imgpatchtools
pkgdesc = Patch img files with system.patch.dat, like OTA zip on PC
- pkgver = 0.3.r5.g64a745d
+ pkgver = 0.3.r11.g30dcd07
pkgrel = 1
url = https://github.com/erfanoabdi/imgpatchtools
arch = any
- license = GPL
+ license = GPL3
makedepends = git
+ makedepends = gcc
+ makedepends = make
depends = zlib
depends = bzip2
depends = openssl
diff --git a/PKGBUILD b/PKGBUILD
index 7031ef42bbb5..eb44787da1c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,30 @@
# Maintainer : Özgür Sarıer <echo b3pndXJzYXJpZXIxMDExNjAxMTE1QGdtYWlsLmNvbQo= | base64 -d>
+# Maintainer : Simon Shi <simonsmh@gmail.com>
pkgname=imgpatchtools
-pkgver=0.3.r5.g64a745d
+pkgver=0.3.r11.g30dcd07
pkgrel=1
pkgdesc="Patch img files with system.patch.dat, like OTA zip on PC"
-arch=('any')
+arch=(x86_64 aarch64)
url="https://github.com/erfanoabdi/imgpatchtools"
-license=('GPL')
-depends=('zlib' 'bzip2' 'openssl')
-makedepends=('git')
+license=(GPL3)
+makedepends=(git zlib bzip2 openssl)
source=("git+https://github.com/erfanoabdi/$pkgname.git")
-md5sums=('SKIP')
+sha256sums=(SKIP)
pkgver() {
- cd "${srcdir}/$pkgname"
-
+ cd "$pkgname"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${srcdir}/$pkgname"
+ cd "$pkgname"
make all
}
package() {
- cd "${srcdir}/$pkgname"
- install -d "${pkgdir}/usr/bin/"
- install -Dm0755 ./bin/* "${pkgdir}/usr/bin/"
+ cd "$pkgname"
+ install -d "$pkgdir"/usr/bin/
+ install -Dm755 bin/* "$pkgdir"/usr/bin/
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
}