summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2019-10-21 12:05:49 -0400
committerAndrew Sun2019-10-21 12:05:49 -0400
commit16248916908febb980b928605f2db66a4156a01e (patch)
treef90ebe58a4519d8ae42c6280a464e3a035eaa4fd
parentb5f46b51ba12b15b296971504924078317aa2a63 (diff)
downloadaur-16248916908febb980b928605f2db66a4156a01e.tar.gz
5.3
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD31
2 files changed, 22 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a23428ca710..33e9394dc27a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
-# Generated by mksrcinfo v8
-# Wed Aug 24 12:03:13 UTC 2016
pkgbase = fntsample
- pkgdesc = For making font samples that show Unicode coverage of the font and are similar in appearance to Unicode charts (includes pdfoutline).
- pkgver = 4.1
+ pkgdesc = PDF and PostScript font samples generator
+ pkgver = 5.3
pkgrel = 1
- url = http://fntsample.sourceforge.net/
+ url = https://github.com/eugmes/fntsample
arch = i686
arch = x86_64
license = GPL3
+ makedepends = cmake
depends = cairo
depends = fontconfig
depends = freetype2
@@ -16,8 +15,8 @@ pkgbase = fntsample
depends = unicode-character-database
depends = perl-pdf-api2
depends = perl-libintl-perl
- source = http://downloads.sourceforge.net/project/fntsample/fntsample/4.1/fntsample-4.1.tar.gz
- md5sums = 109aab88b4ea4a3a78ca415dff3df6f3
+ source = fntsample-5.3.tar.gz::https://github.com/eugmes/fntsample/archive/release/5.3.tar.gz
+ sha256sums = e4e8b50b0a5e984cfdaa32b7d133bd3bf0c62edb14f752f7df1190176023972b
pkgname = fntsample
diff --git a/PKGBUILD b/PKGBUILD
index 485907c20756..ac5afbddb68e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,28 @@
-# Maintainer: Felix Schindler <aur at schindlerfmily dot de>
+# Maintainer: Andrew Sun <adsun701 at gmail dot com>
+# Contributor: Felix Schindler <aur at schindlerfmily dot de>
+
pkgname=fntsample
-pkgver=4.1
+pkgver=5.3
pkgrel=1
-pkgdesc="For making font samples that show Unicode coverage of the font and are similar in appearance to Unicode charts (includes pdfoutline)."
-url=http://fntsample.sourceforge.net/
-license=(GPL3)
+pkgdesc="PDF and PostScript font samples generator"
+url="https://github.com/eugmes/fntsample"
+license=('GPL3')
arch=(i686 x86_64)
depends=(cairo fontconfig freetype2 glib2 pango unicode-character-database perl-pdf-api2 perl-libintl-perl)
-source=(http://downloads.sourceforge.net/project/fntsample/fntsample/4.1/fntsample-4.1.tar.gz)
-md5sums=('109aab88b4ea4a3a78ca415dff3df6f3')
+makedepends=('cmake')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/eugmes/fntsample/archive/release/${pkgver}.tar.gz")
+sha256sums=('e4e8b50b0a5e984cfdaa32b7d133bd3bf0c62edb14f752f7df1190176023972b')
build() {
- cd ${pkgname}-${pkgver}
-
- ./configure --prefix=${pkgdir}/usr --with-unicode-blocks=/usr/share/unicode-character-database/Blocks.txt
+ mkdir -p "${srcdir}/build" && cd "${srcdir}/build"
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ ../${pkgname}-release-${pkgver}
make
}
package() {
- cd ${pkgname}-${pkgver}
-
- make install
-
- sed -i "s;${pkgdir};/;g" ${pkgdir}/usr/bin/pdfoutline
+ cd "${srcdir}/build"
+ make DESTDIR=${pkgdir} install
}