summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2022-11-02 17:22:50 +0800
committerJingbei Li2022-11-02 17:22:50 +0800
commit1628ed5eb958fdf958da34f7e79b085937975bc2 (patch)
treef184704d34024aa31d5d4fba4c61d493ddda3f58
parentbced73dc6cbbe1f9e1e08f94e5000ef671e6d057 (diff)
downloadaur-1628ed5eb958fdf958da34f7e79b085937975bc2.tar.gz
fixed PKGBUILD
-rw-r--r--.gitignore3
-rw-r--r--Makefile.inc1
-rw-r--r--PKGBUILD56
3 files changed, 36 insertions, 24 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..edb011e3450d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar*
+*/
+*.log
diff --git a/Makefile.inc b/Makefile.inc
index e7db5be514a9..9661c4146073 100644
--- a/Makefile.inc
+++ b/Makefile.inc
@@ -16,7 +16,6 @@
# Metis/ParMetis and SCOTCH/PT-SCOTCH (ver 6.0 and later) orderings are now available for MUMPS.
#
-SONAME_VERSION=5.3
SCOTCHDIR = /usr
ISCOTCH = -I$(SCOTCHDIR)/include/scotch
# You have to choose one among the following two lines depending on
diff --git a/PKGBUILD b/PKGBUILD
index 3a834613e3b5..4ac2ad9db3ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,32 +7,43 @@ pkgrel=1
pkgdesc="Sparse solver library using Gaussian elimination, with parmetis implementation"
url="https://graal.ens-lyon.fr/MUMPS/index.php"
license=("custom")
-depends=('lapack' 'openmpi' 'scotch>=6.0.3-3' 'scalapack' 'parmetis' 'metis' 'zlib' 'bzip2')
+depends=('lapack' 'openmpi' 'scotch' 'scalapack' 'parmetis' 'metis' 'zlib' 'bzip2')
makedepends=('gcc-fortran')
provides=('mumps')
conflicts=('mumps')
-backup=()
arch=('i686' 'x86_64')
source=(https://graal.ens-lyon.fr/MUMPS/MUMPS_${pkgver}.tar.gz
- Makefile.inc
- MUMPS-shared.patch
- MUMPS-shared-pord.patch
- MUMPS-shared-seq.patch)
+ Makefile.inc)
sha256sums=('1abff294fa47ee4cfd50dfd5c595942b72ebfcedce08142a75a99ab35014fa15'
- 'b5d3baf74f14f30f7888cc6847ffdf43184aaa9609dd21b9d9ab94a9070639ee'
- '51c754c0d34b461f3635ce2731f82e9c51d512528caf72cac5041380259d063d'
- 'e47d0bb48d278c96963bf0de2a6282836fef80af4344376c2a796c59c723053f'
- '6ae456e4969d1af5ce8f209932d65f2d2dbe475a1fa99c303a6eb92d6771788f')
+ '4bcc8c53626ed69e63d9f086e4262c586c534b9817b7236df63a4164387e2ea7')
-build() {
+prepare() {
cd "${srcdir}/MUMPS_${pkgver}"
cp "${srcdir}/Makefile.inc" .
- patch -Np0 < ../MUMPS-shared.patch
- patch -Np0 < ../MUMPS-shared-pord.patch
- patch -Np0 < ../MUMPS-shared-seq.patch
-
- export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:${srcdir}/MUMPS_${pkgver}/lib
- SONAME_VERSION=$pkgver make -j1 alllib || return 1
+}
+
+build() {
+ cd "${srcdir}/MUMPS_${pkgver}"
+ make all
+}
+
+check () {
+ cd "${srcdir}/MUMPS_${pkgver}/examples"
+ make all
+ # From the README (in examples)
+ MPIRUN="mpirun -np 3 --mca plm_rsh_agent sh --mca opal_warn_on_missing_libcuda 0 --oversubscribe"
+ export LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:${srcdir}/MUMPS_${pkgver}/lib"
+ ${MPIRUN} ./ssimpletest < input_simpletest_real
+ ${MPIRUN} ./dsimpletest < input_simpletest_real
+ ${MPIRUN} ./csimpletest < input_simpletest_cmplx
+ ${MPIRUN} ./zsimpletest < input_simpletest_cmplx
+ ${MPIRUN} ./c_example
+ ${MPIRUN} ./multiple_arithmetics_example
+ ${MPIRUN} ./ssimpletest_save_restore < input_simpletest_real
+ ${MPIRUN} ./dsimpletest_save_restore < input_simpletest_real
+ ${MPIRUN} ./csimpletest_save_restore < input_simpletest_cmplx
+ ${MPIRUN} ./zsimpletest_save_restore < input_simpletest_cmplx
+ ${MPIRUN} ./c_example_save_restore
}
package(){
@@ -42,9 +53,9 @@ package(){
install -D -m644 *.h "${pkgdir}/usr/include"
# Install all libraries
- cd "${srcdir}/MUMPS_${pkgver}/lib" || return 1
- install -m 755 -d "${pkgdir}/usr/lib" || return 1
- install -D -m644 lib* ${pkgdir}/usr/lib || return 1
+ cd "${srcdir}/MUMPS_${pkgver}/lib"
+ install -m 755 -d "${pkgdir}/usr/lib"
+ install -D -m644 lib* ${pkgdir}/usr/lib
# Install libraries mpiseq
cd "${srcdir}/MUMPS_${pkgver}/libseq"
@@ -57,9 +68,8 @@ package(){
install -m 755 -d "${pkgdir}/usr/share/doc/${pkgname}/examples"
cd "${srcdir}/MUMPS_${pkgver}/examples"
install -m 644 * "${pkgdir}/usr/share/doc/${pkgname}/examples"
- #for _FILE in ssimpletest dsimpletest csimpletest zsimpletest c_example; do
- # chmod 0755 "${pkgdir}/usr/share/doc/${pkgname}/examples/${_FILE}"
- #done
+ install -m 644 "${srcdir}/MUMPS_${pkgver}/Makefile.inc" "${pkgdir}/usr/share/doc/${pkgname}/examples"
+ sed -i 's_\(topdir =\).*_\1 /usr_g; s-.*\(Makefile.inc\)-include Makefile.inc-g' "${pkgdir}/usr/share/doc/${pkgname}/examples/Makefile"
# Install license
install -D -m644 "${srcdir}/MUMPS_${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"