summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRhinoceros2015-06-09 09:13:31 +1000
committerRhinoceros2015-06-09 09:13:31 +1000
commit1629d023dbb1d3e05268d55952d96067bc7a600b (patch)
tree9170e3a1c13373b14257e7b6149ad1a64cda4823
downloadaur-1629d023dbb1d3e05268d55952d96067bc7a600b.tar.gz
Initial commit of git version, dev branch
* Based on vim-vimwiki-git, by Andreas Wagner <AndreasBWagner@pointfree.net>
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD43
-rw-r--r--license.txt22
-rw-r--r--vimdoc.install19
4 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2fc90cf7f23f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = vim-vimwiki-dev-git
+ pkgdesc = Personal Wiki for Vim; dev branch.
+ pkgver = v2.1.166.g9949465
+ pkgrel = 1
+ url = http://code.google.com/p/vimwiki/
+ install = vimdoc.install
+ arch = any
+ groups = vim-plugins
+ license = MIT
+ makedepends = git
+ depends = vim
+ provides = vim-vimwiki
+ conflicts = vim-vimwiki
+ source = git+https://github.com/vimwiki/vimwiki.git#branch=dev
+ source = license.txt
+ md5sums = SKIP
+ md5sums = e19fa0689d06a724fc8ddfe824ef2680
+
+pkgname = vim-vimwiki-dev-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77c095bdda00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
+# Contributor: Andreas Wagner <AndreasBWagner@pointfree.net>
+
+pkgname=vim-vimwiki-dev-git
+pkgver=v2.1.166.g9949465
+pkgrel=1
+pkgdesc="Personal Wiki for Vim; dev branch."
+arch=('any')
+url="http://code.google.com/p/vimwiki/"
+license=('MIT')
+groups=('vim-plugins')
+depends=('vim')
+makedepends=('git')
+conflicts=('vim-vimwiki')
+provides=('vim-vimwiki')
+install=vimdoc.install
+source=('git+https://github.com/vimwiki/vimwiki.git#branch=dev' license.txt)
+md5sums=('SKIP' 'e19fa0689d06a724fc8ddfe824ef2680')
+
+pkgver() {
+ cd "$srcdir/vimwiki"
+ local ver="$(git describe --long --tags)"
+ printf "%s" "${ver//-/.}"
+}
+
+package() {
+ cd "$srcdir/vimwiki"
+ install -d ${pkgdir}/usr/share/vim/vimfiles/autoload/vimwiki
+ install -m644 ${srcdir}/vimwiki/autoload/vimwiki/* \
+ ${pkgdir}/usr/share/vim/vimfiles/autoload/vimwiki/
+ install -d ${pkgdir}/usr/share/vim/vimfiles/{ftplugin,plugin,syntax}
+ for x in {ftplugin,plugin,syntax}; do
+ install -m644 ${srcdir}/vimwiki/$x/* \
+ ${pkgdir}/usr/share/vim/vimfiles/$x/
+ done
+ install -Dm644 ${srcdir}/license.txt \
+ ${pkgdir}/usr/share/licenses/${pkgname}/license.txt
+ install -d ${pkgdir}/usr/share/vim/vimfiles/doc
+ install -m644 ${srcdir}/vimwiki/doc/vimwiki.txt \
+ ${pkgdir}/usr/share/vim/vimfiles/doc/
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/license.txt b/license.txt
new file mode 100644
index 000000000000..a2784c730add
--- /dev/null
+++ b/license.txt
@@ -0,0 +1,22 @@
+The MIT Licence
+http://www.opensource.org/licenses/mit-license.php
+
+Copyright (c) 2009 Maxim Kim
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100644
index 000000000000..220693cc8af7
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,19 @@
+post_install() {
+ echo -n "Updating vim help tags..."
+ /usr/bin/vim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install
+}
+
+op=$1
+shift
+
+$op $*