summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhil Schaf2015-06-08 20:08:37 +0200
committerPhil Schaf2015-06-08 20:08:37 +0200
commit163d1e11cf0b6821b10dae08b7be168691f5e5ff (patch)
treee56bba19fc0291f812a7036266fd3da407b8e484
downloadaur-163d1e11cf0b6821b10dae08b7be168691f5e5ff.tar.gz
aur4 migration
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6abca07486c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-graph
+ pkgdesc = python-graph is a library for working graphs in Python
+ pkgver = 1.8.2
+ pkgrel = 3
+ url = https://github.com/pmatiello/python-graph
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-distribute
+ depends = python-pydot
+ source = https://pypi.python.org/packages/source/p/python-graph-core/python-graph-core-1.8.2.tar.gz
+ source = https://pypi.python.org/packages/source/p/python-graph-dot/python-graph-dot-1.8.2.tar.gz
+ md5sums = 16f177496beb6e6bc507b12b8346ff96
+ md5sums = 0ecd251a9fd210a9135e1d1957689709
+
+pkgname = python-graph
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0f411e099df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Phil Schaf <flying-sheep@web.de>
+pkgname=python-graph
+pkgver=1.8.2
+pkgrel=3
+pkgdesc='python-graph is a library for working graphs in Python'
+arch=('any')
+url='https://github.com/pmatiello/python-graph'
+license=('MIT')
+depends=('python' 'python-distribute' 'python-pydot')
+source=(
+ "https://pypi.python.org/packages/source/p/python-graph-core/python-graph-core-$pkgver.tar.gz"
+ "https://pypi.python.org/packages/source/p/python-graph-dot/python-graph-dot-$pkgver.tar.gz")
+md5sums=(
+ '16f177496beb6e6bc507b12b8346ff96'
+ '0ecd251a9fd210a9135e1d1957689709')
+
+package() {
+ cd "$srcdir/python-graph-core-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+ cd "$srcdir/python-graph-dot-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+} \ No newline at end of file