summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcel Campello Ferreira2014-01-13 11:10:57 -0200
committerMarcel Campello Ferreira2014-01-13 11:10:57 -0200
commit16677849da56abdae8fafd963c449b93f6124d61 (patch)
treec521beb1c7f18f4434e159f5f6067d61099b982d
parent36ffc99959483d57048ff4a6c3abab06604a7c97 (diff)
downloadaur-16677849da56abdae8fafd963c449b93f6124d61.tar.gz
Version 2.0.0-2.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
-rw-r--r--neo4j-tmpfile.conf1
-rw-r--r--neo4j.install3
-rw-r--r--neo4j.service3
5 files changed, 18 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c69876f5073..7bcd21efbc8c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = neo4j
pkgdesc = A fully transactional graph database implemented in Java
pkgver = 2.0.0
- pkgrel = 1
+ pkgrel = 2
url = http://neo4j.org/
install = neo4j.install
arch = any
@@ -21,11 +21,13 @@ pkgbase = neo4j
source = conf.patch
source = neo4j.install
source = neo4j.service
+ source = neo4j-tmpfile.conf
sha256sums = 44a7160ead5cf70a385cceed30f7e999e29047b39ca92ac346bd230e2767f2ff
sha256sums = 3b7dfe7448e82a7be4dfa31d1d30aa3921a483c6a33926800664af3bef25e3d2
sha256sums = d230ccb4d2ddd7bc504d729c50170c39acc8f16815168f99b82f4d7fdd07b094
- sha256sums = 2885511c87bd9594ffb81715fe4b9163c1f895c43206bc6f06048deca26d0de5
- sha256sums = 9a02869e8e974e6bb2003b920a43652605c0e7431f54b59a16fc566bc1833497
+ sha256sums = 6af4ac963343f8d88c2a10361391eea113737a2383eed3fbba26c89e548d4d66
+ sha256sums = 27e044354f10cb4c844b827442850326d900bc40e01443dbc0cd446bd057af27
+ sha256sums = e9ecbf86072ca92129ab1889b5f91e2494b86e84248bd15a37681a3997892d7d
pkgname = neo4j
diff --git a/PKGBUILD b/PKGBUILD
index e39b648e2322..8f37d72f50cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Marcel Campello Ferreira <tucho.tijucano@gmail.com>
pkgname=neo4j
pkgver=2.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="A fully transactional graph database implemented in Java"
arch=(any)
url="http://neo4j.org/"
@@ -19,12 +19,14 @@ source=(http://dist.neo4j.org/neo4j-community-$pkgver-unix.tar.gz
bin.patch
conf.patch
neo4j.install
- neo4j.service)
+ neo4j.service
+ neo4j-tmpfile.conf)
sha256sums=(44a7160ead5cf70a385cceed30f7e999e29047b39ca92ac346bd230e2767f2ff
3b7dfe7448e82a7be4dfa31d1d30aa3921a483c6a33926800664af3bef25e3d2
d230ccb4d2ddd7bc504d729c50170c39acc8f16815168f99b82f4d7fdd07b094
- 2885511c87bd9594ffb81715fe4b9163c1f895c43206bc6f06048deca26d0de5
- 9a02869e8e974e6bb2003b920a43652605c0e7431f54b59a16fc566bc1833497)
+ 6af4ac963343f8d88c2a10361391eea113737a2383eed3fbba26c89e548d4d66
+ 27e044354f10cb4c844b827442850326d900bc40e01443dbc0cd446bd057af27
+ e9ecbf86072ca92129ab1889b5f91e2494b86e84248bd15a37681a3997892d7d)
prepare() {
@@ -80,5 +82,5 @@ package() {
install -Dm644 neo4j.service $pkgdir/usr/lib/systemd/system/neo4j.service
# Runtime files
- install -dm755 $pkgdir/run/neo4j
+ install -Dm644 neo4j-tmpfile.conf $pkgdir/usr/lib/tmpfiles.d/neo4j.conf
}
diff --git a/neo4j-tmpfile.conf b/neo4j-tmpfile.conf
new file mode 100644
index 000000000000..2730682b2d70
--- /dev/null
+++ b/neo4j-tmpfile.conf
@@ -0,0 +1 @@
+d /run/neo4j 0755 neo4j neo4j - \ No newline at end of file
diff --git a/neo4j.install b/neo4j.install
index a035c1724d8b..fbe06d3eb0a4 100644
--- a/neo4j.install
+++ b/neo4j.install
@@ -9,7 +9,8 @@
chown -R neo4j.neo4j /var/lib/neo4j
chown -R neo4j.neo4j /var/log/neo4j
chown -R neo4j.neo4j /etc/neo4j
- chown -R neo4j.neo4j /run/neo4j
+
+ /usr/bin/systemd-tmpfiles --create neo4j.conf
}
post_upgrade() {
diff --git a/neo4j.service b/neo4j.service
index 5b1092a6a64b..f2f9617d49ac 100644
--- a/neo4j.service
+++ b/neo4j.service
@@ -7,3 +7,6 @@ Type=forking
ExecStart=/usr/bin/neo4j start
ExecStop=/usr/bin/neo4j stop
PIDFile=/run/neo4j/neo4j-service.pid
+
+[Install]
+WantedBy=multi-user.target