summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12018-06-22 18:00:21 +0800
committerChocobo12018-06-22 18:09:14 +0800
commit1671403453b8d5666ce47b11d559701423026af9 (patch)
tree6984e99e86c46e6ffe83506f81ec75c3785c9da6
downloadaur-1671403453b8d5666ce47b11d559701423026af9.tar.gz
newpkg: sbsigntools-git 0.9.1.r0.ga631793-1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD42
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6173ba4256da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = sbsigntools-git
+ pkgdesc = Signing utility for UEFI secure boot
+ pkgver = 0.9.1.r0.ga631793
+ pkgrel = 1
+ url = https://git.kernel.org/pub/scm/linux/kernel/git/jejb/sbsigntools.git
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = gnu-efi-libs
+ makedepends = help2man
+ depends = glibc
+ depends = libutil-linux
+ depends = openssl
+ provides = sbsigntools
+ conflicts = sbsigntools
+ source = git+https://git.kernel.org/pub/scm/linux/kernel/git/jejb/sbsigntools.git
+ sha256sums = SKIP
+
+pkgname = sbsigntools-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1806161e0ca2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=sbsigntools-git
+pkgver=0.9.1.r0.ga631793
+pkgrel=1
+pkgdesc="Signing utility for UEFI secure boot"
+arch=('i686' 'x86_64')
+url="https://git.kernel.org/pub/scm/linux/kernel/git/jejb/sbsigntools.git"
+license=('GPL3')
+depends=('glibc' 'libutil-linux' 'openssl')
+makedepends=('git' 'gnu-efi-libs' 'help2man')
+provides=('sbsigntools')
+conflicts=('sbsigntools')
+source=("git+https://git.kernel.org/pub/scm/linux/kernel/git/jejb/sbsigntools.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "sbsigntools"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "sbsigntools"
+
+ ./autogen.sh
+ ./configure --prefix="/usr"
+ make
+}
+
+check() {
+ cd "sbsigntools"
+
+ make check
+}
+
+package() {
+ cd "sbsigntools"
+
+ make DESTDIR="$pkgdir" install
+}