summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Anastasio2021-04-06 14:41:02 +0200
committerLuca Anastasio2021-04-06 14:41:02 +0200
commit1675da4881c415a2bce3ebffd71d82d18d66efb0 (patch)
tree2017640d866773ae52eddca58eff0494df84a966
downloadaur-1675da4881c415a2bce3ebffd71d82d18d66efb0.tar.gz
Remote.it desktop application, first commit
-rw-r--r--.SRCINFO54
-rw-r--r--.gitignore11
-rw-r--r--PKGBUILD23
-rw-r--r--remoteit-desktop-bin.install25
4 files changed, 113 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa89171ee059
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,54 @@
+pkgbase = remoteit-desktop-bin
+ pkgdesc = Remote.it cross platform desktop application for creating and hosting connections
+ pkgver = 3.0.2
+ pkgrel = 1
+ url = https://remote.it/
+ install = remoteit-desktop-bin.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = alsa-lib
+ depends = atk
+ depends = at-spi2-atk
+ depends = at-spi2-core
+ depends = cairo
+ depends = dbus
+ depends = desktop-file-utils
+ depends = discord
+ depends = expat
+ depends = gcc-libs
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = glibc
+ depends = gtk3
+ depends = hicolor-icon-theme
+ depends = libappindicator-gtk3
+ depends = libcups
+ depends = libdrm
+ depends = libnotify
+ depends = libsecret
+ depends = libx11
+ depends = libxcb
+ depends = libxcomposite
+ depends = libxdamage
+ depends = libxext
+ depends = libxfixes
+ depends = libxkbcommon
+ depends = libxrandr
+ depends = libxss
+ depends = libxtst
+ depends = mesa
+ depends = nspr
+ depends = nss
+ depends = pango
+ depends = util-linux-libs
+ depends = xdg-utils
+ conflicts = remoteit
+ conflicts = remoteit-desktop
+ options = !strip
+ options = !emptydirs
+ source = https://downloads.remote.it/desktop/v3.0.2/remoteit-amd64-installer.deb
+ md5sums = e2fbaa1a9362853825309e5034889476
+
+pkgname = remoteit-desktop-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f872d06f031a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,11 @@
+*.tar
+*.tar.*
+*.deb
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c8047aad951
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Luca Anastasio <anastasio dot lu at gmail dot com>
+pkgname=remoteit-desktop-bin
+pkgver=3.0.2
+pkgrel=1
+pkgdesc="Remote.it cross platform desktop application for creating and hosting connections"
+url="https://remote.it/"
+arch=('i686' 'x86_64')
+license=('custom')
+depends=('alsa-lib' 'atk' 'at-spi2-atk' 'at-spi2-core' 'cairo' 'dbus' 'desktop-file-utils' 'discord' 'expat' 'gcc-libs' 'gdk-pixbuf2' 'glib2' 'glibc' 'gtk3' 'hicolor-icon-theme' 'libappindicator-gtk3' 'libcups' 'libdrm' 'libnotify' 'libsecret' 'libx11' 'libxcb' 'libxcomposite' 'libxdamage' 'libxext' 'libxfixes' 'libxkbcommon' 'libxrandr' 'libxss' 'libxtst' 'mesa' 'nspr' 'nss' 'pango' 'util-linux-libs' 'xdg-utils')
+optdepends=()
+makedepends=()
+conflicts=('remoteit' 'remoteit-desktop')
+replaces=()
+backup=()
+options=('!strip' '!emptydirs')
+install=${pkgname}.install
+source=("https://downloads.remote.it/desktop/v${pkgver}/remoteit-amd64-installer.deb")
+md5sums=('e2fbaa1a9362853825309e5034889476')
+
+package() {
+ tar xf data.tar.xz -C "${pkgdir}"
+ install -D -m644 "/opt/remoteit/LICENSES.chromium.html" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/remoteit-desktop-bin.install b/remoteit-desktop-bin.install
new file mode 100644
index 000000000000..59845c46de04
--- /dev/null
+++ b/remoteit-desktop-bin.install
@@ -0,0 +1,25 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ # Link to the binary
+ ln -sf '/opt/remoteit/remoteit' '/usr/bin/remoteit'
+
+ # SUID chrome-sandbox for Electron 5+
+ chmod 4755 '/opt/remoteit/chrome-sandbox' || true
+
+ update-mime-database /usr/share/mime || true
+ update-desktop-database /usr/share/applications || true
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ # Delete the link to the binary
+ rm -f '/usr/bin/remoteit'
+ update-desktop-database -q
+}