summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorskydrome2015-06-01 15:26:15 -0400
committerskydrome2015-06-01 15:26:15 -0400
commit167c5caec1c56c6f64b6b95eb0cdcd005cfc80a3 (patch)
tree2980ed2e1b09323c27f665473dc5b80210ed094f
downloadaur-167c5caec1c56c6f64b6b95eb0cdcd005cfc80a3.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD41
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4cc20c598756
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = rtmpdump-git
+ pkgdesc = A tool to download rtmp and rtmpe streams
+ pkgver = 0.499.a107cef
+ pkgrel = 1
+ url = http://rtmpdump.mplayerhq.hu/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ license = LGPL2.1
+ makedepends = git
+ depends = openssl
+ provides = rtmpdump
+ conflicts = rtmpdump
+ source = git+git://git.ffmpeg.org/rtmpdump
+ md5sums = SKIP
+
+pkgname = rtmpdump-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..798ff55918e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Christopher Rosell <chrippa@gmail.com>
+# Contributor: Army
+# Contributor: tomegun
+
+pkgname=rtmpdump-git
+pkgver=0.499.a107cef
+pkgrel=1
+pkgdesc="A tool to download rtmp and rtmpe streams"
+url="http://rtmpdump.mplayerhq.hu/"
+arch=('i686' 'x86_64')
+license=('GPL2' 'LGPL2.1')
+depends=('openssl')
+makedepends=('git')
+provides=('rtmpdump')
+conflicts=('rtmpdump')
+source=("git+git://git.ffmpeg.org/rtmpdump")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/rtmpdump"
+ echo "0.$(git rev-list --count HEAD).$(git describe --always)"
+}
+
+build() {
+ cd "$srcdir/rtmpdump"
+ make OPT="$CFLAGS" XLDFLAGS="$LDFLAGS"
+}
+
+package() {
+ cd "$srcdir/rtmpdump"
+
+ install -dm755 "$pkgdir/usr/lib"
+
+ make prefix=/usr \
+ sbindir=/usr/bin \
+ mandir=/usr/share/man \
+ DESTDIR="$pkgdir" \
+ install
+}
+
+# vim:set ts=2 sw=2 et: