summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpatrick962022-03-01 19:43:27 +0100
committerpatrick962022-03-01 19:43:27 +0100
commit167c787eac67d7940ece922ad9eadc6cce7aedf4 (patch)
treecf527bea2092e65793085e040b0f24590a45b106
parentb90c9f7763a406095b246d8933037560778a21df (diff)
downloadaur-167c787eac67d7940ece922ad9eadc6cce7aedf4.tar.gz
Release 3.6.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
-rw-r--r--polybar.install26
3 files changed, 13 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5bbece44cf68..5ba75b762a92 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = polybar
pkgdesc = A fast and easy-to-use status bar
- pkgver = 3.5.7
- pkgrel = 2
+ pkgver = 3.6.0
+ pkgrel = 1
url = https://github.com/polybar/polybar
- install = polybar.install
arch = i686
arch = x86_64
arch = aarch64
@@ -14,6 +13,7 @@ pkgbase = polybar
makedepends = python-sphinx
makedepends = python-packaging
makedepends = i3-wm
+ depends = libuv
depends = cairo
depends = xcb-util-image
depends = xcb-util-wm
@@ -26,11 +26,8 @@ pkgbase = polybar
depends = jsoncpp
depends = curl
optdepends = i3-wm: i3 module support
- optdepends = ttf-unifont: Font used in example config
- optdepends = siji-git: Font used in example config
- optdepends = xorg-fonts-misc: Font used in example config
conflicts = polybar-git
- source = https://github.com/polybar/polybar/releases/download/3.5.7/polybar-3.5.7.tar.gz
- sha256sums = 73210e6d74217acb953b253990b4302343b7b6a7870fe1da9a1855daa44123db
+ source = https://github.com/polybar/polybar/releases/download/3.6.0/polybar-3.6.0.tar.gz
+ sha256sums = 563473d5ae2b83d4dba6372f85cbcfd8d5a271b4cf3345ff57acff9c81e1b065
pkgname = polybar
diff --git a/PKGBUILD b/PKGBUILD
index 8b154d5bded5..cf3fe79478bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,20 @@
# Maintainer: Patrick Ziegler <p.ziegler96@gmail.com>
pkgname=polybar
-pkgver=3.5.7
-pkgrel=2
+pkgver=3.6.0
+pkgrel=1
pkgdesc="A fast and easy-to-use status bar"
+# aarch64 is not officially supported by polybar, it is only listed here for convenience
arch=("i686" "x86_64" "aarch64")
url="https://github.com/polybar/polybar"
license=("MIT")
-depends=("cairo" "xcb-util-image" "xcb-util-wm" "xcb-util-xrm" "xcb-util-cursor"
- "alsa-lib" "libpulse" "libmpdclient" "libnl" "jsoncpp" "curl")
-optdepends=("i3-wm: i3 module support"
- "ttf-unifont: Font used in example config"
- "siji-git: Font used in example config"
- "xorg-fonts-misc: Font used in example config")
+depends=("libuv" "cairo" "xcb-util-image" "xcb-util-wm" "xcb-util-xrm"
+ "xcb-util-cursor" "alsa-lib" "libpulse" "libmpdclient" "libnl"
+ "jsoncpp" "curl")
+optdepends=("i3-wm: i3 module support")
makedepends=("cmake" "python" "pkg-config" "python-sphinx" "python-packaging" "i3-wm")
conflicts=("polybar-git")
-install="${pkgname}.install"
source=(${url}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz)
-sha256sums=('73210e6d74217acb953b253990b4302343b7b6a7870fe1da9a1855daa44123db')
+sha256sums=('563473d5ae2b83d4dba6372f85cbcfd8d5a271b4cf3345ff57acff9c81e1b065')
_dir="${pkgname}-${pkgver}"
prepare() {
diff --git a/polybar.install b/polybar.install
deleted file mode 100644
index 25ac794f102d..000000000000
--- a/polybar.install
+++ /dev/null
@@ -1,26 +0,0 @@
-post_install() {
- cat << EOF
-
- Get started with the example configuration:
-
- $ install -Dm644 /usr/share/doc/polybar/config \$HOME/.config/polybar/config
- $ polybar example
-
- For more information, see https://github.com/polybar/polybar/wiki
-
-EOF
-}
-
-post_upgrade() {
- [ "$(vercmp "$2" "2.5.1-1")" = "-1" ] || exit 0
- cat << EOF
-
- The % suffix has been removed from percentage tokens.
- The suffix is instead added by the user, for example:
-
- format-charging = Capacity %percentage%%
-
- -- jaagr
-
-EOF
-}