summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfreijon2017-03-08 23:01:20 +0100
committerfreijon2017-03-08 23:02:54 +0100
commit16971a4bf4ba3179af29a2e3a2e4e94da7120599 (patch)
tree804583eb0c462a7f4dcad5e6a45ebb6aa8d6de22
parent1285a29d43289ddce402e05c6d5fb7d43d1d98be (diff)
downloadaur-16971a4bf4ba3179af29a2e3a2e4e94da7120599.tar.gz
Implemented a workaround for the issue that Arch wasn't considered a distribution
-rw-r--r--PKGBUILD2
-rw-r--r--arch_cover.patch26
2 files changed, 24 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8922dcf46df3..823be54eafeb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,7 +32,7 @@ source=(
sha256sums=(
'SKIP'
'8e05d76654424b51f47dee6962d618d1ad6514fa29affc17dfcf764cc955bd23'
- 'ce8f1651d3da51a6d336190b0f64b3f0d931a3ee6a338ce07033d9d9ba66157b'
+ '2a02b1a1b63f134d1b37d60d31d738efb787e08bf029ac1734f16ac9caea3c15'
'cd8a0dde2b1ac32fdcedb28c87cca3a4d956a4e4fee8ec41f8211c41d43e5e95'
)
diff --git a/arch_cover.patch b/arch_cover.patch
index 590e2e71c54a..4675fba5bd60 100644
--- a/arch_cover.patch
+++ b/arch_cover.patch
@@ -1,8 +1,28 @@
-*** covermodes_orig.py 2017-03-08 21:02:31.348718017 +0100
---- pulseaudio_dlna/covermodes.py 2017-03-08 20:59:27.636324915 +0100
+*** covermodes_orig.py 2017-03-08 22:56:08.019483965 +0100
+--- pulseaudio_dlna/covermodes.py 2017-03-08 22:54:30.813287898 +0100
+***************
+*** 92,99 ****
+
+ @property
+ def thumb(self):
+! dist_name, dist_ver, dist_arch = platform.linux_distribution()
+ logger.debug(dist_name)
+ if dist_name == 'Ubuntu':
+ dist_icon = 'ubuntu'
+ elif dist_name == 'debian':
+--- 92,100 ----
+
+ @property
+ def thumb(self):
+! dist_name, dist_ver, dist_arch = platform.linux_distribution(supported_dists=platform._supported_dists + ('arch',))
+ logger.debug(dist_name)
++ print('THE PLATFORM IS:' + dist_name)
+ if dist_name == 'Ubuntu':
+ dist_icon = 'ubuntu'
+ elif dist_name == 'debian':
***************
*** 106,111 ****
---- 106,113 ----
+--- 107,114 ----
dist_icon = 'opensuse'
elif dist_name == 'gentoo':
dist_icon = 'gentoo'